Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 121443 - catalyst2 umount
Summary: catalyst2 umount
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: Catalyst (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Catalyst Developers
Depends on:
Reported: 2006-02-03 08:16 UTC by Goran Mekić
Modified: 2008-11-09 10:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Output of catalyst2 + some commands (catalyst.txt,3.49 KB, text/plain)
2006-02-08 07:13 UTC, Goran Mekić

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2006-02-03 08:16:37 UTC
Catalyst2 tries to cleanup chrooted /tmp/*, and doesn't umount /tmp/kerncache, /usr/portage/packages and /usr/portage. I don't know anything about python programming, but I'm sure this is whare the error is (I see that those dirs are mounted after catalyst2 stops, and trying to do rm -R <path_to_catalyst_stage>/tmp, says the same "Device or resource busy". Btw, after sucessuful build of stage1, stage2 stops with this error.
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2006-02-08 06:38:20 UTC
Can you please post the actual output?
Comment 2 Goran Mekić 2006-02-08 07:13:52 UTC
Created attachment 79232 [details]
Output of catalyst2 + some commands
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2006-02-08 07:52:19 UTC
Try clearing your autoresume points...
Comment 4 Goran Mekić 2006-02-12 17:27:10 UTC
Only thing that happend is that whole process was started again. As my /tmp and /var/tmp in chroot are clean, I suppose that cleaning is not putting .autoresume-<whatever-stage>/clean file. This is just my wild guess, as a person without any knowledge about python.
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2006-04-19 08:30:01 UTC
I'm going to assume that this wasn't magically fixed by a newer catalyst release, right?
Comment 6 Goran Mekic 2006-04-19 10:54:44 UTC
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2006-04-19 12:55:19 UTC
Any chance you can use something like lsof to find out exactly why the device is busy?
Comment 8 Goran Mekic 2006-04-19 13:54:47 UTC
It's not busy when catalyst finish his work. I can simply umount those mount mounts (tmp/kerncache, usr/portage, usr/portage/packages, all in /var/tmp/catalyst2/tmp/default/stageN). While catalyst is working, it is logical that those mount points are busy. So, I lsof can't give us any hint here.
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2006-05-23 13:03:14 UTC
OK.  Perhaps you missed my meaning.  You need to add an lsof call to catalyst, so you can see what is blocking, not after it has completed.
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2006-06-28 06:11:46 UTC
Please reopen after performing the requested actions.  I cannot duplicate this, so without more information, there isn't anything that I can do.
Comment 11 bob5972 2008-11-09 05:09:54 UTC
I get the same problem.

The only thing in the chrooted /tmp is /tmp/kerncache, which has /var/tmp/catalyst/kerncache/default/livecd-stage2-x86-1 mounted on it.

It's trying to delete everything in /tmp without unmounting kerncache first.

If you take /tmp out of livecd/empty then it blocks on the chrooted /usr/portage the same way since /usr/portage/distfiles is mounted on there.
It also clears out all your distfiles (from the hosts /usr/portage/distfiles) before being unable to delete the folder in the chroot /usr/portage/distfiles where its mounted.
Comment 12 bob5972 2008-11-09 10:27:59 UTC
Ok, so I had /var/tmp/catalyst as a symlink to /root/catalyst which seemed to be causing some of my problems.  So I got rid of the symlink and moved it back to /var/tmp/catalyst but I keep getting the same error.

To make things weirder, now I can't delete the folders after it's finished running.

Catalyst says:

Cleaning chroot: /usr/portage... 
rm: cannot remove directory `/var/tmp/catalyst/tmp/default/livecd-stage1-x86-1//usr/portage/distfiles': Device or resource busy
rm: cannot remove directory `/var/tmp/catalyst/tmp/default/livecd-stage1-x86-1//usr/portage/packages': Device or resource busy

!!! catalyst: Couldn't clean /usr/portage

!!! catalyst: Error encountered during run of target livecd-stage1

Catalyst aborting....

And then afterwards I try to manually delete the folders and get the same error.

But what's really weird, is that they don't show up on mount.

mount says:

/dev/hda3 on / type reiserfs (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,gid=5,mode=620)
none on /dev/shm type tmpfs (rw,noexec,nosuid,nodev)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
nfsd on /proc/fs/nfs type nfsd (rw,noexec,nosuid,nodev)

But if I cat /proc/mounts I get:

Serenity:~# cat /proc/mounts 
rootfs / rootfs rw 0 0
/dev/root / reiserfs rw,noatime 0 0
proc /proc proc rw,nosuid,nodev,noexec 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec 0 0
udev /dev tmpfs rw,nosuid,size=10240k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,gid=5,mode=620 0 0
/dev/hdb3 /home/bob5972 reiserfs rw,noatime 0 0
none /dev/shm tmpfs rw,nosuid,nodev,noexec 0 0
usbfs /proc/bus/usb usbfs rw,nosuid,noexec,devgid=85,devmode=664 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec 0 0
nfsd /proc/fs/nfs nfsd rw,nosuid,nodev,noexec 0 0
/dev/root /var/tmp/catalyst/tmp/default/livecd-stage1-x86-1/usr/portage reiserfs rw,noatime 0 0
/dev/root /var/tmp/catalyst/tmp/default/livecd-stage1-x86-1/usr/portage/distfiles reiserfs rw,noatime 0 0
/dev/root /var/tmp/catalyst/tmp/default/livecd-stage1-x86-1/usr/portage/packages reiserfs rw,noatime 0 0

So I dunno what's going on anymore, but I can't rm them and I can't umount them.