Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 120550 - nant-0.85_rc3-r1 ebuild fails with SIGILL
Summary: nant-0.85_rc3-r1 ebuild fails with SIGILL
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-27 10:06 UTC by Santiago Gala
Modified: 2006-12-10 01:15 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Santiago Gala 2006-01-27 10:06:33 UTC
(...)
BUILD FAILED

/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/NAnt.build(93,10):
AssemblyInfo file '/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/src/CommonAssemblyInfo.cs' could not be generated.
    An exception was thrown by the type initializer for System.Runtime.Remoting.Lifetime.LifetimeServices
        SIGILL

Total time: 2.3 seconds.

make: *** [build-nant] Error 1
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2006-01-28 19:07:23 UTC
Can you please report your "emerge info" output, as well as the version of mono you are using, and any other relevant information? Thanks.
Comment 2 ziegs 2006-02-01 12:37:54 UTC
i can post my output later, it won't compile here either, but strangely nant-0.85_rc3 merges just fine, so a temporary workaround is to just emerge =nant-0.85_rc3 instead...monodev and boo build against it just fine.
Comment 3 ziegs 2006-02-01 12:40:42 UTC
i lied, boo won't build against rc3, and i don't know if it builds againts rc3-r1.  anywhere here is my version info

fenrir ziegs # mono --version
Mono JIT compiler version 1.1.12.1, (C) 2002-2005 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV      : normal
fenrir ziegs # mcs --version
Mono C# compiler version 1.1.12.1
fenrir ziegs # gmcs --version
Mono C# compiler version 1.1.12.1


and my emerge info:

Portage 2.0.51.22-r2 (default-linux/ppc/2006.0/ppc32/G4, gcc-3.4.5, glibc-2.3.6-r2, 2.6.15-gentoo-r1 ppc)
=================================================================
System uname: 2.6.15-gentoo-r1 ppc 7447/7457, altivec supported
Gentoo Base System version 1.12.0_pre15
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mtune=powerpc -pipe -mcpu=7450 -maltivec -mabi=altivec -fsigned-char"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -mtune=powerpc -pipe -mcpu=7450 -maltivec -mabi=altivec -fsigned-char"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ ftp://linux.cs.lewisu.edu/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="ppc X aac alsa altivec apache2 apm arts audiofile bash-completion berkdb bitmap-fonts boo bzip2 cairo cdr chm crypt cscope cups dbus doc dri dvd dvdread eds emboss encode esd exif expat fam fame ffmpeg firefox flac foomaticdb fortran gdbm gif glitz glut gnome gpm gstreamer gtk gtk2 gtkhtml hal howl idn ieee1394 imagemagick imlib ipv6 jpeg lcms libg++ libwww mad mikmod mng mono motif mp3 mpeg ncurses network nls nptl ogg oggvorbis openal opengl oss pam pcre pdf pdflib perl pic png python quicktime readline ruby samba sdl spell sqlite ssl svg tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis wv xml xml2 xmms xscreensaver xv xvid zlib video_cards_radeon userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 4 Santiago Gala 2006-02-02 11:51:59 UTC
my emerge info, FWIW, and mono --version

sgala@marlow ~/Desktop $ mono --version
Mono JIT compiler version 1.1.12.1, (C) 2002-2005 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV      : normal

sgala@marlow ~/Desktop $ emerge info
Portage 2.1_pre4-r1 (default-linux/ppc/2006.0/ppc32/G4, gcc-3.4.5, glibc-2.3.6-r2, 2.6.15-gentoo-r1 ppc)
=================================================================
System uname: 2.6.15-gentoo-r1 ppc 7455, altivec supported
Gentoo Base System version 1.12.0_pre15
dev-lang/python:     2.2.3-r6, 2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://mirror.usu.edu/mirrors/gentoo/ http://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.inode.at/ http://trumpetti.atm.tut.fi/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp.heanet.ie/pub/gentoo/ http://ftp.easynet.nl/mirror/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://linuv.uv.es/mirror/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://ibiblio.org/pub/Linux/MIRRORS.html "
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LINGUAS="es_ES es en_US en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X aac accessibility alsa altivec apache2 apm arts berkdb bitmap-fonts bluetooth cairo cjk crypt cups dbus dv dvd dvdr dvdread eds emacs emboss encode esd fbcon firefox foomaticdb fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal howl icq imlib insecure-savers ipv6 jabber java jpeg jython kde lcms libg++ libwww mad mikmod mono motif mozcalendar mozsvg mp3 mpeg ncurses nls nptl ogg opengl pam pcmcia pcre pdflib perl pic png pnp python qt quicktime readline sasl sdl spell ssl svg tcpd threads truetype truetype-fonts type1-fonts udev unicode usb v4l v4l2 vorbis xinerama xml xml2 xmms xosd xv xvid yahoo zeroconf zlib elibc_glibc kernel_linux linguas_es_ES linguas_es linguas_en_US linguas_en_GB userland_GNU video_cards_radeon"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LDFLAGS
Comment 5 Laurent G. 2006-03-12 07:02:29 UTC
I have same problem but noticed something not related here :

>>> Unpacking nant-0.85-nightly-2005-12-13-src.tar.gz to /var/tmp/portage/nant-0.85_rc3-r1/work
tar: Un bloc z
Comment 6 Laurent G. 2006-03-12 07:02:29 UTC
I have same problem but noticed something not related here :

>>> Unpacking nant-0.85-nightly-2005-12-13-src.tar.gz to /var/tmp/portage/nant-0.85_rc3-r1/work
tar: Un bloc zéro solitaire repéré à 21914
>>> Source unpacked.

I hope it may help.

(In reply to comment #0)
> (...)
> BUILD FAILED
> 
> /var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/NAnt.build(93,10):
> AssemblyInfo file
> '/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/src/CommonAssemblyInfo.cs'
> could not be generated.
>     An exception was thrown by the type initializer for
> System.Runtime.Remoting.Lifetime.LifetimeServices
>         SIGILL
> 
> Total time: 2.3 seconds.
> 
> make: *** [build-nant] Error 1
> 

Comment 7 Peter Johanson (RETIRED) gentoo-dev 2006-05-14 11:38:00 UTC
Is this still a problem with the recent mono-1.1.13.x releases?
Comment 8 Santiago Gala 2006-05-17 05:09:39 UTC
Yes, exactly the same error, SIGILL. I understand little to nothing about mono.

...
create-common-assemblyinfo:

   [attrib] Setting file attributes for 1 files to Normal.

BUILD FAILED

/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/NAnt.build(93,10):
AssemblyInfo file '/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/src/CommonAssemblyInfo.cs' could not be generated.
    An exception was thrown by the type initializer for System.Runtime.Remoting.Lifetime.LifetimeServices
        SIGILL

Total time: 2.2 seconds.

make: *** [build-nant] Error 1

!!! ERROR: dev-dotnet/nant-0.85_rc3-r1 failed.
Call stack:
  ebuild.sh, line 1527:   Called dyn_compile
  ebuild.sh, line 931:   Called src_compile
  nant-0.85_rc3-r1.ebuild, line 40:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 9 David Gurvich 2006-05-23 06:21:29 UTC
Same problem here on PPC with mono-1.1.13.6
Comment 10 Ed Catmur 2006-06-23 06:24:49 UTC
Repro here with mono 1.1.15.
Comment 11 Ed Catmur 2006-06-23 06:42:07 UTC
From http://nant.sourceforge.net/faq.html#building-mono-1 :

> How can I avoid getting a NullReferenceException when building NAnt on Mono?
> 
> There are currently some regressions in Mono CVS (bug #55996) with regards to > AppDomain unloading which cause a NullReferenceException when building NAnt.
> 
> Zoltan Varga implemented a workaround for this issue: set the environment 
> variable MONO_NO_UNLOAD to any value before running NAnt:
> 
> $ export MONO_NO_UNLOAD=1
> $ make clean
> $ make
> $ mono bin/NAnt.exe clean build
                     
SIGILL, SIGSEGV, whatever; this is PPC. Exporting MONO_NO_UNLOAD gets it to > build.
Comment 12 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-12-10 01:15:51 UTC
Added a fix into 0.85.  It should work now.  Thanks for your patience.