Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 120444 - prelude-manager reports: invalid section : "db"
Summary: prelude-manager reports: invalid section : "db"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-26 09:47 UTC by Robert Larson
Modified: 2006-02-02 11:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Larson 2006-01-26 09:47:44 UTC
Upon the execution of 'prelude-manager' I receive errors.  It does start but doesn't connect to MySQL (maybe I'm wrong and the problem is with libpreludedb?).

I am running (~x86):
prelude-manager-0.9.1-r1
libprelude-0.9.3
libpreludedb-0.9.2

# emerge --info
Portage 2.0.54 (default-linux/x86/2005.0, gcc-3.3.6, glibc-2.3.5-r2, 2.6.12-vs2.0-gentoo-r1 i686)
=================================================================
System uname: 2.6.12-vs2.0-gentoo-r1 i686 AMD Sempron(tm)   3000+
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=athlon-4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirrors.tds.net/gentoo http://mirror.datapipe.net/gentoo http://gentoo.netnitco.net http://www.gigaload.org/gentoo.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X Xaw3d a52 aalib acl acpi adns aim alsa apache2 apm arts audiofile avi berkdb bitmap-fonts browserplugin bzip2 cdda cddb cdio cdparanoia cdr crypt cscope cups curl dba dbm dga doc dvd dvdr dvdread eds emboss encode esd ethereal example exif expat fastcgi firebird flatfile foomatic foomaticdb fortran gd gdbm gif glut gmp gpm gstreamer gtk gtk2 idn imagemagick imlib inifile innodb ipv6 jabber jack java javascript jpeg kde kerberos ladcca lcms ldap libcaca libg++ libwww mad mhash mikmod mime mmx mng motif mozilla mp3 mpeg msn musicbrainz mysql mysqli ncurses nls nocd odbc ogg oggvorbis openal opengl osc oscar oss pam pcre pdflib perl php png posix postgres ppds prelude python qt quicktime readline samba sasl sdl session slang sndfile soap sox spell sse ssl svg sysvipc szip tcltk tcpd threads tidy tiff truetype truetype-fonts type1-fonts udev unicode usb vcd vorbis win32codecs xface xine xml xml2 xmms xv xvid yahoo zeo zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY


Here are the errors I receive:

/etc/prelude-manager/prelude-manager.conf:90: invalid section : "db".
/etc/prelude-manager/prelude-manager.conf:93: invalid option "type" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:96: invalid option "host" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:99: invalid option "port" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:102: invalid option "name" in 
"global" section at depth 0.
/etc/prelude-manager/prelude-manager.conf:108: invalid option "pass" in 
"global" section at depth 0.
- server started (listening on 0.0.0.0 port 4690).

**  It may be worth noting that I received more errors here due to the interpretation of "user" as the user I wanted to run the server as and not the user of the database.  The errors not included specified the files and directories the user didn't have access to.


Here is my configuration located in /etc/prelude-manager/prelude-manager.conf:
include = /etc/prelude/default/global.conf
listen = 0.0.0.0
[db]
type = mysql
host = localhost
port = 3306
name = prelude
user = prelude
pass = ...

The contents of the included global.conf are:
[prelude]

When I first set it up I just went through and uncommented the items above, and filled in the appropriate values.  I have not been able to replicate this on another machine (I haven't tried), but I was able to uninstall, remove all of the remaining protected directories, then reinstall and receive the same errors.  I was able to download and configure/make/install the sources without encountering any problems.

I was able to find this:
http://www.prelude-ids.org/pipermail/prelude-user/2005-April/000768.html

I also shot a message to prelude-user mailing list, but I haven't heard back.  Let me know if you need more info. ;)
Comment 1 Robert Larson 2006-02-02 11:44:07 UTC
I received a response from Yoann Vandoorselaere on the prelude-user list.  Here is what he said:

"This error usually happen if you setup Prelude-Manager before
libpreludedb, since the Prelude-Manager configure script will disable
the database plugin if libpreludedb cannot be found."

I reinstalled, installing libpreludedb first and it correctly registers the section "[db]".

...

Okay, I just now realized that this problem is a result of not using the "dbx" USE flag.  After checking the ebuild it makes sense.