Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 120401 - Need a fix for pegasos in genkernel-3.3.10
Summary: Need a fix for pegasos in genkernel-3.3.10
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: genkernel (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-26 03:55 UTC by Lars Weiler (RETIRED)
Modified: 2006-01-26 05:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Weiler (RETIRED) gentoo-dev 2006-01-26 03:55:15 UTC
The current stable genkernel-3.3.10 fails in gen_initramfs.sh, as it wants to copy the non-existant initramfs for the pegasos-kernel.

genkernel-3.3.11_pre3 contains a fix, which does an extra-check if a pegasos-kernel with --genzimage will be compiled.  I used the genkernel's pre-versions for test-builds, so I never saw that error before.

Either, upgrade genkernel in the 2006.0-snapshot or add the patch for copying the initramfs:

--- /usr/share/genkernel/gen_initramfs.sh       2006-01-08 11:58:44.000000000 +0100
+++ /opt/cvs/gentoo/src/genkernel_bradmssw/gen_initramfs.sh     2006-01-26 01:47:36.000000000 +0100
@@ -627,7 +627,10 @@
 
        if ! isTrue "${CMD_NOINSTALL}"
        then
-               cp ${TMPDIR}/initramfs-${KV} /boot/initramfs-${KNAME}-${ARCH}-${KV} ||
-                       gen_die 'Could not copy the initramfs to /boot!'
+               if [ "${GENERATE_Z_IMAGE}" != '1' ]
+               then
+                       cp ${TMPDIR}/initramfs-${KV} /boot/initramfs-${KNAME}-${ARCH}-${KV} ||
+                               gen_die 'Could not copy the initramfs to /boot!'
+               fi
        fi
 }
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2006-01-26 05:50:33 UTC
Please use genkernel 3.3.11_pre* which are in the official snapshots, as we will be using 3.3.11 final for 2006.0's release.