Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 119837 - soft lockup CPU0 on iBook G4
Summary: soft lockup CPU0 on iBook G4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-01-21 09:56 UTC by Alessandro Re
Modified: 2006-01-21 12:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Re 2006-01-21 09:56:35 UTC
Rebooting my iBook i got an error which block the machine. It doesn't proceed and using the old kernel still doesn't work.
Actual kernel is vanilla 2.6.15 and the old was gentoo 2.6.14.

The error is:
BUG: soft lockup detected on CPU#0!
NIP: C000678C LR: C01ECFF4 SP: CFFC3DD0 REGS: cffc3d20 TRAP: 0901   Not tainted
MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
TASK: cffc17b0[1] 'swapper' THREAD: cffc2000
Last syscall: 120
GPR00: 1C94C000 CFFC3DD0 CFFC17B0 00081788 000088B8 FFFFFFFF 00001BE4 C03A0000
GPR08: C03B90EB C0410000 00003FFF C0440000 82000048
NIP [c000678c] __delay+0xc/0x14
LR [c013cff4] ide_wait_not_busy+0x3d/0x90
Call trace:
 [c01ee760] probe_hwif+0x7a8
 [c01ef9a8] probe_hwif_init_with_fixup+0x1c/0xac
 [c01f62f8] pmac_ide_setup_device+0x6f0/0x708
 [c01f6504] pmac_ide_macio_attach+0x1f4/0x268
 [c01d9720] macio_device_probe+0x60/0x8c
 [c01c15cc] driver_probe_device+0x60/0xcd
 [c01c1750] __driver_attach+0x58/0x90
 [c01c0b04] bus_for_each_dev+0x54/0x94
 [c01c17ac] driver_attach+0x24/0x34
 [c01c1020] bus_add_driver+0x74/0x148
 [c01c1c74] driver_register+0x48/0x5c
 [c01da260] macio_register_driver+0x4c/0x68
 [c0437ef4] pmac_ide_probe+0x38/0x48
 [c0437c78] ide_init+0x6c/0x90
 [c0003dc8] init+0x9c/0x21c
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-21 10:00:44 UTC
OK, neither new or old kernel works - so: We can't fix hardware, sorry.
Comment 2 Alessandro Re 2006-01-21 12:26:37 UTC
After a sequence of reboots the system works, and the bug doesn't show in dmesg.

If it were an hardware problem why does it work? I'm not a low level expert, but this doesn't seem an hardware problem, imho.

It's a pity i didn't tried with other kernels, sorry.