Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 119139 - nx-x11 modular X dependencies
Summary: nx-x11 modular X dependencies
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
: 127970 129485 149005 (view as bug list)
Depends on: 113996
Blocks: 125088
  Show dependency tree
 
Reported: 2006-01-15 16:41 UTC by Ginsu
Modified: 2006-09-24 23:47 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nx-x11-1.4.0-r4.ebuild.diff (nx-x11-1.4.0-r4.ebuild.diff,2.14 KB, patch)
2006-01-25 14:43 UTC, Marcelo Goes (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ginsu 2006-01-15 16:41:18 UTC
nx-x11 requires the following modular X dependencies:

imake, gccmakedep, rman
Comment 1 Marcelo Goes (RETIRED) gentoo-dev 2006-01-25 14:43:02 UTC
Created attachment 78110 [details, diff]
nx-x11-1.4.0-r4.ebuild.diff
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2006-02-04 09:00:37 UTC
nx-x11 won't work properly with modular X without #113996 being fixed anyway.
Comment 3 Thomas van Kampen 2006-02-14 07:38:20 UTC
#113996 is fixed now.
Comment 4 Jon 2006-03-12 15:55:01 UTC
The xorg deps are in the nxcomp ebuild in the overlay. :) I thined down the list a bit, though. I think all the absolute dependencies are there. This has been in the overlay for a couple of days. :)

Cheers.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-03-29 07:41:45 UTC
*** Bug 127970 has been marked as a duplicate of this bug. ***
Comment 6 Robin Bankhead 2006-04-01 03:50:51 UTC
Hi,

I applied this patch to the ebuild, but afterwards an 'emerge -Dvp nx-x11' did not pull in any of these deps.  Did I do something wrong?

Steps:
# cd $PORTDIR_OVERLAY
# mkdir net-misc
# cp -R /usr/portage/net-misc/nx-x11 net-misc
# cd net-misc/nx-x11
[downloaded the patch to here]
# patch -p0 <nx-x11-1.4.0-r4.ebuild.diff
# rm nx-x11-1.4.0-r4.ebuild.diff
# ebuild nx-x11-1.4.0-r4.ebuild digest
# emerge -Dvp nx-x11
Comment 7 Jon 2006-04-02 17:42:20 UTC
(In reply to comment #6)
> Hi,
> 
> I applied this patch to the ebuild, but afterwards an 'emerge -Dvp nx-x11' did
> not pull in any of these deps.  Did I do something wrong?
> 
> Steps:
> # cd $PORTDIR_OVERLAY
> # mkdir net-misc
> # cp -R /usr/portage/net-misc/nx-x11 net-misc
> # cd net-misc/nx-x11
> [downloaded the patch to here]
> # patch -p0 <nx-x11-1.4.0-r4.ebuild.diff
> # rm nx-x11-1.4.0-r4.ebuild.diff
> # ebuild nx-x11-1.4.0-r4.ebuild digest
> # emerge -Dvp nx-x11
> 
If you have virtual/x11 set in /etc/portage/profile/virtuals, or you created that virtual ebuild and installed it, then the xorg 7 dependencies will not be pulled in. There is an or statement and if you have virtual x11 set, the or comes true for that and bypasses all the xorg 7 depends. Check and see if you have virtual x11 set and try removing that, and then try to emerge nx-x11 again.

Let me know if this helps. :)

cheers
Comment 8 Joe Wells 2006-04-08 21:19:03 UTC
What is the status of the patch for this bug?  Marcelo Goes proposed a
patch about 2 and a half months ago.  Is it waiting for something
else?

Meanwhile I am working around the problem by some code in /etc/portage/bashrc that adds app-text/rman as a dependency for net-misc/nx-x11.
Comment 9 Jon 2006-04-09 15:13:10 UTC
(In reply to comment #8)
> What is the status of the patch for this bug?  Marcelo Goes proposed a
> patch about 2 and a half months ago.  Is it waiting for something
> else?
> 
> Meanwhile I am working around the problem by some code in /etc/portage/bashrc
> that adds app-text/rman as a dependency for net-misc/nx-x11.
> 
Soon, the packages will be in portage. :) The !M ebuilds are being worked on. :) Once they are finished we can place everything in poratge. The ebuilds have been updated with a lot of changes. So, stay tuned.

Cheers.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-04-10 08:26:18 UTC
*** Bug 129485 has been marked as a duplicate of this bug. ***
Comment 11 Joe Wells 2006-04-10 13:35:22 UTC
This bug overlaps with half of bug 117777 (as pointed out in bug
129485 comment 2 by Kimmo Sundqvist).
Comment 12 Stuart Herbert (RETIRED) gentoo-dev 2006-05-01 13:52:21 UTC
Hi,

Please test the latest nx-x11 ebuild, which was added to Portage yesterday.  You'll need to unmask the ebuild, plus net-misc/nxcomp.

Best regards,
Stu
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-09-24 23:47:19 UTC
*** Bug 149005 has been marked as a duplicate of this bug. ***