Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118985 - dev-util/insight-6.4 fails to compile after tcl update
Summary: dev-util/insight-6.4 fails to compile after tcl update
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Olivier Crete (RETIRED)
Depends on:
Reported: 2006-01-14 05:55 UTC by Sandro Bonazzola (RETIRED)
Modified: 2006-03-23 11:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

full build log (4507-insight-6.4.log,102.45 KB, text/plain)
2006-01-14 05:56 UTC, Sandro Bonazzola (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Bonazzola (RETIRED) gentoo-dev 2006-01-14 05:55:38 UTC
The error appens during a configure script and the output is:
checking system version (for dynamic loading)... ../.././tcl/unix/configure: line 7061: syntax error near unexpected token `)'
../.././tcl/unix/configure: line 7061: `        OSF*)'
configure: error: ../.././tcl/unix/configure failed for unix
make[1]: *** [configure-tcl] Error 1
make[1]: Leaving directory `/var/tmp/portage/insight-6.4/work/insight-6.4'
make: *** [all] Error 2

I'll attach the complete build log.

emerge --info
Portage 2.1_pre3-r1 (default-linux/amd64/2005.1, gcc-3.4.5, glibc-2.3.6-r2, 2.6.14-gentoo-r7 x86_64)
System uname: 2.6.14-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.12.0_pre14
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS=" -march=athlon64 -O2 -pipe -fforce-addr -ffast-math -msse2 -ftracer -m3dnow "
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS=" -march=athlon64 -O2 -pipe -fforce-addr -ffast-math -msse2 -ftracer -m3dnow "
FEATURES="autoconfig ccache collision-protect confcache cvs distlocks elog multilib-strict parallel-fetching sandbox sfperms strict stricter test userpriv"
USE="amd64 7zip X a52 aac aalib acl acpi alsa apache2 arts asf audiofile avi berkdb bitmap-fonts bzip2 cairo canvas cdb cdparanoia cdr chroot cpudetection crypt cups curl dba dbus directfb dlloader dri dts dv dvd dvdr dynagraph emboss encode erandom esd exif expat fam ffmpeg firefox flac foomaticdb gd gdbm ggi gif gimp gimpprint glibc-omitfp glut gmp gnome gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml guile hal idn ieee1394 imagemagick imlib ipv6 ithreads java jbig jikes jpeg jpeg2k junit justify kde kdeenablefinal lcms ldap libcaca libwww linuxthreads-tls lm_sensors logitech-mouse logrotate lzo lzw lzw-tiff mad mailwrapper mdb mhash mikmod mmap mng motif mozsvg mp3 mpeg mpm-worker musicbrainz mysql ncurses nls nptl nptlonly numeric nvidia odbc offensive ogg openal openexr opengl oss pam pcre pcsc-lite pdflib perl php png ppds python qt quicktime readline rtc samba scanner sdl slang smp snmp speex spell ssl subversion svg sysfs tcltk tcpd test tetex tga theora threads tiff timidity truetype truetype-fonts type1-fonts udev unicode usb userlocales utf8 vcd vda vorbis wmf xine xinerama xml2 xmms xpm xv xvid zlib elibc_glibc kernel_linux linguas_it userland_GNU"
Comment 1 Sandro Bonazzola (RETIRED) gentoo-dev 2006-01-14 05:56:28 UTC
Created attachment 77070 [details]
full build log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-01-14 06:08:28 UTC
Sigh... bash-3.1 really "rocks". See Bug 117744, the patch should work here as well.
Comment 3 Olivier Crete (RETIRED) gentoo-dev 2006-01-14 09:12:06 UTC
thanks sandro and jakub... the fix should be in CVS now (in 6.4)
Comment 4 Sandro Bonazzola (RETIRED) gentoo-dev 2006-01-15 10:23:56 UTC
Same problem with tk...
checking system version (for dynamic loading)... ../.././tk/unix/configure: line 5161: syntax error near unexpected token `('
../.././tk/unix/configure: line 5161: `  case `(ac_space=' '; set | grep ac_space) 2>&1` in'
configure: error: ../.././tk/unix/configure failed for unix
make[1]: *** [configure-tk] Error 1
make[1]: Leaving directory `/var/tmp/portage/insight-6.4/work/insight-6.4'
make: *** [all] Error 2

If you prefer I can open a new bug for traking it...
Comment 5 Sandro Bonazzola (RETIRED) gentoo-dev 2006-01-15 10:41:40 UTC
Reopening. In addition to the tk error, I was trying rebuilding insight-6.1 for bug #116630, it's also affected by the tcl error and probably after applying the patch to it it will be affected by tk error.
Comment 6 Patrizio Bassi 2006-01-26 02:59:56 UTC
i continue to have same error reported in comment #4, not fixed in cvs
Comment 7 tim 2006-02-12 09:50:44 UTC
not sure, if it's related, but i have a similar problem here:
gcc -c -O3 -march=pentium-m -mmmx -msse -msse2 -mfpmath=sse -fomit-frame-pointer -pipe  -                     fprefetch-loop-arrays -Wall -Wconversion -Wno-implicit-int -fPIC -I../.././tcl/unix/../ge                     neric -I../.././tcl/unix -DHAVE_UNISTD_H=1 -DHAVE_LIMITS_H=1 -D_LARGEFILE64_SOURCE=1 -DTC                     L_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DHAVE_TYPE_OFF64_T=1 -DHAVE_GETCWD=1 -                     DHAVE_OPENDIR=1 -DHAVE_STRSTR=1 -DHAVE_STRTOL=1 -DHAVE_STRTOLL=1 -DHAVE_STRTOULL=1 -DHAVE                     _TMPNAM=1 -DHAVE_WAITPID=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_TERMIOS=1 -DHAVE_                     SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R                     =1 -DHAVE_TM_GMTOFF=1 -DHAVE_TIMEZONE_VAR=1 -DHAVE_ST_BLKSIZE=1 -DSTDC_HEADERS=1 -DHAVE_S                     IGNED_CHAR=1 -DHAVE_LANGINFO=1 -DSTATIC_BUILD=1 -DPEEK_XCLOSEIM=1 -DHAVE_SYS_IOCTL_H=1                              -DTCL_SHLIB_EXT=\".so\" ../.././tcl/unix/../unix/tclAppInit.c
i686-pc-linux-gnu-ar cr libtclstub8.4.a tclStubLib.o  ; i686-pc-linux-gnu-ranlib libtclst                     ub8.4.a
rm -f libtcl8.4.a
i686-pc-linux-gnu-ar cr libtcl8.4.a regcomp.o regexec.o regfree.o regerror.o tclAlloc.o t                     clAsync.o tclBasic.o tclBinary.o tclCkalloc.o tclClock.o tclCmdAH.o tclCmdIL.o tclCmdMZ.o                      tclCompCmds.o tclCompExpr.o tclCompile.o tclDate.o tclEncoding.o tclEnv.o tclEvent.o tcl                     Execute.o tclFCmd.o tclFileName.o tclGet.o tclHash.o tclHistory.o tclIndexObj.o tclInterp                     .o tclIO.o tclIOCmd.o tclIOGT.o tclIOSock.o tclIOUtil.o tclLink.o tclListObj.o tclLiteral                     .o tclLoad.o tclMain.o tclNamesp.o tclNotify.o tclObj.o tclPanic.o tclParse.o tclParseExp                     r.o tclPipe.o tclPkg.o tclPosixStr.o tclPreserve.o tclProc.o tclRegexp.o tclResolve.o tcl                     Result.o tclScan.o tclStringObj.o tclThread.o tclThreadAlloc.o tclThreadJoin.o tclStubIni                     t.o tclStubLib.o tclTimer.o tclUtf.o tclUtil.o tclVar.o tclUnixChan.o tclUnixEvent.o tclU                     nixFCmd.o tclUnixFile.o tclUnixPipe.o tclUnixSock.o tclUnixTime.o tclUnixInit.o tclUnixTh                     rd.o  tclUnixNotfy.o  tclLoadDl.o  ; i686-pc-linux-gnu-ranlib libtcl8.4.a
gcc  tclAppInit.o -L/var/tmp/portage/insight-6.4/work/insight-6.4/tcl/unix -ltcl8.4 -ldl                       -lieee -lm \
        -Wl,-rpath,/opt/insight/lib -o tclsh
make[3]: Leaving directory `/var/tmp/portage/insight-6.4/work/insight-6.4/tcl/unix'
make[2]: Leaving directory `/var/tmp/portage/insight-6.4/work/insight-6.4/tcl'
make[1]: Leaving directory `/var/tmp/portage/insight-6.4/work/insight-6.4'
make: *** [all] Error 2
Comment 8 Olivier Crete (RETIRED) gentoo-dev 2006-02-12 16:29:34 UTC
comment #7: I dont see any error message in the part you pasted.
Comment 9 tim 2006-02-12 16:36:52 UTC
the last line says:
make: *** [all] Error 2

which part of "Error" is unclear ;-)
Comment 10 younker 2006-02-16 00:21:17 UTC
I got the same error as described in comment 4.
Comment 11 karel van ijperen 2006-02-28 05:06:07 UTC
I got the same error as described in comment 4
Comment 12 Patrizio Bassi 2006-03-05 13:51:05 UTC
still unsolved..
Comment 13 ginka 2006-03-09 14:31:44 UTC
I had this happen to.  Downgrading to bash 3.0 fixed it.  
Comment 14 Aron Griffis (RETIRED) gentoo-dev 2006-03-21 14:11:24 UTC
I think these are all fixed now, at least I fixed up the stable tcl and tk today and the others seemed to already be fixed.  Please re-open if there's still an issue.
Comment 15 Aron Griffis (RETIRED) gentoo-dev 2006-03-21 14:22:21 UTC
Actually, I see the problem with insight too, so I've fixed that up now as well.  Here are my changes, which should resolve this bug:

Note these only fix the tcl/tk configure issues.  The other issues are unrelated and should be reported in a separate bug.
Comment 16 Sandro Bonazzola (RETIRED) gentoo-dev 2006-03-23 11:21:30 UTC
Tcl/Tk configure problem resolution verified. Works for me for insight-6.4.