Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118664 - lapack-atlas-3.6.0-r1 depends on =sci-libs/blas-atlas-3.6.0 instead of =sci-libs/blas-atlas-3.6.0*
Summary: lapack-atlas-3.6.0-r1 depends on =sci-libs/blas-atlas-3.6.0 instead of =sci-l...
Status: RESOLVED DUPLICATE of bug 118521
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-11 07:16 UTC by Erik Zeek
Modified: 2006-01-11 07:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Zeek 2006-01-11 07:16:13 UTC
lapack-atlas-3.6.0-r1 has a dependency on =sci-libs/blas-atlas-3.6.0, which prevents it from using sci-libs/blas-atlas-3.6.0-r1 (and gives an annoying upgrade downgrade cycle).  Changing the dependency to =sci-libs/blas-atlas-3.6.0* fixes the problem.


--- /home/gentoo/portage/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r1.ebuild.orig        2006-01-11 10:11:48.000000000 -0500
+++ /home/gentoo/portage/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r1.ebuild     2006-01-11 10:11:55.000000000 -0500
@@ -21,7 +21,7 @@

 DEPEND="virtual/libc
        >=sys-devel/libtool-1.5
-       =sci-libs/blas-atlas-3.6.0
+       =sci-libs/blas-atlas-3.6.0*
        sci-libs/lapack-config
        ifc? ( dev-lang/ifc )"



For completeness:
emerge info
Portage 2.1_pre3-r1 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r2, 2.6.15-gentoo i686)
=================================================================
System uname: 2.6.15-gentoo i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.12.0_pre13
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=prescott -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/grass60/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -mtune=prescott -march=prescott -pipe"
DISTDIR="/home/gentoo/portage/distfiles"
FEATURES="autoconfig candy ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://gentoo.mirrors.pair.com/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.chem.wisc.edu/gentoo/"
LC_ALL="en_US.utf8"
LINGUAS="en-US"
MAKEOPTS="-j2"
PKGDIR="/home/gentoo/portage/packages"
PORTAGE_TMPDIR="/home/gentoo/tmp"
PORTDIR="/home/gentoo/portage"
PORTDIR_OVERLAY="/home/gentoo/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 7zip X X509 Xaw3d a52 aac aalib acl acpi activefilter ada aim aio alsa amarok amd amr aotuv apache2 apm arts artswrappersuid artworkextra asf asm asterisk async atlas auctex audiofile authdaemond automount avi bash-completion bcmath bcp bdf berkdb bitmap-fonts bjam bl blas blender-game bonobo boo bzip2 c++ cairo calendar cap caps ccache cdda cddb cdf cdio cdparanoia cdr cdrom cgi chm clanJavaScript clanVoice cli clisp cmucl commercial corba cpdflib cracklib crosscompile crypt cscope css ctype cups curl curlwrappers cvsgraph daap dba dbm dbus dbx dcc debugger dga dhcp dio directfb discard-path dnd dpms dri dts dv dvd dvdr dvdread dynagraph ecc editor edl eds effects emboss emoticon encode enscript epson erandom esd examples exif expat extraicons extramodules fam fame fat fbcon fbdev fbsplash ffmpeg fftw finger firefox fits flac flash flatfile fltk font-server fontconfig foomaticdb force-cgi-redirect fortran fpx freetts freetype ftp fuse gb gcc-libffi gcj gcl gd gdal gdbm geoip geos ggi gif gimp gimpprint ginac gitsendemail gkrellm glade glep glgd glitz glut glx gml gmp gmtfull gmthigh gmtsuppl gmttria gnome gnome-print gnomedb gnuplot gnutls gpgme gphoto2 gpm gps graphviz grass gs gsl gssapi gstreamer gtk gtk2 gtkhtml guile gzip hal haskell hddtemp hdf hdf5 hfs high-ints hlapi hou hpn html httpd i8x0 iconv icq id3 ide idea idn image imagemagick imap imlib imlib2 inifile inkjar insecure-drivers insecure-savers ipv6 itcl jack jai jasper java javacomm javascript jbig jce jikes jimi jit jp2 jpeg jpeg2k junit jython kcal kde kdeenablefinal kdepim kdexdeltas kqemu ladcca lame lapack largeterminal latex lcms ldap libcaca libclamav libdsk libg++ libgda libsamplerate libwww live lm_sensors logitech-mouse logrotate logwatch lua lzo lzw mad mail maildir mailwrapper mapeditor maps math matroska mbrola md5sum mhash mikmod mime ming mixer mjpeg mmap mmx mmxext mng mod mopac7 motif mozilla moznocompose moznoirc moznomail mozsha1 mozsvg mp3 mp4live mpeg mpeg2 mpeg4 mplayer mpqc multiprocess multitarget musepack music musicbrainz mysql nas ncurses net netcdf network new-login nfs nls no-old-linux nocd nowin nptl nsplugin ntfs ntlm numarray numeric oav objc ocaml octave offensive ofx ogdi ogg oggvorbis openal openbabel openexr opengl osc oss pam parse-clocks pascal patented pcntl pcre pdf pdfkit pdflib pear perl php physfs pic player plotutils plugin png pnp portaudio posix postfix povray ppds print pyste python qemu-fast qhull qt quicktime quotas quotes rar rdesktop readline real recode remix rle rogue rpc rrdtool rss rtc ruby samba sasl sbcl scanner scp screen sdk sdl seti sftp shared sharedext sharedmem shorten shout skins slp smime smp sndfile sockets softmmu sou sounds speedo speex spell spl sql sqlite sse sse-filters sse2 ssl stencil-buffer stream subject-rewrite subp subtitles subversion suid svg svgz symlink sysfs syslog sysvipc szip t1lib tcltk tcpd test tetex tga theora thesaurus threads tidy tiff timidity tokenizer toolbar tools transcode truetype truetype-fonts type1 type1-fonts ucs2 ucs4 udev unicode urandom usb userlocales utf8 uudeview v4l v4l2 vcd vcdimager vfat videos vidix vim-with-x virus-scan visualization vlm voice vorbis webdav win32codecs wmf wordperfect wv wxwindows x264 xanim xatrix xface xforms xine xinetd xml xml2 xmms xosd xpm xprint xscreensaver xsl xslt xv xvid xvmc yv12 zip zlib elibc_glibc kernel_linux linguas_en-US userland_GNU"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-11 07:17:29 UTC

*** This bug has been marked as a duplicate of 118521 ***