Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118636 - ./configure bug in php-cgi
Summary: ./configure bug in php-cgi
Status: RESOLVED DUPLICATE of bug 23579
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-01-11 02:40 UTC by Peter Slizik
Modified: 2006-01-19 07:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Slizik 2006-01-11 02:40:23 UTC
The ./configure process in emerge dev-php/php-cgi fails with the following error:

configure: error: Sablotron version 0.96 or greater required.

(Actual version of php-cgi: 4.4.0. XML support enabled.)

Actually, Sablotron version 1.0.1 is installed on my system.


The problem lies in how configure checks the version number. It uses the following test program:

#line 90520 "configure"
#include "confdefs.h"

#include <stdlib.h>
#include <sablot.h>

int main ()
    double version;
    version = atof(SAB_VERSION);

    if (version >= 0.96) {

There are two problems with this program. Firstly, it seems that it's not good to use atof with a double variable. (double test = atof("0.96") returns some crazy int number, while float test = atof("0.96") works correctly.)  Secondly, with the change of the version number from 0.xx to 1.x.x the atof() function fails completely.

Hope this helps.
(I'm not sure whether the configure file is the responsibility of gentoo or original php developers.)

Peter Slizik
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-11 02:49:57 UTC

*** This bug has been marked as a duplicate of 23579 ***
Comment 2 Tarragon M. Allen 2006-01-12 16:26:53 UTC
I really don't see how applies to this problem?
Comment 3 Peter Slizik 2006-01-19 06:51:56 UTC
> I really don't see how applies to
> this problem?

Well, I don't see either. But setting USE="-java" have helped. 

Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-01-19 07:17:06 UTC
(In reply to comment #2)
> I really don't see how applies to
> this problem?

Check Bug 98853.