Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118393 - amule wont install - wxcas
Summary: amule wont install - wxcas
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo net-p2p team
Depends on:
Reported: 2006-01-09 05:05 UTC by Lars.van.Reenstrømen
Modified: 2006-01-18 14:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Lars.van.Reenstrømen 2006-01-09 05:05:42 UTC
emerge --info
Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.14-suspend2-r7 i686)
System uname: 2.6.14-suspend2-r7 i686 Intel(R) Pentium(R) 4 Mobile CPU 1.80GHz
Gentoo Base System version 1.6.13
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-Os -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium4 -pipe"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 7zip X aac accessibility acpi alsa amarok amuled arts audiofile avi bitmap-fonts browserplugin bzip2 cardbus ccache cdr cjk crypt cups curl dict dvd dvdr dvdread eds emboss encode exif expat extras fam ffmpeg firefox foomaticdb fortran gd gdbm gif gimp gimpprint glut gphoto2 gpm gstreamer gtk2 i8x0 idn imagemagick imlib ipv6 jabber javascript jpeg kde lcms libg++ libwww logitech-mouse mad madwifi mikmod mmx mng motif mozsvg mp3 mpeg musicbrainz ncurses nls ogg oggvorbis opengl oss pam pcre pdflib perl png python qt quicktime readline reiser4 reiserfs remote samba sdl spell sse sse2 ssl stats svg svga symlink tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vcd vorbis wifi win32codecs wmf xchat xchatdccserver xml2 xmms xv xvid zlib linguas_de userland_GNU kernel_linux elibc_glibc"

gentoo-portable vixie # USE="gtk" emerge -av amule

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] net-p2p/amule-2.0.3-r4  +amuled -debug +gtk +nls +remote +stats +unicode 0 kB

collect2: ld returned 1 exit status
make[5]: *** [wxcas] Fehler 1
make[5]: Leaving directory `/var/tmp/portage/amule-2.0.3-r4/work/aMule-2.0.3/src/utils/wxCas/src'
make[4]: *** [all-recursive] Fehler 1
make[4]: Leaving directory `/var/tmp/portage/amule-2.0.3-r4/work/aMule-2.0.3/src/utils/wxCas'
make[3]: *** [all-recursive] Fehler 1
make[3]: Leaving directory `/var/tmp/portage/amule-2.0.3-r4/work/aMule-2.0.3/src/utils'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/amule-2.0.3-r4/work/aMule-2.0.3/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/amule-2.0.3-r4/work/aMule-2.0.3'
make: *** [all] Fehler 2

!!! ERROR: net-p2p/amule-2.0.3-r4 failed.
!!! Function src_compile, Line 90, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 1 Marcin Kryczek (RETIRED) gentoo-dev 2006-01-13 05:15:20 UTC
i can't reproduce that, however i see you're using gcc-3.3. could you try to compile amule with gcc-3.4.x and let me know if that'll help?
Comment 2 Lars.van.Reenstrømen 2006-01-18 14:07:12 UTC
(In reply to comment #1)
> i can't reproduce that, however i see you're using gcc-3.3. could you try to
> compile amule with gcc-3.4.x and let me know if that'll help?

Hello Marcin,

Will do recompile with gcc 3.4.x as soon as possible and give you more feedback.

Comment 3 Lars.van.Reenstrømen 2006-01-18 14:49:33 UTC
short update:

I've tried to recompile amule unstable (2.1.x) with unstable wxGTK 2.6.1. .... hooray ... successful!

But there a more unanswered questions...
On my other desktop system i've used only stable pakets and it works very fine with wxgtk and amule.
At my trial and error seek i've installed another gentoo basic system strictly used the official gentoo handbook. After installation i've typed only emerge amule and about 2 hours and 39 other dependencies later comes the same error. ;)
There are only two things the same ... the notebook and the kernel config.
uuaaa... whats going on? ;)

But finally i have an amule installed. :)