Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 118141 - x11-libs/cairo-0.2 (is blocking x11-libs/cairo-1.0.2)
Summary: x11-libs/cairo-0.2 (is blocking x11-libs/cairo-1.0.2)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2006-01-07 01:16 UTC by Gustav Schaffter
Modified: 2006-02-19 23:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

patch to remove the nasty check (cairo-0.4.0-makefile.patch,1.52 KB, patch)
2006-01-14 09:21 UTC, Simon Stelling (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustav Schaffter 2006-01-07 01:16:08 UTC
# emerge sync

# emerge -puvD world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <x11-libs/cairo-0.2 (is blocking x11-libs/cairo-1.0.2)
[ebuild     U ] x11-libs/cairo-1.0.2 [0.1.23-r1] +X -doc* -glitz +png 1,424 kB
[ebuild     U ] x11-libs/pango-1.10.2 [1.8.1-r1] -debug -doc 1,141 kB
[ebuild     U ] x11-libs/gtk+-2.8.8 [2.6.10-r1] -debug -doc +jpeg +tiff 11,627 kB

Total size of downloads: 14,192 kB

# emerge -puvtD world

These are the packages that I would merge, in reverse order:

Calculating world dependencies ...done!
[blocks B     ] <x11-libs/cairo-0.2 (is blocking x11-libs/cairo-1.0.2)
[nomerge      ] x11-themes/gnome-icon-theme-2.10.1  -debug
[nomerge      ]  x11-themes/hicolor-icon-theme-0.8
[nomerge      ]             gnome-base/libgnomeui-2.10.1  -debug -doc +jpeg -static
[nomerge      ]              gnome-base/libbonoboui-2.10.1  +X -debug -doc -static
[nomerge      ]               gnome-base/libgnomecanvas-2.10.2  +X -debug -doc -static
[nomerge      ]                gnome-base/libglade-2.5.1  -debug -doc
[ebuild     U ]                 x11-libs/gtk+-2.8.8 [2.6.10-r1] -debug -doc +jpeg +tiff 11,627 kB
[ebuild     U ]                  x11-libs/pango-1.10.2 [1.8.1-r1] -debug -doc 1,141 kB
[ebuild     U ]                  x11-libs/cairo-1.0.2 [0.1.23-r1] +X -doc* -glitz +png 1,424 kB

Total size of downloads: 14,192 kB

# emerge info
Portage 2.0.53 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r5-sleipner i686)
System uname: 2.6.14-gentoo-r5-sleipner i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.2.3-r5, 2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O3 -march=pentium4 -funroll-loops -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 X acl acpi adns alsa apm arts audiofile avi berkdb bitmap-fonts bonobo bzip2 cdr crypt cups curl dvd dvdr eds emacs emboss encode esd exif expat fam flac font-server foomaticdb fortran gd gdbm gif glut gnome gpm gstreamer gtk gtk2 guile hal idn imagemagick imlib ipv6 java jpeg junit kde lcms libg++ libwww mad mhash mikmod mmx mng motif mozcalendar mozilla mozsvg mp3 mpeg ncurses new-login nls nptl nptlonly ogg oggvorbis opengl oss pam pcre pdflib perl png ppds python qt quicktime readline recode scanner sdl slang speex spell sqlite sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs xine xml xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"

# ls -l /etc/portage/package.keywords
ls: /etc/portage/package.keywords: No such file or directory

Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-01-07 02:42:38 UTC
Yes, you need to unmerge the old version.

*** This bug has been marked as a duplicate of 79606 ***
Comment 2 Gustav Schaffter 2006-01-08 04:00:29 UTC
Which I did, and it all worked out fine.

I guess I was surpriced that an old version was blocking a newer version of the same package. Thought that would be done through an update (??).

Hope it won't happen with python or gcc or somesuch. ;-)

Anyway, unmerge plus merge solved it.


Comment 3 Simon Stelling (RETIRED) gentoo-dev 2006-01-14 09:17:44 UTC
reopening to re-assign
Comment 4 Simon Stelling (RETIRED) gentoo-dev 2006-01-14 09:20:33 UTC
blocking another version in the same SLOT of the same package is just plainly wrong. Normally an update would exactly solve this problem, the only reason this was done is the kinda strange check mentioned in bug 85285 comment 3. There is a patch, I think it should be applied and sent upstream instead of doing senseless blocking.
Comment 5 Simon Stelling (RETIRED) gentoo-dev 2006-01-14 09:21:29 UTC
Created attachment 77085 [details, diff]
patch to remove the nasty check
Comment 6 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-02-19 23:19:25 UTC
0.2 is no longer in portage.  Closing as fixed.