Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117881 - Building OpenOffice 2.0.1 fails: WARNING: - helpex - Can't create file ../../../../
Summary: Building OpenOffice 2.0.1 fails: WARNING: - helpex - Can't create file ../../...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-01-05 06:08 UTC by Alexander Skwar
Modified: 2006-01-06 00:15 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2006-01-05 06:08:10 UTC
............................................................................................................................................................................WARNING: - helpex - Can't create file ../../../../ No#0
WARNING: - helpex - Can't create file ../../../../ No#1
WARNING: - helpex - Can't create file ../../../../ No#199
ERROR: - helpex - Can't create file ../../../../
Disk full ? Mounted NFS volume broken ?
.dmake:  Error code 255, while making '../../../../'
'---* *---'

ERROR: Error 65280 occurred while making /0b/Gentoo/portage/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1/build/ooa680-m1/helpcontent2/source/text/scalc/01
make: *** [stamp/build] Fehler 1

!!! ERROR: app-office/openoffice-2.0.1 failed.
!!! Function src_compile, Line 208, Exitcode 2
!!! Build failed
!!! If you need support, post the topmost build error, NOT this status message.

I doubt that there's not enough free space. The file system is 4000MB big. Right now, ie. after the build has failed, there is:

[15:01:22 vz6tml@dewup-ww02:/0b/Gentoo/portage/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1/build/ooa680-m1/helpcontent2/source/text/scalc/01] $ pwd
[15:01:24 vz6tml@dewup-ww02:/0b/Gentoo/portage/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1/build/ooa680-m1/helpcontent2/source/text/scalc/01] $ cd ../../../../unxlngi6
[15:01:33 vz6tml@dewup-ww02:/0b/Gentoo/portage/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1/build/ooa680-m1/helpcontent2/] $ df .
Dateisystem          1K-Blcke   Benutzt Verfgbar Ben% Eingehngt auf
                       4096000   2728120   1367880  67% /0b/Gentoo/portage/tmp/portage

So, there's still ~1.3GB free.

/0b/Gentoo/portage/tmp/portage is a tmpfs.

[14:55:18 vz6tml@dewup-ww02:~] $ emerge info
Portage 2.1_pre3-r1 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.5-r3, 2.6.14-gentoo-r6.05 i686)
System uname: 2.6.14-gentoo-r6.05 i686 Intel(R) Xeon(TM) CPU 2.40GHz
Gentoo Base System version 1.12.0_pre13
distcc[21435] (dcc_set_trace_from_env) ERROR: failed to open logfile /var/log/distcc.log: Permission denied [enabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
CFLAGS="-O2 -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
FEATURES="autoconfig buildpkg ccache collision-protect distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="        http://localhost/~vz6tml/gentoo-files        http://localhost/gentoo-files/         http://localhost/~vz6tml/gentoo-files/        http://localhost:60081/pub/Mirrors/gentoo/    http://localhost:60080/pub/gentoo/    http://localhost:60082/mirror/  http://localhost:60083/pub/linux/distributions/gentoo/         http://localhost:60084/ "
USE="x86 7zip GAPING_SECURITY_HOLE X acl apache apache2 artworkextra async audiofile avi bash-completion berkdb bitmap-fonts bzip2 ccache ck-server crypt css cups curl dbus dvd encode exif expat fam fat ffmpeg firefox font-server foomaticdb gd gdbm gif gmail gmailtimestamps gmp gnome gpm gs gtk gtk2 hal hfs hpn i8x0 iconv id3 idn imagemagick imlib imlib2 java javascript jfs jikes jpeg junit kde kdeenablefinal lame lcms ldap libedit libg++ libwww linuxthreads-tls lm_sensors lynxkeymap lzo lzw lzw-tiff mad mailbox maildir matroska mhash mmx mng motif mozsvg mp3 mpeg mpm-worker msdav mysql mysqli ncurses network nfs nis nls no-old-linux no-suexec nodrm nomusic nptl ntlm offensive ogg oggvorbis pam pcre pdflib perl php png posix postfix python qt quicktime rar rdesktop readline real recode reiserfs ruby samba sapdb screen sdl sendfile sftp slang smp sockets spell sse sse2 ssl stream subtitles symlink sysvipc tcpd tiff transcode truetype truetype-fonts udev unicode usb userlocales utf8 vim vim-pager vim-with-x vorbis webdav win32codecs xattr xfs xine xinetd xml2 xmms xv xvid yp zlib elibc_glibc kernel_linux linguas_de userland_GNU"

The build was done with:

[14:55:21 vz6tml@dewup-ww02:~] $ PKGDIR=/dev/shm/packages FEATURES="-distcc -collision-protect" emerge -vat openoffice

These are the packages that I would merge, in reverse order:

Calculating dependencies ...done!
[ebuild     U ] app-office/openoffice-2.0.1 [2.0.0] USE="curl gnome gtk java kde ldap xml2 zlib -eds* -mozilla" 0 kB

Total size of downloads: 0 kB
Comment 1 Peter Read 2006-01-05 06:44:56 UTC
Have you tried rebuilding with non-RAM based PORTAGE_TMPDIR ?
Comment 2 Alexander Skwar 2006-01-05 06:47:56 UTC
(In reply to comment #1)
> Have you tried rebuilding with non-RAM based PORTAGE_TMPDIR ?

Not yet. I'm in the process of rebuilding it with a normal reiserfs fs which has 14g available.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-01-05 06:58:41 UTC
Please, try with a "normal" filesystem with at least 6GB of free space available, and reopen if you are able to reproduce the issue.
Comment 4 Alexander Skwar 2006-01-05 07:11:43 UTC
Does "reiserfs" qualify as being a "normal" fs? :)

As I wrote, I'm currently building it on a reiserfs which had, at the beginning of the build, ~14g available. I'll update this bug as "soon" (well, we're talking OOo here, aren't we? *G*) as the build has finished.
Comment 5 Alexander Skwar 2006-01-05 22:15:03 UTC
Hmm, I now rebuild it on a reiserfs - worked. I then rebuild it on a larger (7g) tmpfs - broke as described here.


Will report upstream.
Comment 6 Alexander Skwar 2006-01-06 00:15:59 UTC
Reported upstream - see