Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117733 - php-toolkit: php-select doesn't link properly
Summary: php-toolkit: php-select doesn't link properly
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Highest major (vote)
Assignee: PHP Bugs
Depends on:
Reported: 2006-01-04 05:55 UTC by grischa
Modified: 2006-01-05 02:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

debug output of "php-select php php4" (debug_php-select.txt,5.11 KB, text/plain)
2006-01-04 06:40 UTC, grischa
emerge info debug output (emerge-info-steffen.txt,1.55 KB, text/plain)
2006-01-04 07:29 UTC, Steffen Weber
php-select debug output (php-select-debug-steffen.txt,4.13 KB, text/plain)
2006-01-04 07:30 UTC, Steffen Weber

Note You need to log in before you can comment on or make changes to this bug.
Description grischa 2006-01-04 05:55:02 UTC
i did an php4 install using the new portage structure (dev-lang).

##### Settings START

## ADD to /etc/portage/package.keywords:
	# New PHP4/5 struct added
	=dev-lang/php-4.4.1-r3 ~amd64

## ADD to /etc/portage/package.use

	# new php architecture:
	=dev-lang/php-4* -* cli cgi apache2 ctype gd java jpeg ming mysql pcre png session sharedmem truetype xml xml2 xsl zlib

## Remove php5 from being installed - /etc/portage/package.mask

##### Settings END

## The emerge worked fine
emerge "=dev-lang/php-4*"

##  but when i wan't to use the php-toolkit to set the php cli version an error occurs:
php-select php php4

## !!produces:
"ln: when making multiple links, last argument must be a directory"

# looks like the symlink couldn't be created....there's no
# php -> /usr/lib64/php4/bin/php
# in /usr/bin

# so i added it my self and evrything worked fine....

ln -s /usr/lib64/php4/bin/php /usr/bin/php

Comment 1 Luca Longinotti (RETIRED) gentoo-dev 2006-01-04 06:10:05 UTC
Hi, please add -x to the first line of /usr/sbin/php-select (so that it looks like #!/bin/bash -x), and report here the output you then get, -x enables debug of bash scripts. :)
Also, your emerge info would be intersting to know, thanks.
Best regards, CHTEKK.
Comment 2 grischa 2006-01-04 06:40:58 UTC
Created attachment 76160 [details]
debug output of "php-select php php4"
Comment 3 Steffen Weber 2006-01-04 07:29:42 UTC
Created attachment 76161 [details]
emerge info debug output
Comment 4 Steffen Weber 2006-01-04 07:30:22 UTC
Created attachment 76162 [details]
php-select debug output
Comment 5 Luca Longinotti (RETIRED) gentoo-dev 2006-01-04 09:22:12 UTC
I just added app-admin/php-toolkit-1.0-r1 to the tree, wich, at least for me, fixes the issue, thanks again for helping us track and debug this! :)
emerge sync in a couple of hours and emerge php-toolkit again, making sure it's the 1.0-r1 version, and your problem should be fixed.
Please report back to this bug if 1.0-r1 indeed fixed your problems or not, thanks!
Marking as test-request in the meantime.
Best regards, CHTEKK.
Comment 6 Steffen Weber 2006-01-04 10:54:59 UTC
Thanks, this bug is history! Just emerged php-toolkit-1.0-r1 and then re-emerged dev-lang/php, because I was too lazy to use php-select. ;-)
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-01-04 13:36:25 UTC
Thanks for reporting back, closing.
Comment 8 grischa 2006-01-05 02:17:55 UTC
it's working fine on my amd64 machine, i suggest to remove the package mask.