Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117366 - hotplug 20040923-r1 firmware agent broken
Summary: hotplug 20040923-r1 firmware agent broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Greg Kroah-Hartman (RETIRED)
Depends on:
Reported: 2006-01-01 10:43 UTC by Benjamin Schulz
Modified: 2007-01-15 11:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Schulz 2006-01-01 10:43:26 UTC
I revently updated my system.
I now use Kernel gentoo-sources on my Laptop system.
I have an prism54 cardbus wlan card and an internal centrino wlan ipw2100.
both firmwares are in /lib/Firmware (which the firmware.agent script names as appropriate path)
the kernel has the appropriate settings (Firmware loading enabled (in Kernel), hotplug enabled etc.).

The connection to the internet has worked on my laptop until an emerge -uD world, which also updated hotplug. I have no udev installed, so I assume it is the hotplug script.
Other users have a similar behaviour. See:
but in this cases, udev seems involved, which I have (according to emerge --search udev) not installed on my system.

Since im not able to connect to internet with my laptop and emerge, could some cracks please tell me the changes I have to made (I assume it are only some Filename renames or other things).
Comment 1 Benjamin Schulz 2006-01-01 10:45:34 UTC
sorry in the line
"both firmwares are in /lib/Firmware"

is a typo and it must read

"both firmwares are in /lib/firmware"

that is the correct path.
Comment 2 Benjamin Schulz 2006-01-01 10:47:42 UTC
changed the status of the bug to what it is, since I ann't use my wlan cards
Comment 3 Benjamin Schulz 2006-01-01 11:27:55 UTC
It seems that I have to add one comment.
The Kernel of my laptop tells me at startup that it is indeed "activating udev".
This may be du to a first "overall genkernel" compilation wich I modified afterwards via genkernel --menuconfig.

But I have no udev ebuild on my system. As emerge and the portage files tell me. 
Comment 4 Benjamin Schulz 2006-01-02 17:41:56 UTC
I must made some comments.
I had a devfs configuration. But at startup some script (maybe /sbin/rc) says udev activated. I ensured via kernel option and changing some other configs in the gentoo wiki for defvs and udev that udev is not loaded.

The bug has to to with Bug 104470 . 
echo "/sbin/hotplug" > /proc/sys/kernel/hotplug
solved all. 
But it is of course no "solution". 

The Problem on my System seems, that some scripts which are installed via emerge -uD world assume! that no one uses devfs anymore and try to "install" an udev firmware which does not exist.
Comment 5 Greg Kroah-Hartman (RETIRED) gentoo-dev 2006-01-02 20:39:32 UTC
On 2.6 kernels, devfs does not exist anymore, nor is it supported in the gentoo
startup scripts, so you are on your own here, sorry.
Comment 6 Benjamin Schulz 2006-01-03 02:43:31 UTC
On 2.6 kernels, devfs does not exist anymore, nor is it supported in the gentoo
startup scripts, so you are on your own here, sorry.

1) Since it can be compiled in my kernel, it does exist. 2.6.14 seems to be the first Kernel where it is removed.

2) Some People, which have the same Problems with the firmware loader claim, these problems are udev related. They aren't since I've got devfs working.
Comment 7 Greg Kroah-Hartman (RETIRED) gentoo-dev 2006-01-03 10:26:33 UTC
2.6.13 was when devfs was removed, not 2.6.14.

Yes, the firmware stuff seems to be hotplug related, not udev, but since
udev is taking over the hotplug functionality, it can be fixed there.
Comment 8 Benjamin Schulz 2006-01-03 13:34:53 UTC
what do you mean with "it can be fixed there".
When a feature of gentoo is broken which affects older systems (Kernels 2.6.12,13) too, one should not fix udev, but the problem which caused the error independent from udev!

Do you want to force everybody (even old Kernel 2.6.12 or 2.4 users) to convert to udev even if their system worked correctly before emerge -uD world? I think linux users (especially users of gentoo) should have the right to be as conserative as they want. Some people might want to wait a few weeks more before going to udev.

I think it would be a good job to look via Debug comments what happens in Kernel and hotplug, when a firmware gets loaded, Or compare old versions of the Kernel hotplug and the hotplug scripts on changements.
Comment 9 Greg Kroah-Hartman (RETIRED) gentoo-dev 2006-01-03 15:40:48 UTC
This bug has nothing to do with 2.4 kernels.

For 2.6, if you use devfs you are on your own, due to it being gone (since 
August 2005) and unsupported (since 2.4) from upstream.

And, for 2.6 kernels that want hotplug support, udev is going to be the
solution, as it solves the hotplug issues much better than the old
hotplug scripts (which were originally just a proof of concept shell script
that never got replaced...)
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-01-15 11:31:58 UTC
devfs + ancient 2.6.x kernels -> completely unsupported, you are on your own.

hotplug + udev + troubles loading firmware -> move to Bug 147006 (or just unmerge hotplug)

Closing this, nothing to be done here.