Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117240 - cinelerra-cvs-20051005 crashes on several events AMD64
Summary: cinelerra-cvs-20051005 crashes on several events AMD64
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-30 16:57 UTC by Attila Stehr
Modified: 2006-07-14 15:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Attila Stehr 2005-12-30 16:57:37 UTC
cinelerra-cvs is NOT hard masked... (but cinelerra non cvs version)

steps to reproduce:
1) open a video file (avi, mpg ...)
2) press play

atti@magic ~ $ cinelerra
Cinelerra 2.0 Sat Aug 27 21:05:30 PDT 2005 (C)2005 Heroine Virtual Ltd.

Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.
signal_entry: got SIGSEGV my pid=15272 execution table size=48:
    file.C: file.C: 313
    VRender::run 0
    VRender::run 0.1
    VRender::run 0.2
    vrender.C: process_buffer: 109
    vrender.C: process_buffer: 116
    vrender.C: get_colormodel: 323
    vrender.C: get_colormodel: 326
    vrender.C: process_buffer: 119
    vrender.C: process_buffer: 124
    vrender.C: process_buffer: 171
    virtualvconsole.C: process_buffer: 60
    virtualvconsole.C: process_buffer: 71
    virtualvconsole.C: process_buffer: 75
    virtualvnode.C: render: 139
    virtualvnode.C: render_as_module: 188
    virtualvnode.C: read_data: 88
    virtualvnode.C: read_data: 91
    module.C: update_transition: 218
    module.C: update_transition: 224
    module.C: update_transition: 234
    vmodule.C: render: 361
    vmodule.C: render: 366
    vmodule.C: render: 439
    vmodule.C: import_frame: 88
    vmodule.C: import_frame: 96
    vmodule.C: import_frame: 110
    file.C: file.C: 313
    vmodule.C: import_frame: 112
    vmodule.C: import_frame: 132
    vmodule.C: import_frame: 177
    vmodule.C: import_frame: 235
    vmodule.C: import_frame: 237
    vmodule.C: import_frame: 311
    vmodule.C: render: 445
    virtualvnode.C: render_as_module: 206
    virtualvnode.C: render_as_module: 213
    virtualvnode.C: render_as_module: 222
    virtualvnode.C: render_as_module: 239
    virtualvnode.C: render_as_module: 249
    virtualvnode.C: render: 144
    virtualvconsole.C: process_buffer: 107
    vrender.C: process_buffer: 173
    VRender::run 0.3
    VRender::run 6
    VRender::run 7
    VRender::run 8
    VRender::run 10
signal_entry: lock table size=46
    0x55555621e0f0 PlaybackEngine::start_lock PlaybackEngine::create_objects *
    0x55555621dd20 CWindowTool::input_lock CWindowTool::run
    0x5555562d2440 PlaybackEngine::start_lock PlaybackEngine::create_objects *
    0x5555562f2c80 TransportQue::output_lock PlaybackEngine::run *
    0x5555563158f0 MainIndexes::input_lock MainIndexes::run 1 *
    0x5555563bdfe0 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555555c08810 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555555c07550 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555555c558f0 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555555c2ed00 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x55555643b230 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555556439760 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555555c54630 BC_Repeater::startup_lock BC_Repeater::initialize *
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x5555562f2c80 TransportQue::output_lock PlaybackEngine::run
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x55555669eb20 CommonRender::start_lock CommonRender::start_command *
    0x55555623f8e0 TransportQue::output_lock PlaybackEngine::run *
    0x5555563158f0 MainIndexes::input_lock MainIndexes::run 1
    0x555555c6e380 LoadPackage::completion_lock LoadServer::process_packages 1 *
    0x555555c6e310 LoadClient::completion_lock LoadServer::process_packages 2 *
    0x55555647def0 LoadClient::input_lock LoadClient::run *
    0x55555647def0 LoadClient::input_lock LoadClient::run
    0x55555626f080 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x55555607fa20 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x55555619c370 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556249270 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x55555626f080 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x5555563bf7e0 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x55555607fa20 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x55555619c370 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x555556249270 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x55555626f080 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x555556317a30 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x5555563bf7e0 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x555556439b60 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x555556317a30 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556317a30 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556317a30 BC_WindowBase::event_condition BC_WindowBase::get_event *
    0x555556317a30 BC_WindowBase::event_condition BC_WindowBase::get_event
    0x55555669a8e0 RenderEngine::input_lock RenderEngine::arm_command *
    0x55555669aa70 RenderEngine::first_frame_lock RenderEngine::arm_command *
    0x55555669aa70 RenderEngine::first_frame_lock RenderEngine::arm_command *
BC_Signals::dump_buffers: buffer table size=0
BC_Signals::delete_temps: deleting 0 temp files
SigHandler::signal_handler total files=0
atti@magic ~ $

magic atti # emerge -pvD cinelerra-cvs

These are the packages that I would merge, in order:

Calculating dependencies   ...done!
[ebuild   R   ] media-video/cinelerra-cvs-20051005  (-3dnow) +alsa +esd (-mmx) -oss -static 0 kB

Total size of downloads: 0 kB
magic atti #

magic atti # emerge info
Portage 2.0.53 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.13-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.13-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O1 -pipe -fomit-frame-pointer -g -ggdb3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /usr/X11R6/bin/startx /etc/env.d"
CXXFLAGS="-march=athlon64 -O1 -pipe -fomit-frame-pointer -g -ggdb3"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy distlocks sandbox severe sfperms strict test"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acpi alsa amd64 audiofile avi berkdb bitmap-fonts bzip2 bzlib cdda cdio cdr crypt css cups curl dbus dga directfb dlloader dmalloc dnd dpms dts dvd dvdr dvdread eds emacs emboss encode esd exif expat fam fame fat fbcon ffmpeg firefox flac foomaticdb freetype gcj gdbm ggi gif gimpprint glut gmp gnome gpm gs gstreamer gtk gtk2 hal hardened howl idn imagemagick imlib ipv6 ithreads javascript jpeg jpeg2k kde lcms libsamplerate libwww linuxthreads-tls lzo lzw lzw-tiff mad matroska memlimit mikmod mjpeg mmap mng mozcalendar mozdevelop mozsvg mp3 mpeg mpi ncurses nls nptl nptlonly ntfs nvidia ogg oggvorbis on-the-fly-crypt openal openexr opengl pam pcre pda pdflib perl png ppds python qt quicktime readline real reiserfs rle sdl slang sndfile spell ssl stream svg symlink tcltk tcpd test tetex tga theora threads tidy tiff toolbar truetype truetype-fonts type1-fonts udev unicode usb userlocales vcd videos vorbis wmf xine xml xml2 xmms xosd xpm xprint xtermtoolbar xv xvid xvmc yv12 zlib linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, PORTDIR_OVERLAY

magic atti #
Comment 1 Attila Stehr 2005-12-30 17:19:15 UTC
same with vanilla-gcc build
Comment 2 Daniel Gulotta 2006-03-08 17:59:20 UTC
I had this problem on my x86 machine as well (and for both the 20051005 and 20060219 versions).  Selecting the ALSA output driver seems to have fixed the problem (OSS was the default).

Here's a backtrace from the crash:
#0  0x0812ce5a in AudioDevice::open_output (this=0xa148ae88, 
    config=0xa1473050, rate=48000, samples=16384, realtime=0)
    at audiodevice.C:167
#1  0x082d7ecc in RenderEngine::open_output (this=0xa14062d8)
    at renderengine.C:362
#2  0x082d79b5 in RenderEngine::arm_command (this=0xa14062d8, 
    command=0x8bc3560, current_vchannel=@0xaf5e3434, 
    current_achannel=@0xaf5e3430) at renderengine.C:210
#3  0x082926db in PlaybackEngine::arm_render_engine (this=0x8bc3218)
    at playbackengine.C:125
#4  0x08292fdd in PlaybackEngine::run (this=0x8bc3218) at playbackengine.C:413
#5  0xb782ca7b in Thread::entrypoint (parameters=0x8bc3218) at thread.C:46
#6  0xb7178aba in start_thread () from /lib/tls/libpthread.so.0
#7  0xb70f135e in clone () from /lib/tls/libc.so.6

The problem seems to be that if Cinelerra is compiled without OSS, then lowlevel_out is set to NULL if the OSS driver is selected.  The segmentation fault occurs when lowlevel_out is dereferenced.
Comment 3 Attila Stehr 2006-03-10 11:33:28 UTC
approved!

Now how do we 'make' cinelerra-cvs not showing audio drivers (in settings) which are not installed?
Comment 4 Simon Stelling (RETIRED) gentoo-dev 2006-06-23 10:36:50 UTC
not amd64-specific
Comment 5 Attila Stehr 2006-06-23 12:57:22 UTC
setting "Hardware" to ALL then
Comment 6 Marc Hildebrand (RETIRED) gentoo-dev 2006-06-25 16:09:29 UTC
Could you please try the newest version (cinelerra-cvs-20060619)?
Until now I don't have any problems with it.
As far as I can remember the issue has been adressed upstream.
If the problem still exists please file a new bug and I'll contact upstream.
Cheers,

Marc.
Comment 7 Attila Stehr 2006-07-14 15:33:52 UTC
Problem seems to be fixed in cinelerra-cvs-20060619. :)

- marking as VERIFIED -