Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 116625 - building libbonobo v2.10.1 requires XML::Parser
Summary: building libbonobo v2.10.1 requires XML::Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2005-12-24 10:25 UTC by Trenton D. Adams
Modified: 2005-12-24 11:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

libbonobo build log (config.log,10.11 KB, text/plain)
2005-12-24 10:27 UTC, Trenton D. Adams

Note You need to log in before you can comment on or make changes to this bug.
Description Trenton D. Adams 2005-12-24 10:25:49 UTC
So, I get an error message as follows.  I assume that I can attach the config.log after I've commited this message.  If so, I will do so.

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/libbonobo-2.10.1/work/libbonobo-2.10.1/config.log

!!! ERROR: gnome-base/libbonobo-2.10.1 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

[root@reuben ~]#less /var/tmp/portage/libbonobo-2.10.1/work/libbonobo-2.10.1/config.log
Comment 1 Trenton D. Adams 2005-12-24 10:27:43 UTC
Created attachment 75457 [details]
libbonobo build log
Comment 2 Trenton D. Adams 2005-12-24 10:30:19 UTC
Oh, by the way, the fix for this is to simply "emerge XML-Parser", and then run the merge of libonobo again.

I also forgot to mention that I think I was running 2005.0 at the time, but i can't remember now, I haven't used it in awhile.  Either way, I do have an up-to-date portage tree, and I had just finished upgrading my entire system with an update world.
Comment 3 Trenton D. Adams 2005-12-24 10:49:51 UTC
I take that back.  Merging XML-Parser doesn't do a thing.  I thought I ran into this awhile back, and fixed it by manually merging the required package, but perhaps I'm wrong on the package now.  Anyhow know which package I need to merge in order to continue?

I REALLY badly want distcc installed, and it won't install without installing a bunch of gnome stuff, and that won't install until this finishes.
Comment 4 Trenton D. Adams 2005-12-24 11:07:40 UTC
Ok, I finally got it to work by using cpan to install XML-Parser.  Why the XML-Parser package didn't work, I don't know.
Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-24 11:49:07 UTC

*** This bug has been marked as a duplicate of 41124 ***