Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 116427 - mplayer crashes X with xv enabled on ATI Radeon Mobility 9600
Summary: mplayer crashes X with xv enabled on ATI Radeon Mobility 9600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
Depends on:
Reported: 2005-12-22 15:42 UTC by René 'Necoro' Neumann
Modified: 2007-04-16 12:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Complete output of strace (strace.dbg,312.22 KB, text/plain)
2005-12-22 15:46 UTC, René 'Necoro' Neumann
strace -i output (mplayer.trace,510.94 KB, text/plain)
2006-06-24 02:48 UTC, René 'Necoro' Neumann

Note You need to log in before you can comment on or make changes to this bug.
Description René 'Necoro' Neumann 2005-12-22 15:42:24 UTC
If I run the mplayer in an X-Server, having the xv-userflag enabled, it kills X. W/o xv it works normal (but slow - which is normal i think).
This only happens on my Laptop (IBM Thinkpad T42 with ATI Radeon Mobility 9600; original ati-drivers) - my PC with an nVidia-GPU is running as it should...

Output of strace run on mplayer:

gettimeofday({1135292632, 998751}, {4294967236, 0}) = 0
write(4, "\214\23\r\0C\0\0\0\1\0 \0\6\0 \0\10\0 \0YV12\0\0\0\0\0"..., 52) = -1 EPIPE (Broken pipe)
--- SIGPIPE (Broken pipe) @ 0 (0) ---
+++ killed by SIGPIPE +++

Output on mplayer-emerge-infos:

media-video/mplayer-1.0_pre7-r1  -3dfx -3dnow -3dnowext +X -aac -aalib +alsa (-altivec) -arts -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags +debug -dga -directfb -doc -dts -dv -dvb +dvd +dvdread -edl +encode +esd -fbcon -ggi +gif +gtk -i8x0 +ipv6 -jack -joystick +jpeg -libcaca -lirc -live -livecd -lzo +mad -matroska -matrox +mmx -mmxext -mythtv -nas +nls -nvidia +opengl +oss +png -real -rtc -samba +sdl +sse +sse2 +svga -tga -theora +truetype -v4l -v4l2 +vorbis +win32codecs -xanim -xinerama -xmms +xv +xvid -xvmc

emerge --info:

Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14-gentoo-r5 i686)
System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) M processor 1.80GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium-m -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/init.d /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium-m -pipe"
FEATURES="autoconfig candy distlocks sandbox sfperms strict"
USE="x86 X alsa apache2 apm audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdr cdrw crypt css cups curl dvd dvdread eds emboss encode esd exif expat fam ffmpeg foomaticdb fortran gd gdbm gif glut gpm gtk gtk2 idn imlib ipv6 java jpeg junit lcms libg++ libwww mad mhash mikmod mmx mng motif mp3 mpeg mysql ncurses nls nsplugin ogg oggvorbis opengl oss pam pcre pdflib perl png python quicktime readline sdl slang spell sse sse2 ssl svg svga tcpd tetex threads tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs xml2 xv xvid zlib linguas_de userland_GNU kernel_linux elibc_glibc"
Comment 1 René 'Necoro' Neumann 2005-12-22 15:46:15 UTC
Created attachment 75356 [details]
Complete output of strace
Comment 2 Patrick McLean gentoo-dev 2006-02-07 12:25:36 UTC
Try the open source ati drivers, this sounds like a bug in the ati proprietary video drivers.
Comment 3 Steve Dibb (RETIRED) gentoo-dev 2006-06-22 08:24:33 UTC
still a bug?
Comment 4 René 'Necoro' Neumann 2006-06-24 02:48:01 UTC
Created attachment 89988 [details]
strace -i output


I use "x11-drivers/ati-drivers-8.25.18" at the moment and the 2.6.16-r9-gentoo-sources...

I re-ran "strace" (better "strace -i" this time) on mplayer and it seems, that it is not the broken pipe, but that mplayer hangs up itself some time before

strace -i: (see attachment for full trace)
[ffffe410] ioctl(5, SNDCTL_DSP_GETODELAY or SNDCTL_DSP_PROFILE, 0xbf8cb484) = 0
[ffffe410] gettimeofday({1151141821, 446590}, NULL) = 0
[ffffe410] gettimeofday({1151141821, 448090}, NULL) = 0
[ffffe410] gettimeofday({1151141821, 448110}, NULL) = 0
[ffffe410] gettimeofday({1151141821, 448128}, NULL) = 0
[ffffe410] ioctl(5, SNDCTL_DSP_GETODELAY or SNDCTL_DSP_PROFILE, 0xbf8cb484) = 0
[ffffe410] nanosleep({0, 36770000}, 0)  = ? ERESTART_RESTARTBLOCK (To be restarted)
[ffffe410] --- SIGHUP (Hangup) @ 0 (0) ---
[ffffe410] write(2, "\n\nMPlayer wurde durch Signal 1 i"..., 66) = -1 EIO (Input/output error)
[ffffe410] write(2, "- MPlayer ist abgest\303\274rzt. Das s"..., 398) = -1 EIO (Input/output error)
[ffffe410] munmap(0xb690e000, 163840)   = 0
[ffffe410] munmap(0xb682c000, 311296)   = 0
[ffffe410] munmap(0xb67e0000, 311296)   = 0
[ffffe410] munmap(0xb6936000, 7917568)  = 0
[ffffe410] --- SIGCONT (Continued) @ 0 (0) ---
[ffffe410] close(3)                     = 0
[ffffe410] shmdt(0xb68c3000)            = 0
[ffffe410] write(4, "\224\2\2\0\7\0@\1+\0\1\0", 12) = -1 EPIPE (Broken pipe)
[ffffe410] --- SIGPIPE (Broken pipe) @ 0 (0) ---
[ffffe410] write(2, "\n\nMPlayer wurde durch Signal 13 "..., 65) = -1 EIO (Input/output error)
Comment 5 Luca Barbato gentoo-dev 2006-06-24 05:11:45 UTC
try with the opensource driver, I'm afraid isn't mplayer fault.
Comment 6 René 'Necoro' Neumann 2007-04-16 12:47:12 UTC
Just saw that this bug is still not closed :) The problem does not exist any more ;)