Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 11622 - NFS generates constant RPC related log errors on ReiserFS filesystems
Summary: NFS generates constant RPC related log errors on ReiserFS filesystems
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Brandon Low (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-12-05 07:26 UTC by Kerin Millar
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kerin Millar 2002-12-05 07:26:50 UTC
Hi. I've just setup a server with Gentoo, and had my first experience with
NFS/NIS for my existing Linux client. The "everything" log gets filled up with
error messages saying something like:

> Dec  5 13:17:09 [kernel] RPC request reserved 272 but used 276

I believe this is a kernel problem. I'm using gentoo-sources-r9, haven't tried
r10. Here's a thread with discusses the issue.

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=linux.kernel.3CA1081D.7040101%40fugmann.dhs.org&rnum=1&prev=/groups%3Fq%3D%2522RPC%2Brequest%2Breserved%2B272%2Bbut%2Bused%2522%26hl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26selm%3Dlinux.kernel.3CA1081D.7040101%2540fugmann.dhs.org%26rnum%3D1

I think a patch is shown there. Basically, I'm wondering if lolo could put this
in the gentoo-sources, whether it is safe to use ... or whether there is some
other kind of workaround that can be used. I'd rather use gentoo-sources than
vanilla because they work very well for me.

NFS performance seems OK, and it doesn't cause any major problems. But the
effect on the log is very annoying.
Comment 1 Brandon Low (RETIRED) gentoo-dev 2003-01-12 22:28:34 UTC
can you tell me if this is still an issue with the new gentoo-sources-2.4.20-r1
please?
Comment 2 Kerin Millar 2003-01-13 15:34:58 UTC
OK, my server is now running gentoo-sources-2.4.20-r1 and yes, it does look as
though the problem as reported has disappeared :-) Looks like it got stamped out
in 2.4.20.

However, I am getting this sort of thing popping fairly regularly:

Jan 13 21:22:12 [ypserv] refused connect from 10.0.0.133:33076 to procedure
ypproc_match

This message was appearing before too - so I'm hoping that this is due to my
inexperience of the particulars of NFS/NIS and that it is nothing more than an
inconsistency in my setup; obviously I'm not sure. I'm not running NFS in TCP
mode, BTW.

Things generally seem to be working. I've marked this as WORKSFORME rather than
FIXED because I've only been running a few minutes, nonetheless the problem as
originally filed does seem to have gone away.

I'm going to keep these sources running ony my server for the time being. Aside
from this bug, do not hesitate to email me if there's anything else I can help
out with to assist the testing.
Comment 3 Kerin Millar 2003-01-15 03:41:19 UTC
Yes, I'm still not seeing that message. That's been well over 24 hours now, so I
think it is safe to say this particular bug would be closed by any kernel >=
2.4.20. The new Gentoo kernel seems stable too.

Marked as closed.