Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 115385 - elfutils fails to install for the first time due to undefined references
Summary: elfutils fails to install for the first time due to undefined references
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 116219 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-13 00:19 UTC by Chris Slycord
Modified: 2005-12-20 21:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Slycord 2005-12-13 00:19:39 UTC
dev-libs/elfutils-0.118 fails to install due to many undefined references. The
output from the emerge indicates that libdw.so requires libelf.so.1 which wasn't
created and therefor everything that libdw.so references gets screwed up.

Also, this blocks me from using prelink, btw.

Reproducible: Always
Steps to Reproduce:
1. emerge elfutils
2.
3.

Actual Results:  
i586-pc-linux-gnu-gcc -Wall -Wshadow -std=gnu99   -Wunused -Wextra -Wformat=2
-march=pentium-mmx -O2 -fomit-frame-pointer -pipe   -o addr2line  addr2line.o
../libdw/libdw.so
/usr/lib/gcc/i586-pc-linux-gnu/3.4.4/../../../../i586-pc-linux-gnu/bin/ld:
warning: libelf.so.1, needed by ../libdw/libdw.so, not found (try using -rpath
or -rpath-link)
../libdw/libdw.so: undefined reference to `gelf_getsymshndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errno@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_kind@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_update_shdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errmsg@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getshdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_end@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_nextscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrel@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getehdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_rawdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getshstrndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_strptr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getphdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_version@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_begin@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_ndxscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrela@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_memory@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_cntl@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getscn@ELFUTILS_1.0'
collect2: ld returned 1 exit status
make[2]: *** [addr2line] Error 1
make[2]: *** Waiting for unfinished jobs....


Expected Results:  
Ebuild to install

Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r3, 2.6.14-ck6
i686)
=================================================================
System uname: 2.6.14-ck6 i686 AMD Athlon(tm) XP 3000+
Gentoo Base System version 1.12.0_pre11
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-march=pentium-mmx -O2 -fomit-frame-pointer -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium-mmx -O2 -fomit-frame-pointer -pipe
-fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoclean autoconfig ccache distlocks nostrip sandbox sfperms strict
userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://gentoo.llarian.net/
http://gentoo.mirrors.easynews.com/linux/gentoo/
http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow aalib bash-completion bitmap-fonts bzip2 fortran mmx ncurses nls
nptl opengl pam pic python readline sdl slang sse ssl tcpd truetype userlocales
xml xml2 zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Chris Slycord 2005-12-13 00:28:03 UTC
Note that this was on a newly installed system with no pre-existing install of
elfutils. I was able to install version 0.108-r1 without any problems and after
installing that previous version, version 0.118 was able to be installed.

It appears that the problem is that the part of the install for 0.118 requires
the library that is only created after a full install is completed.
Comment 2 Jordan Johnson 2005-12-13 07:23:41 UTC
Same errors on a new gentoo install: (followed Bob P's Stage1/3 Gentoo 2005.1
with GCC-3.4.4 guide)

i686-pc-linux-gnu-gcc -Wall -Wshadow -std=gnu99   -Wunused -Wextra -Wformat=2
-O3 -march=prescott -mtune=prescott -fforce-addr -fomit-frame-pointer -ftracer
-pipe   -o addr2line  addr2line.o ../libdw/libdw.so
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../../i686-pc-linux-gnu/bin/ld:
warning: libelf.so.1, needed by ../libdw/libdw.so, not found (try using -rpath
or -rpath-link)
../libdw/libdw.so: undefined reference to `gelf_getsymshndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errno@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_kind@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_update_shdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errmsg@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getshdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_end@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_nextscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrel@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getehdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_rawdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getshstrndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_strptr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getphdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_version@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_begin@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_ndxscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrela@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_memory@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getdata@ELFUTILS_1.0'
../i686-pc-linux-gnu-gcc -Wall -Wshadow -std=gnu99   -Wunused -Wextra -Wformat=2
-O3 -march=prescott -mtune=prescott -fforce-addr -fomit-frame-pointer -ftracer
-pipe   -o elfcmp  elfcmp.o ../libebl/libebl.a ../libelf/libelf.so  -ldl
libdw/libdw.so: undefined reference to `elf_cntl@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getscn@ELFUTILS_1.0'
collect2: ld returned 1 exit status
make[2]: *** [addr2line] Error 1
make[2]: *** Waiting for unfinished jobs....


emerge info:
Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r3,
2.6.14-gentoo-r4 i686)
=================================================================
System uname: 2.6.14-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.12.0_pre11
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=prescott -mtune=prescott -fforce-addr -fomit-frame-pointer
-ftracer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env
/usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=prescott -mtune=prescott -fforce-addr -fomit-frame-pointer
-ftracer -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aalib acpi alsa apm asf asm audacious audiofile avi
bash-completion berkdb bitmap-fonts bzip2 cairo cdda cddb cdr clock-screen crypt
cups dlloader dvd dvdr dvdread eds emboss encode exif expat fam ffmpeg flac
foomaticdb fortran freetype gdbm gif glibc-omitfp glitz glut glx gnome gpm
gstreamer gtk gtk2 hal idn imlib ipv6 java javascript jpeg kde kdeenablefinal
kdexdeltas key-screen lcms libg++ libwww mad mikmod mmap mmx mng motif mouse
mozilla mozsvg mp3 mpd-mad mpeg mplayer musepack music musicbrainz ncurses nls
nptl nsplugin nvidia offensive ogg oggvorbis openal opengl oss pam pcre pdflib
perl pic png python qt quicktime readline real sdl search-screen spell sse sse2
ssl symlink tcpd threads tiff truetype truetype-fonts type1-fonts udev unicode
usb vorbis win32codecs xanim xatrix xchat xchattext xine xml2 xmms xprint xrandr
xv xvid xvmc zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 3 Tristan RENAUD 2005-12-18 06:58:52 UTC
Hi,

Same error here, on my AMD64 box (first time emerging elfutils) :

x86_64-pc-linux-gnu-gcc -Wall -Wshadow -std=gnu99   -Wunused -Wextra -Wformat=2 -march=k8 -O3 -pipe   -o elfcmp  elfcmp.o ../libebl/libebl.a ../libelf/libelf.so  -ldl
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libelf.so.1, needed by ../libdw/libdw.so, not found (try using -rpath or -rpath-link)
../libdw/libdw.so: undefined reference to `gelf_getsymshndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errno@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_kind@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_update_shdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errmsg@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getshdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_end@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_nextscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrel@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getehdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_rawdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getshstrndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_strptr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getphdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_version@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_begin@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_ndxscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrela@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_memory@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_cntl@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getscn@ELFUTILS_1.0'
collect2: ld a retourn
Comment 4 Tristan RENAUD 2005-12-18 06:58:52 UTC
Hi,

Same error here, on my AMD64 box (first time emerging elfutils) :

x86_64-pc-linux-gnu-gcc -Wall -Wshadow -std=gnu99   -Wunused -Wextra -Wformat=2 -march=k8 -O3 -pipe   -o elfcmp  elfcmp.o ../libebl/libebl.a ../libelf/libelf.so  -ldl
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libelf.so.1, needed by ../libdw/libdw.so, not found (try using -rpath or -rpath-link)
../libdw/libdw.so: undefined reference to `gelf_getsymshndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errno@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_kind@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_update_shdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_errmsg@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getshdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_end@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf32_xlatetom@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_nextscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrel@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getehdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_rawdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getshstrndx@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_strptr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getphdr@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_version@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_begin@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_ndxscn@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_xlatetof@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `gelf_getrela@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_memory@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getdata@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_cntl@ELFUTILS_1.0'
../libdw/libdw.so: undefined reference to `elf_getscn@ELFUTILS_1.0'
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [addr2line] Erreur 1
make[2]: *** Attente des tâches non terminées....
rm i386_ld.o
make[2]: Leaving directory `/var/tmp/portage/elfutils-0.118/work/elfutils-0.118/src'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/var/tmp/portage/elfutils-0.118/work/elfutils-0.118'
make: *** [all] Erreur 2

!!! ERROR: dev-libs/elfutils-0.118 failed.


My emerge --info : 

Portage 2.1_pre1 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r3, 2.6.14-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.14-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.0_pre11
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=k8 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://mirrors.blueyonder.co.uk/mirrors/gentoo ftp://mir.zyrianes.net/gentoo/ ftp://mir.zyrianes.net/gentoo/ http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac acpi alsa apache2 apm arts audiofile avi bash-completion berkdb bindist bitmap-fonts bmp bonobo bzip2 bzlib cdb cdr cpudetection crypt cups curl dga divx4linux dts dv dvb dvd dvdr dvdread eds emboss encode esd exif expat fam fbcon ffmpeg flac foomaticdb fortran ftp gb gd geoip gif glut gmp gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml gveejay hal icq idn ieee1394 imagemagick imlib ipv6 jabber jack java jpeg junit kde lcms ldap libwww lua lzw lzw-tiff mad mikmod mime mjpeg mng motif mozilla mp3 mpeg mplayer mysql nas ncurses nls nvidia ofx ogg oggvorbis openal opengl oss pam pcre pdflib perl png ppds print python qt quicktime rar readline real recode sdl speex spell ssl subtitles svg tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales v4l v4l2 videos visualization vorbis wmf xface xine xml xml2 xmms xosd xpm xprint xsl xv xvid yahoo zlib elibc_glibc kernel_linux linguas_fr userland_GNU"
Unset:  ASFLAGS, CTARGET, LDFLAGS
Comment 5 SpanKY gentoo-dev 2005-12-18 08:30:52 UTC
# emerge -C elfutils && elfutils
that should reproduce it
Comment 6 SpanKY gentoo-dev 2005-12-19 14:56:59 UTC
fixed in cvs
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-12-20 21:58:39 UTC
*** Bug 116219 has been marked as a duplicate of this bug. ***