Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 114835 - xorg 7.0.0_rc3 - Pressing any key on keyboard cycles through my resolutions
Summary: xorg 7.0.0_rc3 - Pressing any key on keyboard cycles through my resolutions
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo X packagers
: 114756 (view as bug list)
Depends on:
Blocks: 112004
  Show dependency tree
Reported: 2005-12-08 00:35 UTC by Ashley Bostock
Modified: 2006-04-05 20:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ashley Bostock 2005-12-08 00:35:49 UTC
Upgraded to xorg 7.0.0_rc3 from xorg 7.0.0_rc2, now after starting X pressing
any key on my keyboard changes the screen resolution.  Each key press just
cycles through those listed in my xorg.conf file.

If add the line Option "Dont Zoom" to my xorg.conf file then it stops doing it
but then none of the keyboard keys work.  I'm using a standard black IBM
keyboard (PS/2 connector, 105 keys), nothing special, no fancy multimedia keys,
etc... and its worked fine in all previous X versions with out any special
configuration.  Also works fine from a terminal (i.e. outside of X).  I've got
another USB keyboard which I tried in the same machine and that has exactly the
same issue.

I've emerged the xf86-input-keyboard driver (which was working fine in
7.0.0_rc2) and my xorg.conf file has: Driver "kbd".

Please let me know what other information I need to provide to resolve this bug.

Reproducible: Always
Steps to Reproduce:
1. Updated to 7.0.0_rc3
2. Start X
3. Press any keyboard key

Actual Results:  
Screen resolution cycles on each key press or keyboard doesn't work at all if
Option "Dont Zoom" is set.

Expected Results:  
Keyboard should work correctly and ouput charaters.

Not infront of machine right now, will added this output shortly.
Comment 1 Ashley Bostock 2005-12-08 11:39:26 UTC
My emerge info....

Portage (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2,
2.6.14-gentoo-r2 i686)
System uname: 2.6.14-gentoo-r2 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env
/usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 X a52 aac acpi alsa apm arts audiofile avi berkdb bitmap-fonts bzip2
cdparanoia cdr crypt cups curl divx4linux dts dvd dvdr dvdread eds emboss encode
esd exif expat fam ffmpeg firefox flac foomaticdb fortran gd gdbm gif glitz glut
gmp gpm gstreamer gtk2 hal idn imagemagick imlib ipv6 java javascript joystick
jpeg jpeg2k junit kde lcms libg++ libwww live mad matroska mikmod mmx mng mono
motif mozilla mozsvg mp3 mpeg musicbrainz mysql ncurses nls nptl nptlonly
nsplugin nsplugins nvidia ogg oggvorbis opengl oss pam pcre pdflib perl png
python qt quicktime readline real samba scanner sdl speex spell sqlite sse sse2
ssl svg svga tcltk tcpd theora tiff truetype truetype-fonts type1-fonts udev
unicode usb vcd vidix visualization vorbis win32codecs wmf xine xinerama xml2
xmms xv xvid xvmc zlib userland_GNU kernel_linux elibc_glibc"
Comment 2 Patrik Kullman 2005-12-09 15:31:04 UTC

cd /usr/lib/X11
ln -s /usr/share/X11/XKeysymDB

Solved my keyboard problems in xorg-7
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2005-12-09 19:41:47 UTC
Donnie, should that stuff be there?  It would appear /usr/lib/X11/ might be the
right location after all:

equery b XKeysymDB
[ Searching for file(s) XKeysymDB in *... ]
x11-libs/libX11-0.99.4 (/usr/share/X11/XKeysymDB)

equery b xkb
[ Searching for file(s) xkb in *... ]
x11-apps/xkbcomp-0.99.2 (/usr/lib/X11/xkb)
x11-base/xorg-server-0.99.4-r2 (/usr/share/X11/xkb)
x11-misc/xkbdata-0.99.1-r1 (/var/lib/xkb)
x11-misc/xkbdata-0.99.1-r1 (/usr/share/X11/xkb)
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-09 23:04:41 UTC
No, datadir is the correct location. Look at any of the's. xkbcomp
installs a symlink to libdir still, but that's unnecessary because xkb now looks
in /usr/bin anyway.

Even XKeysymDB clearly indicates datadir in the autotools files.
Comment 5 Ashley Bostock 2005-12-10 02:27:22 UTC
(In reply to comment #2)
> Try:
> cd /usr/lib/X11
> ln -s /usr/share/X11/XKeysymDB
> Solved my keyboard problems in xorg-7

Just tried that and my keyboard is now functioning correctly.
Should I close this bug as fixed now? or does something in one of the ebuilds
need fixing to add this symlink in on emerging it?
Comment 6 Patrik Kullman 2005-12-10 02:59:46 UTC
As stated by the comments above, that symlink shouldn't have to be done.

Maybe there are some steps of upgrading from 6.8 to 7.0 that I'm unaware of.
Some configuration settings that are pointing wrong?
Donnie? Joshua?

Also, I can't use the flash-plugin anymore.
First it segfaulted because of XErrorDB, when I symlinked that like I did with
XKeysymDB, it segfaulted on some missing locale.
I haven't been able to figure out how to solve that yet.
Comment 7 Patrik Kullman 2005-12-10 03:02:17 UTC
114756 is a duplicate of this bug. .. or vice versa? ;)
Comment 8 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-10 16:35:23 UTC
*** Bug 114756 has been marked as a duplicate of this bug. ***
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-10 16:36:00 UTC
There is clearly some program(s) that wrongly continues to look in /usr/lib
instead of /usr/share. It's just a question of finding it.
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-10 17:03:41 UTC
The problem for KDE is due to my fix, that works as long as /usr/X11R6 does 
not exists. 
I'll fix that. 
Comment 11 Joshua Baergen (RETIRED) gentoo-dev 2005-12-18 11:44:28 UTC
Patrik: RC4 is almost in the tree now.  Drop that symlink you made and see if the problem still exists.

If it does, maybe attach your xorg.conf.
Comment 12 Patrik Kullman 2005-12-28 07:03:33 UTC
I've dropped the symlink and it seems to work (7,0,0 final) except for the Alt Gr (ISO_Level3_Shift) key.. but I guess that's another bug..
Comment 13 Joshua Baergen (RETIRED) gentoo-dev 2006-01-21 12:02:23 UTC
Good to hear Patrik.  Ashley, can you confirm?
Comment 14 Ashley Bostock 2006-01-23 10:31:50 UTC
I'm running...

emerge -pv xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] x11-base/xorg-x11-7.0  -3dfx -xprint 0 kB 

If I remove the symlink (/usr/share/X11/XKeysymDB) then pressing any keyboard keys just cycles my resolution again.

Comment 15 Rob 2006-03-21 17:40:39 UTC
Is this problem with all wm's and de's, or strictly KDE?
Comment 16 Donnie Berkholz (RETIRED) gentoo-dev 2006-03-21 20:22:54 UTC
Waiting for an answer..
Comment 17 Patrick ALLAERT 2006-04-05 14:59:33 UTC
I just switched to modular xorg (x11-base/xorg-x11-7.0-r1) and...
I don't know if my bug is related to this one, the problem I have is that sometimes after pressing a special key (like F12 to open yakuake) or ALT+TAB, my keyboard stop to respond, sometimes definitely ( => need to close the session), sometimes for less than a minute.
When it occurs, even the num lock light cannot be switched.
For info, my system is depcleaned and revdep-rebuilded.
I will post more information if asked!
Comment 18 Joshua Baergen (RETIRED) gentoo-dev 2006-04-05 20:46:08 UTC
(In reply to comment #17)
> I just switched to modular xorg (x11-base/xorg-x11-7.0-r1) and...
> I don't know if my bug is related to this one...

Please file a new bug with your 'emerge info', xorg.conf, and perhaps some Xorg logs from the failure (or just in general too).

Make sure you attach the files, rather than copying and pasting them in.