Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 114671 - Mimimal PPC 2005.1 cannot find built-in DVD-ROM (on a Mac G3)
Summary: Mimimal PPC 2005.1 cannot find built-in DVD-ROM (on a Mac G3)
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: PPC Linux
: High blocker (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2005-12-06 15:44 UTC by Mike Hammill
Modified: 2006-07-19 05:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hammill 2005-12-06 15:44:50 UTC
One cannot proceed beyond "No bootable medium found" when booting the 2005.1 PPC minimal CD on a 
Mac G3 with built-in DVD-ROM (Matshitadvd-rom-sr-8583).

Reproducible: Always
Steps to Reproduce:
1. Boot up using regular Crtl-C (for CDROM)
2. Loads ramfs and says "Making tmpfs for /newroot
3. Says "Attempting to mount CD: - /dev/cdroms/cdrom0
Says "Attempting to mount CD: - /dev/hda
Proceeds with:
No bootable medium found.  Waiting for new devices...
then repeats the attemps to mout CD-ROM at the above two locations.  Ends with:
Could not find CD to boot, something else needed!

Actual Results:  
Stuck with no way to boot minimal CD

Expected Results:  
Continue on to root login

I can to to the shell and ls -l /proc/cdroms/cdrom0 that gives that it is a symbolic link to "../hda" which 
seems wrong.

Looked at "Fixed" threads like:

but none of this helped me (given, though, these fixes were for a USB CD drive).  BTW, I did not try 
unplugging and replugging in my DVD drive, as is suggested in one of the USB CD drive thread 
solutions above.

Hope you have some sort of fix!  Best regards!
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2005-12-06 17:41:38 UTC
Is that DVD-ROM SCSI?  If it is, you'll need doscsi on the command line. 
Otherwise, I'll leave this for more experienced PPC people to comment.
Comment 2 Mike Hammill 2005-12-07 07:25:04 UTC
(In reply to comment #1)
> Is that DVD-ROM SCSI?  If it is, you'll need doscsi on the command line. 
> Otherwise, I'll leave this for more experienced PPC people to comment.

This Matshita DVD-ROM is a ATAPI drive.  On the chance it uses a SCSI protocol,
I tried "doscsi" but it didn't make a difference.  I also tried using "doscsi
scandelay" as mentioned in one of the thread I referred to.  Also, I tried
"debug" with and without the other two. No luck.  Since this was the original
DVD-ROM that came with the G3, I guess someone else would have run into this
already.  Well, hopefully, anyway....  Ideas?
Comment 3 Mike Hammill 2005-12-07 15:09:25 UTC
I tried every combination now that I can think of but absolutely no luck with 2005.1 minimal CD.  I get 
the same sort of error with the 2005.0 minimal CD, but have had success in occaisonally getting it to 
get to the "livecd root#" prompt.  What works for the 2005.0 min. CD is "G3 doscsi" and I also had luck 
with "G3 doscsi video=aty128fb debug".  I one case it actually found the bootable part of the CD and 
said on its own:  "CD medium found" and mounted /newroot/dev/cdroms/cdrom0.  However, even 
getting this far with the 2005.0 min CD, when I look at /dev there is a /dev/hda (the CD-ROM), but no 
/dev/hdc (the ATA harddrive).  This is a relatively large hard drive (300GB), but Mac OS X 10.4 sees it 
(as at least a 128GB drive), and the Ubtuntu LiveCD also sees it.

It occurs to me that a possible (though somewhat sad) workaround is to boot off the Ubuntu LiveCD, 
partition the hard disk, bring down the Gentoo stage3 and snapshot, then proceed building the thing 
for Gentoo.  Am I going down the wrong road for a workaround?   Advice kindly appreciated.
Comment 4 Lars Weiler (RETIRED) gentoo-dev 2005-12-17 19:29:20 UTC
Nice to know that the ubuntu-CD works.  I wonder what they do different...

But you can boot that CD and use a shell for partitioning and changing into the chroot environment with a downloaded Gentoo tar-ball.
Comment 5 Mike Hammill 2005-12-19 07:51:23 UTC
I don't know what the ubuntu folks are doing different.  From what I could tell, the problem on the Gentoo side seems to be related to udev.

Thanks for letting me know I could go ahead with the Gentoo install after getting the Gentoo "goodies" (snapshot, stage3) via Ubuntu.  I'm a bit suspicious that it will work to set up LVM under Ubuntu and expect it to work with Gentoo, though.  Another reason to hope that the Gentoo PPC CDs will work  on PowerMac G3s in the 2006.0 version.

By the way, I *was* able to install Gentoo from the minimal Gentoo 2005.1 CD on a PowerMac G4.  It's been up humming along nicely for several days now.  This was a "franken-mac" (zip from a pc, cdrom from a unix box) but there was no problem with the Gentoo CD and that machine.  The G3 with the ship-to-order DVD, though, which was the subject of this bug, is still a no go.
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2005-12-19 10:10:32 UTC
Try "scandelay" as an option.  It adds an additoinal 10 seconds to the detection so slower media can be found properly.
Comment 7 Mike Hammill 2005-12-23 01:30:52 UTC
Good news: scandelay fixed the problem on the a *different* G3 (the one with a built-to-order CD-ROM drive instead of a built-to-order DVD-ROM).  Great!  Booted without problem with minimal Live CD 2005.1.  That makes my G4 and one G3 Gentooable!

Bad news: using scandelay made no difference on the Mac G3 I have with built-to-order (via Apple) DVD-ROM.  I tried multiple times making sure I spelled scandelay correctly.  I know the DVD-ROM is OK, as I went ahead and installed Fedora Core 4 on that machine via an FC4 install DVD last week.  The OpenFirmware on that machine also seems OK.   With the same Gentoo minimal Live CD 2005.1 that works with scandelay in the *different* G3 noted above, I get the same errors on this machine as previously noted.  Unfortunately, this bug still stands (for this configuration).  Thought I should say something as you're probably working on the 2006 Live CD now.
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2006-03-17 06:14:56 UTC
Please try using "dobladecenter" instead and see if that helps.  The next version of genkernel will have "dobladecenter" renamed to "slowusb" since that's what it really was designed for, but it adds some additional pauses in some other locations that could help with this.  I'm simply curious if the device node just isn't being created quick enough.
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2006-07-19 05:52:05 UTC
No resposne in over 3 months, so I'm going to assume that "dobladecenter" worked.  If this is not the case and you have time to assist in testing, please feel free to REOPEN this bug.