Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 114501 - emacs-cvs ebuild applies patches in src_compile
Summary: emacs-cvs ebuild applies patches in src_compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Matthew Kennedy (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-04 22:48 UTC by Colin Macdonald
Modified: 2006-02-09 10:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Macdonald 2005-12-04 22:48:15 UTC
emacs-cvs ebuild applies patches in src_compile instead of in src_unpack.  This
means that if one uses the ebuild command (as opposed to emerge), there can be
problems where the code is patched twice.

I think the problem could be reproduced like this:
ebuild emacs-cvs-xx.xx.ebuild unpack
ebuild emacs-cvs-xx.xx.ebuild compile  (and then ctrl-c part way through the
compile)
ebuild emacs-cvs-xx.xx.ebuild compile  (will fail because the patches have
already been applied)

The ebuilds should have a src_pack() which calls cvs_src_pack() (from
cvs.eclass) and then uses epatch.  I tried to do but was unsuccessful---I don't
know enough about eclasses.
Comment 1 Colin Macdonald 2006-02-09 10:55:13 UTC
Fixed in emacs-cvs-22.0.50-r1 (currently masked).