Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 114204 - Emerge of media-video/vlc-0.8.1-r1 fails
Summary: Emerge of media-video/vlc-0.8.1-r1 fails
Status: RESOLVED DUPLICATE of bug 108884
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Media-video project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-01 15:23 UTC by matthew.cline
Modified: 2005-12-01 16:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matthew.cline 2005-12-01 15:23:15 UTC
Trying to rebuild app-video/vlc-0.8.1-r1 fails with this error:

make[5]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
make  all-recursive
make[6]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
make[7]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
make[7]: Nothing to be done for `all-am'.
make[7]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
make[6]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
make[5]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/dmo'
Making all in ffmpeg
make[5]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[6]: Entering directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../..   -DSYS_LINUX
-I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin
ffmpeg` -Wsign-compare -Wall -O2 -march=athlon-xp -mtune=athlon-xp -pipe
-fomit-frame-pointer -pipe -MT libffmpeg_a-ffmpeg.o -MD -MP -MF
".deps/libffmpeg_a-ffmpeg.Tpo" \
  -c -o libffmpeg_a-ffmpeg.o `test -f 'ffmpeg.c' || echo './'`ffmpeg.c; \
then mv -f ".deps/libffmpeg_a-ffmpeg.Tpo" ".deps/libffmpeg_a-ffmpeg.Po"; \
else rm -f ".deps/libffmpeg_a-ffmpeg.Tpo"; exit 1; \
fi
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../..   -DSYS_LINUX
-I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin
ffmpeg` -Wsign-compare -Wall -O2 -march=athlon-xp -mtune=athlon-xp -pipe
-fomit-frame-pointer -pipe -MT libffmpeg_a-video.o -MD -MP -MF
".deps/libffmpeg_a-video.Tpo" \
  -c -o libffmpeg_a-video.o `test -f 'video.c' || echo './'`video.c; \
then mv -f ".deps/libffmpeg_a-video.Tpo" ".deps/libffmpeg_a-video.Po"; \
else rm -f ".deps/libffmpeg_a-video.Tpo"; exit 1; \
fi
video.c: In function `ffmpeg_NewPictBuf':
video.c:183: error: structure has no member named `frame_rate'
video.c:183: error: structure has no member named `frame_rate_base'
video.c:185: error: structure has no member named `frame_rate'
video.c:186: error: structure has no member named `frame_rate_base'
video.c: In function `DecodeVideo__ffmpeg':
video.c:634: error: structure has no member named `frame_rate'
video.c:638: error: structure has no member named `frame_rate_base'
video.c:639: error: structure has no member named `frame_rate

Reproducible: Always
Steps to Reproduce:
1. emerge vlc
2.
3.

Actual Results:  
Buld fails

Expected Results:  
successful emerge of ebuild

Here is my emerge info:

Portage 2.0.51.22-r3 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r3,
2.6.14-gentoo-r2 i686)
=================================================================
System uname: 2.6.14-gentoo-r2 i686 AMD Athlon(tm) 
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks prelink sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/
http://gentoo.cites.uiuc.edu/pub/gentoo/ http://gentoo.mirrored.ca/"
MAKEOPTS="-j2"
PKGDIR="/usr/local/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acpi alsa apache2 apm audiofile avi bash-completion
bitmap-fonts bonobo bzip2 bzlib ccache cdb cddb cdr crypt cups curl doc dts eds
emboss encode esd ethereal exif expat fam ffmpeg firefox flac foomaticdb fortran
gd gif glut gnome gpm gstreamer gtk gtk2 gtkhtml guile hbci idn imlib innodb
ithreads java jpeg jpeg2k junit lcms libg++ libwww mad mikmod mmx mmxext mng
motif mp3 mpeg ncurses nls nptl nvidia offensive ofx ogg oggvorbis opengl oss
pam pcre pdflib perl pic png pthreads python quicktime quotes readline real ruby
sdl snmp speex spell sse ssl svga tcltk tcpd tetex theora tiff truetype
truetype-fonts type1-fonts udev vim-with-x vorbis win32codecs x86 xine xml xml2
xmms xprint xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:55:46 UTC
I would have been really, really pleased if you searched the bugzilla a bit as 
there are other dupes.... 
You're using an ffmpeg version from ~x86 and vlc from x86.. that won't work! 

*** This bug has been marked as a duplicate of 108884 ***
Comment 2 matthew.cline 2005-12-01 16:00:03 UTC
Of course I searched for this bug before submitting it. I typed "vlc" into the
search box, which returned two hits: bugs 82128 and 113449, neither of which has
anything to do with this problem.

I figured that typing just the package name was a generic enough search term, am
I missing some kind of bugzilla magic or something?
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 16:11:05 UTC
In the bugzilla's homepage... 
 
Note: Multiple word searches require Java Script enabled.  
 Note: When searching for duplicate bugs, prefix search with 'ALL' 
 
and the second line is in bold. 
Comment 4 matthew.cline 2005-12-01 16:18:13 UTC
I did see that comment, but it really doesn't make any sense. I wasn't searching
for a duplicate bug, I was searching for an existing bug.

In any event, thank you for sharing this with me, I'll be sure to use this
before submitting anymore bugs.