Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 113599 - Muine won't emerge. Mono USE flag required.
Summary: Muine won't emerge. Mono USE flag required.
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-25 17:14 UTC by Todd Walton
Modified: 2005-11-25 17:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd Walton 2005-11-25 17:14:13 UTC
Okay, stop me if you've heard this one.  I'm trying to emerge muine, some kind
of music player.  But the emerge fails with:
" * In order to compile muine, you need to have sys-apps/dbus emerged
 * with 'mono' in your USE flags. Please add that flag, re-emerge
 * dbus, and then emerge muine.

!!! ERROR: media-sound/muine-0.8.3 failed.
!!! Function pkg_setup, Line 67, Exitcode 0
!!! sys-apps/dbus is missing the .NET binding.
!!! If you need support, post the topmost build error, NOT this status message."

I always thought that USE flags would never block a build.  That if an ebuild
really needed some piece of software, it would handle it itself.  Sure, I say,
install what Mono stuff you have to get this muine working, just don't install
it anywhere else.  Shouldn't the muine ebuild (/portage) handle this dependency
itself?


Reproducible: Always
Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-11-25 17:16:24 UTC
Portage cannot handle such dependencies (yet), sorry.

*** This bug has been marked as a duplicate of 2272 ***