Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 113163 - Modular X - Full screen apps crash on exit (will be fixed in >Mesa-6.4)
Summary: Modular X - Full screen apps crash on exit (will be fixed in >Mesa-6.4)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
Depends on:
Blocks: 112004
  Show dependency tree
Reported: 2005-11-21 07:07 UTC by James Le Cuirot
Modified: 2005-12-04 12:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

xorg.conf (xorg.conf,4.90 KB, text/plain)
2005-11-27 12:22 UTC, James Le Cuirot
Xorg.0.log (Xorg.0.log,46.21 KB, text/plain)
2005-11-27 12:25 UTC, James Le Cuirot

Note You need to log in before you can comment on or make changes to this bug.
Description James Le Cuirot gentoo-dev 2005-11-21 07:07:19 UTC
Most full screen apps (i.e games) are crashing on exit in modular X. Neverball 
and Trackballs both exit with "*** glibc detected *** free(): invalid pointer" 
and fail to set the resolution back. Unreal Tournament and Return To Castle 
Wolfenstein appear to crash the X server. I tried setting the resolution of 
Trackballs to be the same as my desktop but the crash still occurs. I also tried 
recompiling Neverball.

I have an ATI Radeon 345M IGP. I've had random crashing problems with the DRI 
module for months now (only just found out what it was) but I think this is a 
separate issue.
Comment 1 Joshua Baergen (RETIRED) gentoo-dev 2005-11-27 10:52:38 UTC
Could you post your 'emerge info' and attach your xorg.conf and Xorg.x.log please?
Comment 2 James Le Cuirot gentoo-dev 2005-11-27 12:22:35 UTC
Created attachment 73686 [details]

Sure. I'm using "NoTrapSignals" in xorg.conf to catch this other crashing
problem I have. I had this problem before I added that line.

Portage 2.0.53_rc7 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2,
2.6.14-suspend2-r2 i686)
System uname: 2.6.14-suspend2-r2 i686 Mobile Intel(R) Pentium(R) 4     CPU
Gentoo Base System version 1.12.0_pre10
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632)
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=pentium4 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/texmf/web2c
CXXFLAGS="-march=pentium4 -O2 -pipe"
FEATURES="autoconfig ccache distlocks noauto sandbox sfperms"
PORTDIR_OVERLAY="/usr/local/portage /home/chewi/chewi-overlay"
USE="x86 16bit 3ds 7zip S3TC X X509 Xaw3d a52 aac aalib acpi aim allegro alsa
amd apache2 audiofile bash-completion berkdb bitmap-fonts blender-game bzip2
cap cardbus cdda cddb cdparanoia cdr cdrom crosscompile crypt cscope css cups
curl dba dedicated dga dhcp dillo directfb dri dv dvd dvdr dvdread emoticon
encode esd examples exif expat fam fastcgi fb fbcon fbdev fbsplash ffmpeg fftw
firefox flac fluidsynth fmod foomaticdb fortran ftp gd-external gdbm ggi gif
gimp gimpprint gkrellm glut gphoto2 gpm gstreamer gtk gtk2 icq idn ieee1394
imagemagick imap imlib jabber jack jack-tmpfs java javascript joystick jpeg
junit kqemu ladcca ladspa lcms libg++ libsamplerate libwww linguas_en_GB lirc
live lj lufsusermount lzo m17n-lib mad maildir mbox mbrola mikmod ming mmx
mmxext mng motif mozilla moznocompose moznoirc moznomail mozp3p mozsvg mp3 mpeg
mpeg2 mpeg4 mplayer mppe-mppc msn music mysql ncurses network nfs nls nocd nptl
nsplugin ntfs offensive ogg oggvorbis openal opengl oss pcmcia pcre pdflib php
png pnp posix postgres ppds python qt quicktime readline real recode reiserfs
rtc ruby samba scanner sdl session slang socks5 sounds spamassassin speex spell
sqlite sse sse2 ssl startup-notification subversion svg svga svgz sysfs tcltk
tcpd tetex tga theora threads tiff timidity transparent-proxy truetype
truetype-fonts type1 type1-fonts udev unicode usb userlocales utf8 v4l v4l2 vcd
videos vim vim-pager vim-with-x vnc vorbis wifi win32codecs wmf wxwindows xanim
xchattext xface xine xml2 xmms xpm xprint xrandr xscreensaver xv xvid xvmc
yahoo zip zlib video_cards_radeon userland_GNU kernel_linux elibc_glibc"
Comment 3 James Le Cuirot gentoo-dev 2005-11-27 12:25:33 UTC
Created attachment 73687 [details]
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2005-11-27 13:31:19 UTC
Try without RENDER acceleration (Option "RenderAccel" "Disable" in your video
driver section will do it I think).
Comment 5 Joshua Baergen (RETIRED) gentoo-dev 2005-11-27 13:34:17 UTC
Nevermind, I just reproduced this on my 855GM.

This worked fine on 6.8.2 I'm assuming?
Comment 6 James Le Cuirot gentoo-dev 2005-11-27 14:43:06 UTC
I know that RENDER acceleration is buggy because I get font corruption in 
OpenOffice unless I turn it off.

Yep it worked fine in 6.8.2. Any ideas then?
Comment 7 Joshua Baergen (RETIRED) gentoo-dev 2005-11-27 15:17:06 UTC
(In reply to comment #6)
> I know that RENDER acceleration is buggy because I get font corruption in 
> OpenOffice unless I turn it off.

This might be fixed in an upcoming version of 7.0, but I'm not 100% certain.

> Yep it worked fine in 6.8.2. Any ideas then?

Please file an upstream bug at and post the link here.
Comment 8 James Le Cuirot gentoo-dev 2005-11-29 08:52:27 UTC
I made the following bug report upstream and eventually got told that it's 
already been fixed in Mesa CVS. I gave CVS a try and it worked. (-: The fix 
should be in the upcoming Mesa 6.5 release.
Comment 9 Joshua Baergen (RETIRED) gentoo-dev 2005-11-29 11:29:56 UTC
Awesome, thanks :)
Comment 10 Donnie Berkholz (RETIRED) gentoo-dev 2005-11-29 12:12:44 UTC
Actually think this was also fixed in the 6.4 branch, meaning it'll hit Xorg 7.0.
Comment 11 James Le Cuirot gentoo-dev 2005-11-29 13:32:56 UTC
I was using mesa-6.4-r1 though?
Comment 12 Joshua Baergen (RETIRED) gentoo-dev 2005-11-29 15:23:39 UTC
What he means is we'll probably see it in some 6.4.x version that will be a part
of the 7.0 release.
Comment 13 Joshua Baergen (RETIRED) gentoo-dev 2005-12-04 09:35:59 UTC
James, this seems fixed for me in 6.4.1.  How about you?
Comment 14 James Le Cuirot gentoo-dev 2005-12-04 12:25:51 UTC
Yep works great. (-:
Comment 15 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-04 12:30:14 UTC
Comment 16 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-04 12:30:40 UTC