Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 112538 - FXRuby ebuild getting old
Summary: FXRuby ebuild getting old
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-14 12:08 UTC by Diego Cano Lagneaux
Modified: 2007-07-23 18:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Cano Lagneaux 2005-11-14 12:08:59 UTC
Last versions of fxruby in portage are 1.2.2 (stable) and 1.2.6 (hardmasked). 1.
2.6 was released on April 14.
Actual last version of fxruby is 1.4.3.
Since 1.2.x versions of fxruby correspond to Fox 1.2 and versions 1.4.x of 
fxruby correspond to Fox 1.4, I think it is about time to make available some 1.
4.x version of fxruby.

Reproducible: Always
Steps to Reproduce:
1.
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2005-11-14 12:21:09 UTC
can you supply an ebuild? 
Comment 2 Diego Cano Lagneaux 2005-11-14 13:29:16 UTC
I am trying to, but I can not get it to work. I always step on a compile error.
I actually have find one reference to the error I have on their mailing list, 
but the solution found was 'fresh install of Fox' which does not seem to help 
here.
I will try to post on the FXRuby mailing list tomorrow to see if anybody can 
help about it.
Comment 3 Diego Cano Lagneaux 2005-11-16 05:40:41 UTC
OK, I have mailed the FXRuby users mailing list and so discovered that FXRuby 1.
4.x needs FOX >1.4.11.
Since Fox v1.4.11 is the last 'not hardmasked' Fox in Portage, it cannot work.

I have seen in the profiles/packages.masked that >fox-1.4.11 is masked because 
of some 'new fox layout' for 'testing'.
So now I know that I should test, and whom I have to contact about this.

Thanks for your time
Comment 4 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2006-09-01 20:29:49 UTC
>=fox-1.4.11 is no longer p.masked. If you contribute an ebuild, I will test it and push it in. I'm not much interested in this because I don't know fox.
Comment 5 M. Edward Borasky 2006-09-03 17:02:58 UTC
fxruby-1.4.6 and fxruby-1.6.1 are available in the Ruby "gem" repository as of this posting. What I don't know is whether "freeride" will work with either of them. I may load the gems and test "freeride" later this weekend.
Comment 6 M. Edward Borasky 2006-09-29 07:19:19 UTC
(In reply to comment #5)
> fxruby-1.4.6 and fxruby-1.6.1 are available in the Ruby "gem" repository as of
> this posting. What I don't know is whether "freeride" will work with either of
> them. I may load the gems and test "freeride" later this weekend.
> 
I haven't been able to get the gems to work. gem claims they have installed, but they throw compile errors (gcc 4.1.1). I'm going to try to track down the upstream folks about that; I'm on the ruby-talk mailing list. There's some debate about the "best" GUI toolkit for Ruby and the Fox advocates might be willing to help.
Comment 7 Matti Bickel (RETIRED) gentoo-dev 2006-10-22 10:12:03 UTC
For the archives: upstream effectivly responded to the bug as WONTFIX, i'm trying to clean up the mess and bring some new and happy fox/fxruby/fxscintilla ebuilds to the tree.
Comment 8 M. Edward Borasky 2006-10-22 14:36:52 UTC
(In reply to comment #7)
> For the archives: upstream effectivly responded to the bug as WONTFIX, i'm
> trying to clean up the mess and bring some new and happy fox/fxruby/fxscintilla
> ebuilds to the tree.
> 
The last "named" fxscintilla I saw was 0.63, which supports fox 1.4. I've got a few free hours (RubyConf 2006 just shut down) so I think I'll see if I get get the upstread fxscintilla "latest" to build. The last time I tried their CVS/SVN source it died a painful death.
Comment 9 M. Edward Borasky 2006-10-22 14:48:24 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > For the archives: upstream effectivly responded to the bug as WONTFIX, i'm
> > trying to clean up the mess and bring some new and happy fox/fxruby/fxscintilla
> > ebuilds to the tree.
> > 
> The last "named" fxscintilla I saw was 0.63, which supports fox 1.4. I've got a
> few free hours (RubyConf 2006 just shut down) so I think I'll see if I get get
> the upstread fxscintilla "latest" to build. The last time I tried their CVS/SVN
> source it died a painful death.
> 


The fxscintilla release 0.71 *just* (19 October 2006) appeared on Savannah

http://download.savannah.nongnu.org/releases/fxscintilla/fxscintilla-1.71.tar.gz

It looks like they release every six months. This one claims to support Fox 1.6; testing in progress with GCC 4.1.1 and Fox 1.6.14 on Atlhon XP.
Comment 10 M. Edward Borasky 2006-10-22 15:50:38 UTC
fxscintilla builds fine from the upstream source. However, FXRuby does *not* build fine from the upstream source! I think I have a patch for it, but I am just about to send the upstream developer the info. He has a missing flag in a Makefile.
Comment 11 M. Edward Borasky 2006-10-22 16:07:03 UTC
Here's the upstream (RubyForge) bug. I just added a note on what I think the problem is, but I don't know if he'll reopen the bug. Meanwhile, if I'm correct, the 1.4 FXRuby ebuild should be OK, although you'll need at least FXScintilla 0.63 for 1.4.

http://rubyforge.org/tracker/index.php?func=detail&aid=5969&group_id=300&atid=1223

Comment 12 Hans de Graaff gentoo-dev 2007-07-21 19:54:10 UTC
Given that there are newer versions of fxruby and the other packages in the tree I'm wondering if this bug can't be closed?
Comment 13 M. Edward Borasky 2007-07-21 21:14:08 UTC
I pretty much gave up on FreeRide and bought Komodo for a Ruby IDE. There were too many broken dependencies and swamped volunteers and bugs, etc., in the whole FreeRide chain. So "WONTFIX" sounds like a good resolution for this bug, unless there's been some improvement in the upstream situation.
Comment 14 Hans de Graaff gentoo-dev 2007-07-23 18:12:29 UTC
WONTFIX is fine with me. If there are problems with the current version of fxruby then please open new bugs for them.

Thanks for the feedback.