Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 112353 - smac-6.0a dies while (or after?) patching
Summary: smac-6.0a dies while (or after?) patching
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
: 112384 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-12 17:39 UTC by Niels
Modified: 2005-11-14 06:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niels 2005-11-12 17:39:47 UTC
When trying to emerge smac-6.0a with:
 ACCEPT_KEYWORDS="~x86" emerge smac-6.0a
the whole Process dies with the following error:

>>> Install smac-6.0a into /var/tmp/portage/smac-6.0a/image/ category games-strategy
 * Copying files... this may take a while...

!!! ERROR: games-strategy/smac-6.0a failed.
!!! Function src_install, Line 61, Exitcode 3
!!! patching
!!! If you need support, post the topmost build error, NOT this status message.

It seems that verifying patch.dat works but patching itself does not...

Reproducible: Always
Steps to Reproduce:
1. mount alpha centauri cdrom (or export a folder as CDROOT)
2. emerge smac-6.0a


Actual Results:  
See the Error posted above.

Expected Results:  
Should have finished.

Portage 2.0.51.22-r3 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2,
2.6.12-gentoo-r10 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r10 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks notitles sandbox sfperms strict
userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.inode.at"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d a52 aac aalib accessibility acl acpi aim alsa arts audiofile
avi bcmath berkdb bitmap-fonts bmp bzip2 calendar caps cdparanoia cdr crypt
cscop ctype cups curl curlwrappers dga dio directfb divx4linux doc dri dts dv
dvd dvdr dvdread eds emboss encode esd ethereal exif expat fam fastcgi fbcon
ffmpeg flac flash foomaticdb fortran ftp gd ggi gif ginac glup glut gnome
gphoto2 gpm gstreamer gtk gtk2 howl icq idea idn ieee1394 imagemagick imlib ipv6
irc jabber java javascript joystick jpeg kde kerberos lcms libcaca libg++ lzw
lzw-tiff mad mikmod mime ming mmap mng motif mozilla mp3 mpeg msn mysql nas
ncurses nls nptl nsplugin nvidia ogg oggvorbis openal opengl osc pam pcre pdflib
perl png ppds python qt quicktime readline samba scanner sdl simplexml sndfile
sockets speex spell ssl svg szip tcltk tcpd theora tiff truetype truetype-fonts
type1-fonts udev unicode usb userlocales v41 vcd videos vorbis wmf wxwindows
xface xine xinerama xml xml2 xmms xosd xpm xprint xsl xv xvid yahoo zlib
linguas_en linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 SpanKY gentoo-dev 2005-11-13 03:28:53 UTC
*** Bug 112384 has been marked as a duplicate of this bug. ***
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-13 07:33:52 UTC
What gave you the idea that it *would* work?
Comment 4 Niels 2005-11-13 14:08:33 UTC
It's a Patch isn't it?

However, it works with the Patch commented out in the ebuild.
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-13 14:13:46 UTC
OK.  The game does not have KEYWORDS for amd64 because it DOES NOT WORK on
amd64!  This is a simple concept.  You cannot expect us to support a BINARY game
from a company that no longer exists on a platform it DOESN'T WORK ON and we
KNOW IT.

The only "bug" here is that you tried to bypass our KEYWORDS and failed.
Comment 6 Niels 2005-11-14 00:09:29 UTC
Um... well sorry.
You meant my architecture, I didn't want to annoy you.

But as you can see I emerged it with ACCEPT_KEYWORDS="~x86" emerge smac-6.0a...

However, it works and all is well.

Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-14 06:26:43 UTC
Ehh... you do know that ACCEPT_KEYWORDS="~x86" doesn't make it think it is an
x86 or anything?  It just makes portage allow installation with those KEYWORDS.

Anyway, the package does not patch properly on amd64, which is why it does not
have amd64 KEYWORDS.

As stated in the FAQ, we don't want bugs on stuff that doesn't have the proper
KEYWORDS.

Also, you should be using /etc/portage/package.keywords rather than
ACCEPT_KEYWORDS on the command line.