Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 112221 - net-im/{gaim,pidgin} crashes with spell checking and <aspell-0.60
Summary: net-im/{gaim,pidgin} crashes with spell checking and <aspell-0.60
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
: 192890 (view as bug list)
Depends on:
Blocks: 187736
  Show dependency tree
 
Reported: 2005-11-11 14:18 UTC by Steven Hay
Modified: 2009-12-17 10:34 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of aspell (aspell.config.txt,5.62 KB, text/plain)
2005-12-13 17:12 UTC, Steven Hay
Details
Output of pdigin on loading (pidgin-output.txt,24.29 KB, text/plain)
2007-05-05 18:04 UTC, Steven Hay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Hay 2005-11-11 14:18:54 UTC
gaim crashes upon trying to write a message for sending or receiving a message.
 Problem is averted by turning off spell checking.


Reproducible: Always
Steps to Reproduce:
1. enable spell check
2. run gaim
3. try to send a message

Actual Results:  
crash:

hays@church ~ $ gaim
*** glibc detected *** free(): invalid pointer: 0x0841b618 ***
Aborted



gdb backtrace:
<hr>
hays@church ~ $ MALLOC_CHECK=2 gdb gaim
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
 
(gdb) handle SIGPIPE nostop
Signal        Stop      Print   Pass to program Description
SIGPIPE       No        Yes     Yes             Broken pipe
(gdb) run
Starting program: /usr/bin/gaim
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1487385952 (LWP 9123)]
*** glibc detected *** free(): invalid pointer: 0x08426d90 ***
 
Program received signal SIGABRT, Aborted.
[Switching to Thread -1487385952 (LWP 9123)]
0xffffe410 in __kernel_vsyscall ()
(gdb) bt full
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xa77aa391 in raise () from /lib/tls/libc.so.6
No symbol table info available.
#2  0xa77abdad in abort () from /lib/tls/libc.so.6
No symbol table info available.
#3  0xa77dd4a7 in __fsetlocking () from /lib/tls/libc.so.6
No symbol table info available.
#4  0xa77e32c7 in malloc_usable_size () from /lib/tls/libc.so.6
No symbol table info available.
#5  0xa77e3d09 in free () from /lib/tls/libc.so.6
No symbol table info available.
#6  0xa683e3f1 in operator delete ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/libstdc++.so.6
No symbol table info available.
#7  0xa681e455 in std::string::_Rep::_M_destroy ()
   from /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/libstdc++.so.6
No symbol table info available.
#8  0xa68d5b67 in aspeller::find_file () from /usr/lib/libaspell.so.15
No symbol table info available.
#9  0xa68e8e7d in aspeller::Language::setup () from /usr/lib/libaspell.so.15
No symbol table info available.
#10 0xa68b73ad in aspeller::DataSet::set_check_lang ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libaspell.so.15
No symbol table info available.
#11 0xa68c7b18 in aspeller_default_readonly_ws::ReadOnlyWS::load ()
   from /usr/lib/libaspell.so.15
No symbol table info available.
#12 0xa68b8e75 in aspeller::add_data_set () from /usr/lib/libaspell.so.15
No symbol table info available.
#13 0xa68d6e32 in aspeller::MultiWS::load () from /usr/lib/libaspell.so.15
No symbol table info available.
#14 0xa68b8e75 in aspeller::add_data_set () from /usr/lib/libaspell.so.15
No symbol table info available.
#15 0xa68c385b in aspeller::SpellerImpl::setup () from /usr/lib/libaspell.so.15
No symbol table info available.
#16 0xa6897e88 in acommon::new_speller () from /usr/lib/libaspell.so.15
No symbol table info available.
#17 0xa6893192 in new_aspell_speller () from /usr/lib/libaspell.so.15
No symbol table info available.
#18 0xa6908166 in ?? () from /usr/lib/enchant/libenchant_aspell.so
No symbol table info available.
#19 0x084250b0 in ?? ()
No symbol table info available.
#20 0xa69085ed in ?? () from /usr/lib/enchant/libenchant_aspell.so
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#21 0xa69085e7 in ?? () from /usr/lib/enchant/libenchant_aspell.so
No symbol table info available.
#22 0xa6908118 in ?? () from /usr/lib/enchant/libenchant_aspell.so
No symbol table info available.
#23 0xa7e78ab4 in ?? () from /usr/lib/libenchant.so.1
No symbol table info available.
#24 0x00000000 in ?? ()
No symbol table info available.
#25 0x084246b0 in ?? ()
No symbol table info available.
#26 0xa7e76f85 in enchant_broker_request_dict () from /usr/lib/libenchant.so.1
No symbol table info available.
#27 0x084246b0 in ?? ()
No symbol table info available.
#28 0x084226b0 in ?? ()
No symbol table info available.
#29 0x0000002f in ?? ()
No symbol table info available.
#30 0xa7e7a0b8 in ?? () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#31 0xa7e7459c in ?? () from /usr/lib/libenchant.so.1
No symbol table info available.
#32 0xa7e7e6e8 in ?? () from /usr/lib/libgtkspell.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#33 0xa7e7d465 in debug () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#34 0x08422650 in ?? ()
No symbol table info available.
#35 0x084038c8 in ?? ()
No symbol table info available.
#36 0x084226b0 in ?? ()
No symbol table info available.
#37 0x00000000 in ?? ()
No symbol table info available.
#38 0xa7e7e6e8 in ?? () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#39 0xa7e7d465 in debug () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#40 0x08422650 in ?? ()
No symbol table info available.
#41 0x0841b528 in ?? ()
No symbol table info available.
#42 0xa7e7c6db in gtkspell_error_quark () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#43 0xa7e7d465 in debug () from /usr/lib/libgtkspell.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#44 0x0841b528 in ?? ()
No symbol table info available.
#45 0xa79d380f in g_malloc0 () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#46 0x00000001 in ?? ()
No symbol table info available.
#47 0x00000020 in ?? ()
No symbol table info available.
#48 0x00000000 in ?? ()
No symbol table info available.
#49 0xa7a2864c in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#50 0xa7e7e6e8 in ?? () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#51 0xafd00fc0 in ?? ()
No symbol table info available.
#52 0xa7e7d47e in debug () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#53 0xa7e7cd02 in gtkspell_new_attach () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#54 0xafd00fc0 in ?? ()
No symbol table info available.
#55 0xa7e7d47e in debug () from /usr/lib/libgtkspell.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#56 0x084225d0 in ?? ()
No symbol table info available.
#57 0xa7a467fc in g_param_spec_override () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#58 0x0805523a in ?? ()
No symbol table info available.
#59 0xa7895ff4 in ?? () from /lib/tls/libc.so.6
No symbol table info available.
#60 0xa7897820 in __malloc_initialize_hook () from /lib/tls/libc.so.6
No symbol table info available.
#61 0x00000014 in ?? ()
No symbol table info available.
#62 0x08422650 in ?? ()
No symbol table info available.
#63 0xa7e798ec in ?? () from /usr/lib/libgtkspell.so.0
No symbol table info available.
#64 0xa7ecca58 in ?? ()
No symbol table info available.
#65 0x00000014 in ?? ()
No symbol table info available.
#66 0xafd00f60 in ?? ()
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#67 0x00000010 in ?? ()
No symbol table info available.
#68 0x00000000 in ?? ()
No symbol table info available.
#69 0x084225d8 in ?? ()
No symbol table info available.
#70 0xa7a45b70 in g_param_spec_override () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#71 0x0841c750 in ?? ()
No symbol table info available.
#72 0x0841c770 in ?? ()
No symbol table info available.
#73 0xa7efddfb in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
No symbol table info available.
Previous frame inner to this frame (corrupt stack?)
(gdb)
(gdb) quit
The program is running.  Exit anyway? (y or n) y
<hr>
hays@church ~ $ emerge info
Portage 2.0.51.22-r3 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2,
2.6.12-ck6 i686)
=================================================================
System uname: 2.6.12-ck6 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -fweb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -fweb"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://knuth/gentoo-portage"
USE="x86 3dnow 3dnowext X aac acl alsa apm arts audiofile avi berkdb
bitmap-fonts bzip2 cdr cjk crypt cups curl dts dvd dvdr eds emboss encode esd
exif expat fam ffmpeg flac foomaticdb fortran gd gdbm gif glut gnome gnutls gpm
gstreamer gtk gtk2 guile idn imagemagick imlib ipv6 java jpeg junit lcms libg++
libwww mad matroska mhash mikmod mmx mmxext mng motif mozilla mozsvg mp3 mpeg
ncurses nls nptl ogg oggvorbis opengl oss pam pcre pdflib perl php png python
quicktime readline samba sdl spell sse ssl svga tcpd tetex theora tiff truetype
truetype-fonts type1-fonts udev unicode vorbis win32codecs xine xml xml2 xmms xv
xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
<hr>
Comment 1 Steven Hay 2005-11-11 14:28:14 UTC
I should have said:

gaim 1.5.0
enchant 1.1.6
aspell 0.50.5-r4

Comment 2 Don Seiler (RETIRED) gentoo-dev 2005-11-13 21:39:28 UTC
what version of gtkspell do you have?

gaim only uses gtkspell directly.  aspell and enchant are used by gtkspell.
Comment 3 Steven Hay 2005-11-14 03:12:37 UTC
[ebuild   R   ] app-text/gtkspell-2.0.11
Comment 4 Don Seiler (RETIRED) gentoo-dev 2005-11-14 11:18:54 UTC
And you have an aspell dictionary installed as well?
Comment 5 Steven Hay 2005-11-14 17:37:44 UTC
[ebuild   R   ] app-dicts/aspell-en-0.51.1

Note that gaim worked and then it stopped working, but unfortunately I can't
really pin down when it stopped working because I hardly ever get or send AIM
messages.  So something has broken and re-emerging everything has not fixed the
problem.

Comment 6 Robert Davis 2005-12-13 14:06:55 UTC
Look like aspell getting an error.  You might try running "aspell config" just
to see if aspell seems to be working.  the data-dir should contain your
dictionary info.
Comment 7 Steven Hay 2005-12-13 17:12:39 UTC
Created attachment 74679 [details]
Output of aspell
Comment 8 Steven Hay 2005-12-13 17:14:52 UTC
hays@church ~/NPGS/FEM $ ls -l /usr/share/aspell/
total 248
-rw-r--r--  1 root root 7711 Nov 15 08:15 ASCII.dat
-rw-r--r--  1 root root 7764 Nov 15 08:15 cp1250.dat
-rw-r--r--  1 root root 8034 Nov 15 08:15 cp1251.dat
-rw-r--r--  1 root root 7763 Nov 15 08:15 cp1252.dat
-rw-r--r--  1 root root 7941 Nov 15 08:15 cp1253.dat
-rw-r--r--  1 root root 7755 Nov 15 08:15 cp1254.dat
-rw-r--r--  1 root root 7880 Nov 15 08:15 cp1255.dat
-rw-r--r--  1 root root 7919 Nov 15 08:15 cp1256.dat
-rw-r--r--  1 root root 7775 Nov 15 08:15 cp1257.dat
-rw-r--r--  1 root root 7743 Nov 15 08:15 cp1258.dat
-rw-r--r--  1 root root   98 Nov 15 08:15 dvorak.kbd
-rw-r--r--  1 root root  113 Nov 15 08:17 en.dat
-rw-r--r--  1 root root 7273 Nov 15 08:17 en_phonet.dat
-rw-r--r--  1 root root 7715 Nov 15 08:15 iso8859-1.dat
-rw-r--r--  1 root root 7740 Nov 15 08:15 iso8859-10.dat
-rw-r--r--  1 root root 7733 Nov 15 08:15 iso8859-13.dat
-rw-r--r--  1 root root 7752 Nov 15 08:15 iso8859-14.dat
-rw-r--r--  1 root root 7729 Nov 15 08:15 iso8859-15.dat
-rw-r--r--  1 root root 7737 Nov 15 08:15 iso8859-2.dat
-rw-r--r--  1 root root 7726 Nov 15 08:15 iso8859-3.dat
-rw-r--r--  1 root root 7726 Nov 15 08:15 iso8859-4.dat
-rw-r--r--  1 root root 8007 Nov 15 08:15 iso8859-5.dat
-rw-r--r--  1 root root 7862 Nov 15 08:15 iso8859-6.dat
-rw-r--r--  1 root root 7890 Nov 15 08:15 iso8859-7.dat
-rw-r--r--  1 root root 7800 Nov 15 08:15 iso8859-8.dat
-rw-r--r--  1 root root 7707 Nov 15 08:15 iso8859-9.dat
-rwxr-xr-x  1 root root  532 Nov 15 08:15 ispell
-rw-r--r--  1 root root 8037 Nov 15 08:15 koi8-f.dat
-rw-r--r--  1 root root 7955 Nov 15 08:15 koi8-r.dat
-rw-r--r--  1 root root 7979 Nov 15 08:15 koi8-u.dat
-rwxr-xr-x  1 root root  118 Nov 15 08:15 spell
-rw-r--r--  1 root root   99 Nov 15 08:15 split.kbd
-rw-r--r--  1 root root  100 Nov 15 08:15 standard.kbd
-rw-r--r--  1 root root 7801 Nov 15 08:15 viscii.dat
Comment 9 Robert Davis 2005-12-19 09:37:53 UTC
Does /usr/lib/aspell have your dictionaries?  You can also create a text file with some misspelled words and run aspell -c filename and see if it works.
Comment 10 Kathryn Kulick (RETIRED) gentoo-dev 2006-06-30 09:08:36 UTC
Does this problem still persist after updates since the bug was filed?
Comment 11 Kathryn Kulick (RETIRED) gentoo-dev 2006-07-06 12:17:43 UTC
Due to no response I am going to close the bug as fixed, however if it is still an issue, feel free to re-open the bug report.
Comment 12 Steven Hay 2007-05-05 18:02:25 UTC
This problem still exists, now with pidgin.  The workaround is to compile gaim without spelling support.
Comment 13 Steven Hay 2007-05-05 18:04:40 UTC
Created attachment 118265 [details]
Output of pdigin on loading
Comment 14 Steven Hay 2007-05-05 18:09:33 UTC
[ebuild   R   ] app-text/aspell-0.50.5-r4  USE="gpm" 993 kB
[ebuild   R   ] app-text/gtkspell-2.0.11-r1  USE="-doc" 340 kB
[ebuild   R   ] net-im/pidgin-2.0.0  USE="crypt dbus gstreamer gtk nls perl spell ssl -avahi -bonjour -cjk -console -custom-cflags -debug -doc -eds -gadu -gnutls -groupwise -meanwhile -msn -prediction -qq -sasl -silc -startup-notification -tcl -tk -xscreensaver" 0 kB
Comment 15 Olivier Crete (RETIRED) gentoo-dev 2007-05-05 18:28:52 UTC
hard to find what the exact problem is... I agree there's probably something wrong with aspell or enchant. Can you paste you emerge --info ?
Comment 16 Steven Hay 2007-05-05 19:07:36 UTC
hays@church ~ $ emerge --info
Portage 2.1.2.2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r2, 2.6.19-gentoo-r5 i686)
=================================================================
System uname: 2.6.19-gentoo-r5 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 05 May 2007 07:30:09 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.3.5-r3, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -fweb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -fweb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/berkano /usr/local/portage"
SYNC="rsync://knuth/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa apache2 arts berkdb bitmap-fonts cairo cdr cjk cli cracklib crypt cups dbus dri dvd dvdr dvdread emboss encode esd fam firefox fortran gdbm gif gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jpeg kde ldap libg++ mad midi mikmod mmx mmxext mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl oss pam pcre perl php png ppds pppd python qt3 qt4 quicktime readline reflection samba sdl session spell spl sse ssl tcpd theora tiff truetype truetype-fonts type1-fonts unicode vorbis win32codecs x264 x86 xinerama xml xml2 xorg xv xvid zlib" ALSA_CARDS="ice1724" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 17 Steven Hay 2007-05-08 01:25:00 UTC
This problem seems to go away with the installation of aspell-0.60 and its associated dictionary, which is in ~x86 currently.
Comment 18 Olivier Crete (RETIRED) gentoo-dev 2007-05-08 02:02:03 UTC
seems this bug is fixed by an aspell upgrade.. any plan on marking aspell 0.60 stable one day ?
Comment 19 Wulf Krueger (RETIRED) gentoo-dev 2007-08-17 21:05:37 UTC
aspell-0.60 and its dictionaries are now marked stable on all major arches.
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2007-08-19 11:58:16 UTC
aspell-0.60.5 is stable everywhere, I guess update the dependency and be done with this?
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-09-20 14:19:33 UTC
*** Bug 192890 has been marked as a duplicate of this bug. ***
Comment 22 Devang M 2007-09-20 20:09:09 UTC
The problem still seems to be there: USE="spell" emerge -pv aspell aspell-en enchant gtkspell pidgin

[ebuild   R   ] app-text/aspell-0.60.5  USE="-examples -gpm nls" 1,714 kB
[ebuild   R   ] app-dicts/aspell-en-6.0.0  179 kB
[ebuild   R   ] app-text/enchant-1.3.0  0 kB
[ebuild   R   ] app-text/gtkspell-2.0.11-r1  USE="-doc" 0 kB
[ebuild   R   ] net-im/pidgin-2.2.0  USE="-bonjour dbus -debug -doc -eds -gadu gnutls -groupwise -gstreamer gtk -meanwhile -ncurses -networkmanager nls -perl -prediction -qq -sasl -silc spell -tcl -tk -zephyr" 7,912 kB

The startup output at the command line is a bit different, without USE="debug" the first line is: 
*** glibc detected *** pidgin: munmap_chunk(): invalid pointer: 0x00000000005e0780 ***
Followed by the backtrace and long memory map: 
http://bugs.gentoo.org/attachment.cgi?id=131186 (the attachment is with USE="debug")

I did try aspell -c file with file having three words, and an ncurses-ish interface popped up asking to either ignore or add the two badly misspelled words. Same with enchant -l file, it output the two misspelled words to the command line. gtkspell is just a library, I'm not sure how to test it. 
Comment 23 Olivier Crete (RETIRED) gentoo-dev 2008-02-16 19:55:46 UTC
need a detailed backtrace
Comment 24 Peter Volkov (RETIRED) gentoo-dev 2009-12-17 10:34:13 UTC
Devang, I guess this bug is fixed long time ago. If it is still an issue, please, update system and open new bug with new backtrace. Closing this bug.