Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 112000 - iptables need option for iptables time module
Summary: iptables need option for iptables time module
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-09 13:16 UTC by Eric Brown
Modified: 2005-11-16 11:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Brown 2005-11-09 13:16:13 UTC
I recently tried to use the iptables time module with hardened-sources 2.6.X and
I was unable to use it because itp_time.so did not exists.  I looked through the
kernel config and there isn't even an option for it presented (in fact, even in
the .config file, I could not identify a variable for it).

I found a reference on netfilter.org saying that this module is not built by
default, but that it could be included through their patching system?

Anyway, the time module sounds like a nice idea and I think it would be a nice
option to have in the kernel for iptables users.  Does anyone know how to add
this to our kernels?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 SpanKY gentoo-dev 2005-11-09 14:26:14 UTC
this would require more maintenance than it's worth

you should be able to find the patch here:
http://www.iptables.org/projects/patch-o-matic/pom-base.html#pom-base-time

it'll prob be integrated into iptables eventually
Comment 2 Eric Brown 2005-11-16 11:35:10 UTC
It's in the man page for iptables as if it's a standard feature.