Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 110982 - dev-java/bluej-bin is not installed correctly
Summary: dev-java/bluej-bin is not installed correctly
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo TreeCleaner Project
URL:
Whiteboard: REMOVED
Keywords:
Depends on: 121141
Blocks: 122772
  Show dependency tree
 
Reported: 2005-10-31 01:56 UTC by gunix
Modified: 2007-07-20 08:52 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gunix 2005-10-31 01:56:03 UTC
When starting bluej I can't create any classes, and this is because
/usr/bin/bluej misses the path to the tools.jar file.
Here is the correct /usr/bin/bluej that should be installed (the first part is
the original bluej file that is commented out).

#!/bin/sh
#APPBASE="/usr/share/bluej-bin"
#CP=`java-config -p bluej-bin`:`java-config -p antlr`
#`java-config --java` -cp "${CP}" bluej.Boot $*

APPBASE="/usr/share/bluej-bin"
CP=`java-config -p bluej-bin`:`java-config -p
antlr`://opt/sun-jdk-1.4.2.09/lib/tools.jar
`java-config --java` -cp "${CP}" bluej.Boot $*


The java-config should produce the path to the tools.jar file also.
So java-config might need to be modified also?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Gilles Dartiguelongue gentoo-dev 2006-06-15 06:47:37 UTC
This bug was solved for me by upgrading to 2.1.1, please report if you still have this problem.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-06-27 03:30:34 UTC
Re-assign wrt Bug 23545, maintainer retired.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 08:52:53 UTC
10:47:12 <+CIA-24> drac * gentoo-x86/dev-java/bluej-bin/ (9 files in 2 dirs): Remove p.masked pkg. Treecleaners, should have been gone in 2006..