Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110976 - muine 0.8.3 does not start
Summary: muine 0.8.3 does not start
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-31 00:46 UTC by Fabian Zeindl
Modified: 2006-03-29 22:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gdb backtrace of muine (muine.log,17.58 KB, text/plain)
2005-11-29 15:58 UTC, Jose daLuz
Details
second muine backtrace (muine2.log,32.75 KB, text/plain)
2005-11-29 16:34 UTC, Jose daLuz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Zeindl 2005-10-31 00:46:41 UTC
I emerge muine 0.8.3 (~x86). Everything worked fine, however when I type "muine"
it says:

Failed to export D-Bus object: Unable to determine the address of the message bus
(muine:22878): Gtk-WARNING **: Error loading theme icon for stock: Symbol
Comment 1 Fabian Zeindl 2005-10-31 00:46:41 UTC
I emerge muine 0.8.3 (~x86). Everything worked fine, however when I type "muine"
it says:

Failed to export D-Bus object: Unable to determine the address of the message bus
(muine:22878): Gtk-WARNING **: Error loading theme icon for stock: Symbol
»stock_media-play« not present in theme
(muine:22878): Gtk-WARNING **: Error loading theme icon for stock: Symbol
»stock_media-prev« not present in theme
(muine:22878): Gtk-WARNING **: Error loading theme icon for stock: Symbol
»stock_media-next« not present in theme
(muine:22878): Gtk-WARNING **: Error loading theme icon for stock: Symbol
»gnome-dev-cdrom-audio« not present in theme
Segmentation fault

Reproducible: Always
Steps to Reproduce:
1. emerge muine
2. start it by typing muine
3.
Comment 2 Spoiala Cristian 2005-11-18 02:45:32 UTC
The reporter solved the problem.

http://mail.gnome.org/archives/muine-list/2005-November/msg00010.html
Comment 3 Jose daLuz 2005-11-29 14:47:02 UTC
Running as a normal user, muine segfaults.  Running as root, I get the following:
Failed to export D-Bus object: Unable to determine the address of the message bus

** (muine:8056): WARNING **: No GConf default audio sink key and osssink doesn't
work

Unhandled Exception: System.Exception: Failed to initialize the audio backend:
Could not render default GStreamer audio output sink
in <0x000b1> Muine.PlaylistWindow:SetupPlayer ()
in <0x001b2> Muine.PlaylistWindow:.ctor ()
in <0x004e2> Muine.Global:Main (System.String[] args)

In the latter case, there is no Segmentation fault message, but muine does not
start.

 emerge --info
Portage 2.0.53_rc7 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r3,
2.6.14-ck5 x86_64)
=================================================================
System uname: 2.6.14-ck5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0_pre11
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.14
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20-r1
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env
/usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LC_ALL="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/gentopia /usr/local/bmg-main /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aac aalib alsa audiofile avi bash-completion berkdb bitmap-fonts
bzip2 cdr crypt cups curl dbus eds emboss encode esd exif expat fam ffmpeg flac
foomaticdb fortran gdbm gif glut gnome gpm gstreamer gtk gtk2 hal howl idn
imagemagick imlib ipv6 jack java jpeg junit kde lcms ldap libwww lua lzw
lzw-tiff mad mikmod mng mono motif mozilla mp3 mpeg ncurses nls nptl ogg openal
opengl pam pcre pdflib perl pic png python qt quicktime readline recode ruby
samba sdl speex spell sqlite ssl svg tcltk tcpd tetex theora tiff truetype
truetype-fonts type1-fonts udev usb userlocales vorbis wmf xine xml2 xmms xpm xv
xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS, LINGUAS, MAKEOPTS
Comment 4 Peter Johanson (RETIRED) gentoo-dev 2005-11-29 14:56:21 UTC
Jose: this may be a different bug altogether, but who knows. The error running
as root is probably because the user instance of gconf isn't found, so it uses
root's settings (which are empty) and tries the osssink gstreamer element, which
you may not have installed. Running as root generally will not help things with
gstreamer.

All: The segfault could be coming from countless places, To really know what's
going on, you'll need to get a useful gdb backtrace for me. General info on
debugging mono stuff can be found here (http://mono-project.com/Debugging), but
the quick and dirty is to add the ~/gdbinit lines as suggested by the above URL,
then do the following:

$ cd /usr/lib/muine
$ gdb mono
(gdb) set args --debug muine.exe
(gdb) run

When muine crashes, you should be able to get (hopefully), a backtrace (from all
threads).

(gdb) thread apply all backtrace

Please report the output from that (either attached as a file or pasted). Thanks.
Comment 5 Jose daLuz 2005-11-29 15:58:49 UTC
Created attachment 73816 [details]
gdb backtrace of muine

Here's the backtrace you requested.  Let me know if there's anything else I can
do to help track this down.
Comment 6 Peter Johanson (RETIRED) gentoo-dev 2005-11-29 16:04:44 UTC
Ugh. Not a particularly helpful backtrace (yet).

Couple of things:

1) after the segfault, still run the 't a a bt' to get a backtrace of *all* of
the threads, not just the thread that died.
2) For the thread that died, a lot of those look like they might be managed
calls. To figure out what calls in C# are going on there, you can do something
like this:

(gdb) call mono_print_method_from_ip (0xb5febf94)

For some of the addresses in the left hand column of the backtrace. Can you see
if any of the topmost addresses result in useful information on the managed
method calls going on?

Thanks.
Comment 7 Jose daLuz 2005-11-29 16:34:14 UTC
Created attachment 73818 [details]
second muine backtrace

Unfortunately, the backtrace stops in the first thread at "Cannot access memory
at address 0x406a7000".  If you know of a way to force it to continue past that
point I will try it.

Based on this backtrace, I tried the first 30 or so addresses with
mono_print_method_from_ip and got results from 4 of them:

IP 0x404a2439 at offset 0x79 of method Muine.Metadata:get_Artists ()
(0x404a23c0 0x404a2506)[domain 0x2aaaaab1de60 - muine.exe]

IP 0x404a1e4f at offset 0x8f of method Muine.Song:Sync (Muine.Metadata)
(0x404a1dc0 0x404a1f9b)[domain 0x2aaaaab1de60 - muine.exe]

IP 0x404a0909 at offset 0xa1 of method Muine.SongDatabase:StartSyncSong
(Muine.Song,Muine.Metadata) (0x404a0868 0x404a0970)[domain 0x2aaaaab1de60 -
muine.exe]

IP 0x4049f385 at offset 0x355 of method CheckChangesThread:ThreadFunc ()
(0x4049f030 0x4049f6fe)[domain 0x2aaaaab1de60 - muine.exe]
Comment 8 Thomas Schreck 2005-12-06 10:18:39 UTC
Hi,

I have also the problem that muine does not start at my system. Mainly because
it could not load the audio backend. I get this exception:

Unhandled Exception: System.Exception: Das Audio-Backend konnte nicht
initialisiert werden:
GStreamer-Play-Objekt konnte nicht erzeugt werden
in <0x00085> Muine.PlaylistWindow:SetupPlayer ()
in <0x00188> Muine.PlaylistWindow:.ctor ()
in <0x0034d> Muine.Global:Main (System.String[] args)


Sorry it is German.

I think it is the same problem like mentioned here: 

http://mail.gnome.org/archives/muine-list/2005-April/msg00006.html

But i have muine-0.8.3, where the patch already is in the normal source.

I really do not have any clue, why this is happening

emerge info:
-------------------------------------

Portage 2.0.51.22-r3 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2,
2.6.13 i686)
=================================================================
System uname: 2.6.13 i686 Intel(R) Pentium(R) M processor 1.60GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O3 -mcpu=i686 -pipe -msse2 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O3 -mcpu=i686 -pipe -msse2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://ftp.uni-erlangen.de/pub/mirrors/gentoo
ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://pandemonium.tiscali.de/pub/gentoo/"
LC_ALL="de_DE.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage-gentopia /usr/local/bmg-main"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acpi alsa apache2 audiofile avi berkdb bitmap-fonts bzip2 cdr crypt
cups curl dvd dvdr eds emboss encode esd ethereal exif expat fam ffmpeg flac
foomaticdb fortran gd gdbm gif glut gnome gpm gstreamer gtk gtk2 guile hal httpd
idn imagemagick imlib ipv6 jpeg junit lcms ldap libg++ libwww lua mad mhash
mikmod mmx mng mono motif mozilla mp3 mpeg mysql ncurses nls ogg oggvorbis
openal opengl oss pam pcre pdflib perl php png postgres ppds python quicktime
readline recode samba sdl slang spell sqlite sse ssl svga tcltk tcpd tetex tiff
truetype truetype-fonts type1-fonts udev unicode usb userlocales vorbis xine xml
xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS, LINGUAS
Comment 9 Jose daLuz 2006-01-21 15:51:18 UTC
I now have debugging symbols compiled in. I still get a segfault with muine-
0.8.3-r1. Here's the backtrace:

Starting program: /usr/bin/mono --debug muine.exe
[Thread debugging using libthread_db enabled]
[New Thread 46912509299488 (LWP 23293)]
[New Thread 1073822048 (LWP 23296)]
[New Thread 1075988832 (LWP 23297)]
[New Thread 1078352224 (LWP 23300)]
[New Thread 1080715616 (LWP 23301)]
[Thread 1080715616 (zombie) exited]
[New Thread 1082816864 (LWP 23302)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1082816864 (LWP 23302)]
0x00000000404a2f19 in ?? ()

(gdb) t a a bt

Thread 6 (Thread 1082816864 (LWP 23302)):
#0  0x00000000404a2f19 in ?? ()
#1  0x00002aaaabaed488 in ?? ()
#2  0x00000000408a6f70 in ?? ()
#3  0x00002aaab1546120 in ?? ()
#4  0x0000000000000001 in ?? ()
#5  0x00002aaab1546120 in ?? ()
#6  0x00002aaaaab63e40 in ?? ()
#7  0x00000000408a6f70 in ?? ()
#8  0x00000000404a292f in ?? ()
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 1078352224 (LWP 23300)):
#0  0x00002aaaab17d965 in __nanosleep_nocancel () from /lib/tls/libpthread.so.0
#1  0x00000000004b4e72 in SleepEx (ms=0, alertable=1) at threads.c:940
#2  0x000000000046da72 in ves_icall_System_Threading_Thread_Sleep_internal (ms=1000) at threads.c:607
#3  0x000000004047ee3d in ?? ()
#4  0x00000000000003e8 in ?? ()
#5  0x0000000000b17120 in ?? ()
#6  0x0000000000b09500 in ?? ()
#7  0x0000000000caabc0 in ?? ()
#8  0x000000004047ede3 in ?? ()
#9  0x0000000000b09840 in ?? ()
#10 0x0000000040465130 in ?? ()
#11 0x0000000040464ff0 in ?? ()
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 1075988832 (LWP 23297)):
#0  0x00002aaaab17abaf in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/libpthread.so.0
#1  0x00000000004ba9f0 in timedwait_signal_poll_cond (cond=0x2aaaaba7a9b8, mutex=0x2aaaaba7a990, timeout=0x0) at handles.c:1203
#2  0x00000000004bab06 in _wapi_handle_timedwait_signal_handle (handle=0x2aaaaba7a9bc, timeout=0x0) at handles.c:1272
#3  0x00000000004bba18 in WaitForSingleObjectEx (handle=0x44e, timeout=4294967295, alertable=-110) at wait.c:179
#4  0x000000000050a476 in finalizer_thread (unused=0x2aaaaba7a9bc) at gc.c:750
#5  0x000000000046f7f3 in start_wrapper (data=0x2aaaaba7a9bc) at threads.c:305
#6  0x00000000004bc964 in timed_thread_start_routine (args=0x2aaaaba7a9bc) at timed-thread.c:134
#7  0x00000000004c9ac7 in GC_start_routine ()
#8  0x00002aaaab1780fa in start_thread () from /lib/tls/libpthread.so.0
#9  0x00002aaaab5cdb63 in clone () from /lib/tls/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 1073822048 (LWP 23296)):
#0  0x00002aaaab17d965 in __nanosleep_nocancel () from /lib/tls/libpthread.so.0
#1  0x00000000004b24f4 in collection_thread (unused=0x40013260) at collection.c:43
#2  0x00002aaaab1780fa in start_thread () from /lib/tls/libpthread.so.0
#3  0x00002aaaab5cdb63 in clone () from /lib/tls/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 46912509299488 (LWP 23293)):
#0  0x00002aaaab17c76b in sem_post () from /lib/tls/libpthread.so.0
#1  0x0000000000511ca9 in GC_suspend_handler ()
#2  <signal handler called>
#3  0x00002aaab0b02bc4 in _dbus_transport_get_is_authenticated (transport=0x8fafa0) at dbus-transport.c:578
#4  0x00002aaab0b03128 in _dbus_transport_get_dispatch_status (transport=0x8fafa0) at dbus-transport.c:824
#5  0x00002aaab0b033c0 in _dbus_transport_queue_messages (transport=0x8fafa0) at dbus-transport.c:888
#6  0x00002aaab0ae5989 in _dbus_connection_get_dispatch_status_unlocked (connection=0x8fb530) at dbus-connection.c:3315
#7  0x00002aaab0ae5bdc in dbus_connection_get_dispatch_status (connection=0x8fb530) at dbus-connection.c:3427
#8  0x00002aaab120cdd3 in message_queue_prepare (source=0x8fafa0, timeout=0x2aaab0b166b8) at dbus-gmain.c:94
#9  0x00002aaaaaef297a in IA__g_main_context_prepare (context=0x8cda40, priority=0x7fffff8c36b4) at gmain.c:2234
---Type <return> to continue, or q <return> to quit---
#10 0x00002aaaaaef3328 in g_main_context_iterate (context=0x8cda40, block=1, dispatch=1, self=0x0) at gmain.c:2527
#11 0x00002aaaaaef38ca in IA__g_main_loop_run (loop=0xbd1030) at gmain.c:2751
#12 0x00002aaaad4df141 in IA__gtk_main () at gtkmain.c:991
#13 0x000000004049d575 in ?? ()
#14 0x00000000006c00f0 in ?? ()
#15 0x00000000006c00c0 in ?? ()
#16 0x0000000000ff4d80 in ?? ()
#17 0x000000004049d513 in ?? ()
#18 0x00002aaaaab64fa0 in ?? ()
#19 0x00007fffff8c3a40 in ?? ()
#20 0x00007fffff8c3780 in ?? ()
#21 0x00002aaaaab28f20 in ?? ()
#22 0x0000000000737920 in ?? ()
#23 0x0000000000000000 in ?? ()
#0  0x00000000404a2f19 in ?? ()

emerge --info
Portage 2.1_pre3-r1 (default-linux/amd64/2005.1, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-ck1-r1 x86_64)
=================================================================
System uname: 2.6.15-ck1-r1 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0_pre15
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1, 2.16.91.0.5
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.15_rc6
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks nostrip sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LC_ALL="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/gentopia /usr/local/bmg-main /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aac aalib alsa audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdr crypt cups curl dbus debug eds emboss encode esd exif expat fam ffmpeg flac foomaticdb fortran gdbm gif glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml guile hal howl idn imagemagick imlib ipv6 jack java jpeg junit kde lcms ldap libwww lua lzw lzw-tiff mad mikmod mng mono motif mozilla mp3 mpeg ncurses nls nptl ogg openal opengl pam pcre pdflib perl pic png python qt quicktime readline recode ruby samba sdl speex spell sqlite ssl svg tcltk tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev usb userlocales vorbis wmf xine xml2 xmms xpm xv xvid zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS, LINGUAS, MAKEOPTS

Comment 10 Peter Johanson (RETIRED) gentoo-dev 2006-03-16 00:08:39 UTC
Is this still present with muine-0.8.4 now in the tree? Thanks.
Comment 11 Peter Johanson (RETIRED) gentoo-dev 2006-03-29 22:28:57 UTC
This may also be related to an amd64 dbus# bug that was resolved recently... Gonna mark this NEEDINFO, please feel free to re-open if you can still reproduce this with recent dbus and muine combinations. Thanks.