Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110731 - xorg-x11 >=6.8.2-r6 - on sparc, VT-switching no longer possible
Summary: xorg-x11 >=6.8.2-r6 - on sparc, VT-switching no longer possible
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: Sparc Linux
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-10-28 10:02 UTC by Chance Platt
Modified: 2006-02-06 19:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Chance Platt 2005-10-28 10:02:47 UTC
xorg-x11-6.8.2-r6 - with a type5 serial keyboard on sparc (specifically, SMP
U60) VT-switching is no longer possible.  I left xorg.conf exactly as I had it
for -r4 (on a 2.4 kernel) to get this result.

Reproducible: Always
Steps to Reproduce:
1.  emerge ~sparc keyworded xorg-x11
2.  leave xorg.conf as it was before the upgrade

Portage (default-linux/sparc/sparc64/2005.0, gcc-3.3.5-20050130,
glibc-, 2.6.14 sparc64)
System uname: 2.6.14 sparc64 sun4u
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.4.23
CFLAGS="-O2 -mtune=ultrasparc -mcpu=ultrasparc -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mtune=ultrasparc -mcpu=ultrasparc -pipe"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
USE="sparc X apache2 avi berkdb bitmap-fonts bonobo cdr crypt cups curl dlloader
eds encode esd fam fbcon flac foomaticdb fortran gcc64 gd gdbm gif gnome gphoto2
gstreamer gtk gtk2 gtkhtml guile imagemagick imlib jpeg libwww mad mikmod motif
mozilla mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python
readline samba sdl slang spell ssl tcltk tcpd tiff truetype truetype-fonts
type1-fonts udev vorbis xine xml xml2 xmms xv zlib userland_GNU kernel_linux

NOTE** I'm running linux-2.6.14 at the moment on this system.  The issue was
evident on 2.4.31-sparc.
Comment 1 Ferris McCormick (RETIRED) gentoo-dev 2005-10-28 10:05:02 UTC
At first glance, this seems to be true for me as well.  I have not really
investigated it beyond that.
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2005-10-28 11:23:47 UTC
First thing to check is just an ls of each patch tarball and compare which
patches are in there. Ferris, could you do that?
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2005-10-28 12:10:06 UTC
Check if it was that kbd-on-2.4... I remember adding that awhile back, and it's
not in -r4.
Comment 4 Ferris McCormick (RETIRED) gentoo-dev 2005-10-28 12:14:02 UTC
Assuming 6.8.2-r4 worked (which Chance claims so), there are two new patch
tarballs: one for -r5 (which might or might not have worked,\) and one for -r6:
xorg-x11-6.8.2-patches-0.1.12.tar.bz2  (dated Sept 21),
xorg-x11-6.8.2-patches-0.1.13.tar.bz2  (dated Oct 3)
The 0.1.12 patch set has these new patches in it:
The first three are sparc-specific, but they have been well tested.
The 0.1.13 patch set has these new patches in it:

The big change for sparc is the elimination of the deprecated keyboard driver
(although it's a tiny patch).  I suppose this could be related to how xorg is
configured in the keyboard's InputDevice Section, but unfortunately, I don't
have a working example to compare against.  And, although I have been using the
'kbd' patch for quite a while, I never do a VT switch, so I cannot comment on
whether or not that functionality was present in -r4+kbd fix.
Comment 5 Ferris McCormick (RETIRED) gentoo-dev 2005-10-28 13:32:56 UTC
For what it's worth:
1.  VT switching also fails on X-modular, kernel 2.6.13 (SB1000)
2.  VT switching works fine for xorg-x11-6.8.2-r6 with kernel 2.6.14 (U60)
Comment 6 Joshua Baergen (RETIRED) gentoo-dev 2005-10-28 13:56:02 UTC
I'm assuming that's latest modular?
Comment 7 Ferris McCormick (RETIRED) gentoo-dev 2005-10-28 14:42:25 UTC
Yes.  I have all of modular in my world file, so it's as of 'emerge --sync;
emerge -uv world' today.  I am not anyplace where I can check, but I think U60's
xorg.conf and SB1000's xorg.conf should be the same for kernel 2.6.xx. 
Keyboards are different, though, because SB1000 uses a universal connector.
(Anyway, it's the most current X-modular available.)
Comment 8 Ferris McCormick (RETIRED) gentoo-dev 2005-10-29 06:32:45 UTC
I am pretty certain that this is another problem with kbd+sparc+kernel-2.4.xx. 
Easiest quick fix is just to put the build for deprecated driver back into the
ebuild for 6.8.2-r6 (no version bump),  It looks as if we are actually making
progress on the sparc kernel-2.6 problems, so I doubt that this is worth
pursuing (for Gentoo); it's almost certainly an upstream problem with kbd, anyway.

The SB1000+kernel-2.6+X-modular problem is, I think, independent of this, and
I'll look at it further.  It could be USB related; I will be putting X-modular
onto a U60(kernel-2.6.14) in a few days and will know more then.  (As I said, I
never do a VTswitch, so I can't say if SB1000 has ever worked.)
Comment 9 Evan Langlois 2005-12-24 11:34:56 UTC
Don't know if this information helps, but I'm using xorg-x11 6.8.2-r6 with a USB PC keyboard (plugged into a PCI USB card), on an UltraSparc, kernel 2.6.15, and VT switching does work.
Comment 10 Joshua Baergen (RETIRED) gentoo-dev 2006-02-04 09:24:13 UTC
Ferris: Any news regarding this on the modular X front now that it's released?
Comment 11 Ferris McCormick (RETIRED) gentoo-dev 2006-02-04 11:43:42 UTC
(In reply to comment #10)
> Ferris: Any news regarding this on the modular X front now that it's released?

It's never worked for me, any kernel, any keyboard on X-modular/sparc.  Last I knew, I believe it did not work with X-modular on anything, though.  (If I remember correctly, spyderous reported that.)  I just verified 90 seconds ago that it does not work for sparc on X-modular, either kernel.  Both are completely current X-modular systems, standard Sun type-5 keyboards.  (Also, sun type-6 USB keyboard failed, last I checked.  That is within the last couple weeks.)
Comment 12 Joshua Baergen (RETIRED) gentoo-dev 2006-02-05 18:01:45 UTC
Upstream, looks similar, but it's probably a KDM bug of some sort.

This is something that should get moved to bugs.fdo.  Ferris, mind doing that?
Comment 13 Ferris McCormick (RETIRED) gentoo-dev 2006-02-06 11:44:56 UTC
(In reply to comment #12)
> Upstream, looks similar, but
> it's probably a KDM bug of some sort.
> This is something that should get moved to bugs.fdo.  Ferris, mind doing that?

Done; see for X-modular.
Comment 14 Joshua Baergen (RETIRED) gentoo-dev 2006-02-06 19:30:29 UTC
Thanks, that's all we're really worried about at this point.