Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110287 - X crashes on qiv when composite is enabled
Summary: X crashes on qiv when composite is enabled
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High critical (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-10-23 22:11 UTC by David Gavilan
Modified: 2006-04-19 19:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

The X log file just after X and everything crashed. (Xorg.0.log.crashed,43.24 KB, text/plain)
2005-11-02 07:07 UTC, David Gavilan
Xorg config file (xorg.conf,18.27 KB, text/plain)
2005-11-02 07:17 UTC, David Gavilan

Note You need to log in before you can comment on or make changes to this bug.
Description David Gavilan 2005-10-23 22:11:38 UTC
When trying to display an image with qiv-1.9 (stable on PPC) and "Composite" is
enabled on xorg-x11-6.8.2, the screen and sound freezes. I can still remotely
login, but there is no process to kill that makes it return to normal (X is
already dead). The only way to recover it is rebooting it. 

Reproducible: Always
Steps to Reproduce:
1. Enable "Composite" to Xorg extensions.
2. Try visualizing an image with qiv.

Actual Results:  
X dies and the screen freezes. Keyboard and mouse input seems dead too.

Expected Results:  
Display the image.

Portage (default-linux/ppc/2005.1/ppc, gcc-3.4.4,
glibc-, 2.6.12-gentoo-r6 ppc)
System uname: 2.6.12-gentoo-r6 ppc 745/755
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/libtool:   1.5.18-r1
CFLAGS="-O2 -mtune=powerpc -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mtune=powerpc -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="ppc X alsa berkdb bitmap-fonts canna cdr cjk crypt cups dvdr emboss esd fam
fortran gcj gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 java jpeg kde
libwww motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png
python qt readline ruby spell ssl svg tcltk tcpd tiff truetype truetype-fonts
type1-fonts udev unicode vorbis xml2 xmms xv zlib userland_GNU kernel_linux
Comment 1 Joshua Baergen (RETIRED) gentoo-dev 2005-10-24 16:12:38 UTC
Please try on, so we know if this has been fixed upstream...
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2005-10-31 22:41:12 UTC
ALso attach your xorg.conf and /var/log/Xorg.0.log, then reopen.
Comment 3 David Gavilan 2005-11-02 07:07:41 UTC
Created attachment 71933 [details]
The X log file just after X and everything crashed.

There seems that the crash didn't generate any log. So the logs seems perfectly
Comment 4 David Gavilan 2005-11-02 07:15:52 UTC
It keeps on crashing. I unmasked and emerged the last xorg, with these flags:

[ebuild   R   ] x11-base/xorg-x11-  (-3dfx) +bitmap-fonts +cjk
-debug -doc -font-server -insecure-drivers +ipv6 -minimal +nls -nocxx +opengl
+pam -sdk -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 0 kB

Then, activated the Composite again. qiv crashed the same way. 

I have attached the Xorg.0.log from that moment. It may be more useful the
/var/log/messages from that moment (user 'david' logs in at 23:26, startx, and
executes 'qiv some_image':

Nov  2 23:26:08 pegasos login(pam_unix)[2631]: session opened for user david by
(uid=0) Nov  2 23:27:02 pegasos Trying to vfree() nonexistent vm area (e2627000)
Nov  2 23:27:02 pegasos Badness in __vunmap at mm/vmalloc.c:308 Nov  2 23:27:02
pegasos Call trace:
Nov  2 23:27:02 pegasos [c00052f0] check_bug_trap+0xbc/0x11c Nov  2 23:27:02
pegasos [c0005664] ProgramCheckException+0x314/0x4a0
Nov  2 23:27:02 pegasos [c0004a28] ret_from_except_full+0x0/0x4c
Nov  2 23:27:02 pegasos [c0055928] __vunmap+0xf8/0x100
Nov  2 23:27:02 pegasos [c000f3ec] iounmap+0x5c/0x60
Nov  2 23:27:02 pegasos [e2491314] radeon_do_cleanup_cp+0x254/0x418 [radeon]
Nov  2 23:27:02 pegasos [e249c090] radeon_driver_pretakedown+0x10/0x20 [radeon]
Nov  2 23:27:02 pegasos [e24ab984] drm_takedown+0x350/0x518 [drm]
Nov  2 23:27:02 pegasos [e24acb98] drm_release+0x4d8/0x588 [drm]
Nov  2 23:27:02 pegasos [c0060098] __fput+0x1a0/0x1c4
Nov  2 23:27:02 pegasos [c005e438] filp_close+0x6c/0xd8
Nov  2 23:27:02 pegasos [c0004320] ret_from_syscall+0x0/0x44
Nov  2 23:30:01 pegasos cron[2851]: (root) CMD (test -x /usr/sbin/run-crons &&
/usr/sbin/run-crons )

After that, I remotely logged in, copied the logs, and rebooted.

Comment 5 David Gavilan 2005-11-02 07:17:36 UTC
Created attachment 71934 [details]
Xorg config file

This is my Xorg config file. Notice that in this file the Composite option has
been disabled, since it's my working configuration.
Comment 6 Joshua Baergen (RETIRED) gentoo-dev 2005-12-04 09:46:37 UTC
If this isn't fixed in 7.0 then we should move this upstream.
Comment 7 David Gavilan 2005-12-04 23:27:42 UTC
The RC (RC1, RC2, and RC3) for xorg-x11 7.0 do not include the ~ppc keyword yet. How can I try to 
check if the problem has been solved?
Comment 8 Joshua Baergen (RETIRED) gentoo-dev 2005-12-05 09:18:24 UTC
Sorry, I wasn't clear.  I didn't intend for you to check right away.  Composite
is considered quite experimental in 6.8, but has matured a bit in 7.0.  I meant
for you to follow up on this bug once 7.0 is released, which will be 2-3 weeks.
Comment 9 Marcelo Goes (RETIRED) gentoo-dev 2006-01-19 10:20:09 UTC
Is this a duplicate of bug 79694?
Comment 10 David Gavilan 2006-01-19 19:16:50 UTC
It could be that the responsible is gdk, but there is not "gdk error" output message, just a big kernel crash.

I tried unmasking Xorg-7.0 to try qiv there, but now I'm having problems with DRI. Enabling it "freezes" the system (I can still ssh, but killing X doesn't help). X gives this output

(EE) RADEON(0): Idle timed out, resetting engine... 
(EE) RADEON(0): Idle timed out, resetting engine... 

I have an AGP Radeon 7500 on a Pegasos 2. 
I'm not sure if I should submit a bug because this is a masked package... ^^;
Comment 11 Joshua Baergen (RETIRED) gentoo-dev 2006-01-20 19:16:35 UTC
#79694 does sound quite similar to this issue...

And despite 7.0 being masked, we are accepting bug reports on it.  The packages that are masked will not change much between now and the time they are unmasked for release into ~arch.
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2006-04-19 19:58:54 UTC
If you run "export XLIB_SKIP_ARGB_VISUALS=1" before running qiv from the same terminal, does it still fail? Reopen when you reply.