Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110178 - media-libs/flac-1.1.2-r3 xmms plugin fails to play SOME files. Shows 0:00 time
Summary: media-libs/flac-1.1.2-r3 xmms plugin fails to play SOME files. Shows 0:00 time
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luis Medinas (RETIRED)
Depends on: xmms-must-die
  Show dependency tree
Reported: 2005-10-22 15:46 UTC by Peter Hyman
Modified: 2006-10-23 01:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

metaflac output of files (f.out,3.17 KB, text/plain)
2005-10-22 15:49 UTC, Peter Hyman
Flac file output 1 (b.out,116.68 KB, text/plain)
2005-10-22 15:50 UTC, Peter Hyman
Flac file output 2 (g.out,1.23 MB, text/plain)
2005-10-22 15:52 UTC, Peter Hyman
screenshot of xmms view of two flac files (xmms-confusion.png,31.70 KB, image/png)
2005-10-23 05:47 UTC, Peter Hyman

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Hyman 2005-10-22 15:46:14 UTC
I recently downloaded a set of flac files that won't play on xmms. The files
test fine using flac -t and also play with noatun, kaboodle. I did notice that
when noatun starts up, it appears to start twice. It seems to play and count up
to about two seconds, reset to 0:00 and then play fine. With XMMS, however, it
seems to be unable to get synched and XMMS will appear to read through some of
the file, and then stop. This does not occur with most flac files. I am
attaching two outputs. One compares the metaflac info with a file that plays
followed by the output of the file that does not. The second and third files
show the detailed analysis of the two files. The file g.out is the good file,
and b.out is the bad one as far as XMMS is concerned. All files in the new set
don't play in XMMS, not just a few. All files do play in noatun.

Reproducible: Always
Steps to Reproduce:
1. play flac file in xmms
2. play flac file in noatun

Actual Results:  
0:00 time shown in xmms, plays in noatun, but appears to start twice before playing.

Expected Results:  
flac file plays in xmms

three files attached which hopefully will shed light on this
Comment 1 Peter Hyman 2005-10-22 15:49:46 UTC
Created attachment 71228 [details]
metaflac output of files

Alice cooper file does NOT work in xmms second unnamed one does
Comment 2 Peter Hyman 2005-10-22 15:50:30 UTC
Created attachment 71229 [details]
Flac file output 1

This file does not play on xmms
Comment 3 Peter Hyman 2005-10-22 15:52:02 UTC
Created attachment 71230 [details]
Flac file output 2

This file DOES play in xmms
Comment 4 Luis Medinas (RETIRED) gentoo-dev 2005-10-22 16:31:16 UTC
did you tried with another versions of flac ? I think this is related to flac
not to xmms directly.

check out this
Comment 5 Peter Hyman 2005-10-23 04:01:39 UTC
(In reply to comment #4)
> did you tried with another versions of flac ? I think this is related to flac
> not to xmms directly.

I have the latest flac, and there seem to be none in ~x86 at the time. According
to the flac website, I have the latest version. Did you suggest I downgrade? I
agree. It has to be related to the plugin, not xmms. It must be something to do
with the encoding method or something in it.
> check out this
Yes, I saw that, but this is not a crasher. XMMS just continues on its way, but
does not play the cut. I'll see if there is a flac bugzilla. I'll refer it to here. 

Just thought you should know in case something else similar pops up in the future.

Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-23 04:18:50 UTC
This might be related to bug #104518 with xine-lib ... can you try if that is 
able to play them or have the same behavior of xmms, so to rule out if it's an 
xmms problem? 
Comment 7 Peter Hyman 2005-10-23 05:47:56 UTC
Created attachment 71276 [details]
screenshot of xmms view of two flac files

Here is why xmms is not playing the flac file in question. It _thinks_ it's an
MP3 file based on the tag info. Looking at the INFO screen, you can see that
the top flac file (the problem one) shows tag data and stream info as if it's
an mpeg. xmms therefore must be loading the wrong driver trying to play it.
OTOH, the bottom panel shows the proper flac info, but no tag info -- must not
have been added. However, I have numerous other flac files WITH tag info that
play fine in xmms. The only difference between these two files is the library
used to encode them. One used 1.1.2 (that does not play on xmms), and the one
that does was 1.1.0. I wonder if that might be part of the problem. I will post
this on the xmms bug site and see. The fact that xmms is unable to properly
identify a flac file as one SEEMS to indicate that the problem is there.
Comment 8 Peter Hyman 2005-10-23 06:43:25 UTC
running flac -d filename, then flac -e8 filename and re-adding meta info with
metaflac allows the file to run properly in xmms. There must have been something
strange about the original encodings. Am reporting this to the flac bugzilla for
further review. This is a lousy workaround, but one that should be noted in case
others cannot play flac files. It's interesting that other media players seem to
read the filename and use the appropriate driver. XMMS seems to be looking at
the file contents and mistakenly thinks it's an MPEG file!
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-10-23 00:41:26 UTC
xmms and all plugins are now package.masked and will be removed from the tree in one month.

Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-10-23 01:03:46 UTC