Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 109897 - [EBUILD] www-apps/{cvs,svn,git}trac (new ebuild)
Summary: [EBUILD] www-apps/{cvs,svn,git}trac (new ebuild)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://www.cvstrac.org/
Whiteboard:
Keywords: EBUILD
: 119002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-20 00:49 UTC by Steve-o
Modified: 2016-09-08 09:12 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cvstrac-1.1.5.ebuild (cvstrac-1.1.5.ebuild,1.54 KB, text/plain)
2005-10-20 00:49 UTC, Steve-o
Details
cvstrac.conf (cvstrac.conf,4.80 KB, text/plain)
2005-10-20 00:50 UTC, Steve-o
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve-o 2005-10-20 00:49:12 UTC
New ebuild for cvstrac.

A Web-Based Bug And Patch-Set Tracking System For CVS.

I suggest www-apps/cvstrac because its similar to trac and that's where it lives.

Steve-o
Comment 1 Steve-o 2005-10-20 00:49:58 UTC
Created attachment 71058 [details]
cvstrac-1.1.5.ebuild
Comment 2 Steve-o 2005-10-20 00:50:49 UTC
Created attachment 71059 [details]
cvstrac.conf

Example configuration for CGI operation under Apache 2, borrowed from AWstats.
Comment 3 Thomas Eckert 2006-03-05 00:32:34 UTC
any special reason why not the latest version (1.2.1) is used?

there are also "svn"- and "git"-SCM-backends supported -- these may be handled
by USE-flags.

i've tested the git-backend in 1.2.1 and it seems to work fine at first glance
though it only works on checked-out working-dirs (that contain a ".git"-dir).
this restriction is fixed in the cvs-version already (can work on a "cg-push"-ed
repository).

sample-compile-line for the git-backend of version 1.2.1:
--- snipp ---
        make \
                APPNAME=gittrac \
                SRCDIR=${S} \
                INSTALLDIR=${D}/${DOCUMENT_ROOT} \
                || die "compile failed"
--- snapp ---
Comment 4 Steve-o 2006-03-20 10:15:55 UTC
There is no maintainer for this ebuild, you can find SVN support in a different ebuild called svntrac.
Comment 5 Thomas Eckert 2006-11-18 09:14:22 UTC
in the meantime cvstrac-2.0.0 was released and the the git-part now works
perfectly on "cg-push'ed" central git-repositories.

would it be better to submit a separate gitrac-ebuild
pro:
- ebuilds less complex
- better testing as svn, git, cvs testing is split up
contra:
- common parts need double-testing and adjustments

what do you think?
Comment 6 Kevin 2007-03-11 19:13:18 UTC
What's the latest news on this?  I would use it.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-09-16 07:42:30 UTC
*** Bug 119002 has been marked as a duplicate of this bug. ***
Comment 8 Marek Szuba gentoo-dev 2016-08-08 14:24:27 UTC
Upstream is still alive, not much activity but it's better than nothing - especially given some of the more recent commits were security-related. I guess it grinds down to user demand, then. Therefore:


While this is still a viable package for the Gentoo Portage tree it appears this ebuild is lacking in community interest. If you (or another user) are still wanting this to make it into the Portage tree please let us know! It would be additionally helpful (but not required) if you were willing to help out with the package by becoming it's proxied maintainer; you have already done most of the work for this task. Gentoo even has a dedicated team[1] for assisting users in becoming proxied maintainers. If you are interested in maintaining this package, please contact proxy-maint@gentoo.org or join #gentoo-proxy-maint on Freenode IRC.

If this bug remains silent without further comments for 30 days i will close it with the resolution of WONTFIX. Beyond that the bug can always be reopened to get this package back on track for the Gentoo Portage tree.

[1]: https://wiki.gentoo.org/index.php?title=Project:Proxy_Maintainers

Kind regards,
Marecki