Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 109800 - dev-java/bluej-2.0.5 - Cannot open existing project or create new project
Summary: dev-java/bluej-2.0.5 - Cannot open existing project or create new project
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 115587 (view as bug list)
Depends on: 121141
Blocks: 122772
  Show dependency tree
 
Reported: 2005-10-19 06:04 UTC by Dan Keder
Modified: 2007-07-20 08:52 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Keder 2005-10-19 06:04:16 UTC
When creating new project or opening an existing project, Bluej fails to open  
the project and throws the following exception:  
       
Exception in thread "main" java.lang.NoClassDefFoundError:       
com/sun/jdi/ReferenceType       
        at bluej.debugger.Debugger.getDebuggerImpl(Debugger.java:42)       
        at bluej.pkgmgr.Project.<init>(Project.java:382)       
        at bluej.pkgmgr.Project.openProject(Project.java:143)       
        at bluej.Main.processArgs(Main.java:96)       
        at bluej.Main.<init>(Main.java:48)       
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native       
Method)       
        at       
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructor       
AccessorImpl.java:39)       
        at       
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingCon       
structorAccessorImpl.java:27)       
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)       
        at java.lang.Class.newInstance0(Class.java:350)       
        at java.lang.Class.newInstance(Class.java:303)       
        at bluej.Boot.bootBluej(Unknown Source)       
        at bluej.Boot.main(Unknown Source)       
   
   
Bluej probably cannot find tools.jar in CLASSPATH. I solved it by changing the    
line CP=`java-config -p bluej-bin`:`java-config -p antlr` in /usr/bin/bluej to     
CP=`java-config -p bluej-bin`:`java-config -p antlr`:`java-config    
-O`/lib/tools.jar 

Reproducible: Always
Steps to Reproduce:
1. Open existing project (Project->Open Project) or create new project 
(Project->New Project) 
 
Actual Results:  
Bluej doesn't open the project 

Expected Results:  
Open project in the workspace 

Versions:   
Bluej-2.0.5    
sun-jdk-1.5.0.05
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-10-19 06:12:54 UTC
Guess why Java 1.5 is still hard masked and not supported.
Comment 2 Dan Keder 2005-10-19 07:12:16 UTC
(In reply to comment #1) 
> Guess why Java 1.5 is still hard masked and not supported. 
 
Of course, but that doesn't change the fact that I and maybe even other people 
need 1.5. At least there is a way (hack? :-) ) to make it working... 
Comment 3 Gilles Dartiguelongue gentoo-dev 2006-06-15 06:45:55 UTC
Hem, I had this problem months ago but it was solved by 2.1.1 release and later. Do you still have this problem ?
Comment 4 Dan Keder 2006-06-18 08:11:05 UTC
(In reply to comment #3)
> Hem, I had this problem months ago but it was solved by 2.1.1 release and
> later. Do you still have this problem ?

No, it works now. I have tested version 2.1.3.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-06-27 03:28:54 UTC
Re-assign wrt Bug 23545, maintainer retired.
(In reply to comment #4)
> (In reply to comment #3)
> > Hem, I had this problem months ago but it was solved by 2.1.1 release and
> > later. Do you still have this problem ?
> 
> No, it works now. I have tested version 2.1.3.
> 

Closing then.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-06-27 03:32:59 UTC
Or not, it's not bumped in portage.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-06-27 03:33:29 UTC
*** Bug 115587 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-06-27 03:34:22 UTC
Re-assign wrt Bug 23545, maintainer retired.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 08:52:05 UTC
10:47:12 <+CIA-24> drac * gentoo-x86/dev-java/bluej-bin/ (9 files in 2 dirs): Remove p.masked pkg. Treecleaners, should have been gone in 2006..