Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 109542 - bitstream compilation error in transcode 0.6.14-r3
Summary: bitstream compilation error in transcode 0.6.14-r3
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-17 02:13 UTC by John Berry
Modified: 2005-10-30 15:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Berry 2005-10-17 02:13:24 UTC
I tried to update to the last version of transcode (0.6.14-r3), but the
compilation failed while the compilation of bitstream :

if /bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.
-I. -I..     -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-D_FILE_OFFSET_BITS=64 -march=pentium-m -mtune=pentium-m -O3 -pipe
-fomit-frame-pointer -ftracer -DDCT_YUV_PRECISION=1 -MT bitstream.lo -MD -MP -MF
".deps/bitstream.Tpo" -c -o bitstream.lo bitstream.c; \
then mv -f ".deps/bitstream.Tpo" ".deps/bitstream.Plo"; else rm -f
".deps/bitstream.Tpo"; exit 1; fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -Wall -D_LARGEFILE_SOURCE
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -march=pentium-m -mtune=pentium-m
-O3 -pipe -fomit-frame-pointer -ftracer -DDCT_YUV_PRECISION=1 -MT bitstream.lo
-MD -MP -MF .deps/bitstream.Tpo -c bitstream.c  -fPIC -DPIC -o .libs/bitstream.o
In file included from bitstream.c:37:
bitstream.h:36: warning: type qualifiers ignored on function return type
bitstream.c: In function 'bitstream_fill_current':
bitstream.c:100: error: invalid lvalue in increment
make[2]: *** [bitstream.lo] Erreur 1
make[2]: Leaving directory
`/var/tmp/portage/transcode-0.6.14-r3/work/transcode-0.6.14/libac3'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory
`/var/tmp/portage/transcode-0.6.14-r3/work/transcode-0.6.14'
make: *** [all] Erreur 2

!!! ERROR: media-video/transcode-0.6.14-r3 failed.
!!! Function src_compile, Line 128, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.


Reproducible: Always
Steps to Reproduce:
1. Update the portage tree
2. ACCEPT_KEYWORDS="~x86" emerge transcode
3.

Actual Results:  
Compilation failed

Expected Results:  
Compilation succeed

Portage 2.0.53_rc5 (default-linux/x86/2005.0, gcc-4.0.2, glibc-2.3.5-r2,
2.6.13-gentoo-r3 i686)
=================================================================
System uname: 2.6.13-gentoo-r3 i686 Intel(R) Pentium(R) M processor 1600MHz
Gentoo Base System version 1.6.13
ccache version 2.4 [enabled]
dev-lang/python:     2.3.4-r1, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe -fomit-frame-pointer -ftracer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/texmf/web2c
/etc/env.d"
CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe -fomit-frame-pointer -ftracer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo
http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr_FR fr en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 7zip X X509 Xaw3d a52 aac acl acpi activefilter ada aim alsa aotuv
apache2 apm arts artswrappersuid athena atlas atm auctex avi bash-completion
berkdb bitmap-fonts blas blender-game bluetooth bzip2 calendar cardbus ccache
cdparanoia cdr chroot cjk clamav crypt css cups curl curlwrappers dba dbm dbx
dhcp dio directfb divx4linux dlloader dnd dnsdb doc dts dv dvd dvdr ecc emacs
emacs-w3 emboss encode esd ethereal examples exif exiscan-acl fam fastcgi fat
fbcon fftw fmod font-server foomaticdb fortran ftp gd gdbm geoip gif gimp
gimpprint ginac glut gnokii gnuplot gnustep gnutls gpgme gphoto2 gpm gsnd gtk
gtk2 hardened hardenedphp icq icu idn ieee1394 imagemagick imap imlib innodb
iodbc ipv6 ithreads j2ee jabber jai java javascript jboss jce jfs jikes jit jpeg
junit kde kerberos kqemu krb4 lcms ldap libclamav libg++ libwww lzo mad mcal
memlimit mikmod mime mmx mono motif mozsvg mp3 mpeg msn mule mysql mysqli
ncurses neXt nis nls nntp nptl nptlonly ntlm oav objc odbc ogg oggvorbis openal
opengl oscar oss pam pam_timestamp pcmcia pcntl pcre pda pdfkit pdflib perl
pg-hier php pic png pnp posix postgres povray prelude profile python qt
quicktime quotas radius readline reiserfs ruby samba scanner sdl server session
sguil sharedext simplexml skey slang slp smartcard smime soap sockets socks5
softmmu spell spl sql sqlite sse sse2 ssl subversion symlink sysfs szip tcltk
tcpd tetex threads tiff tokenizer truetype truetype-fonts trusted type1-fonts
unicode usb userlocales v4l vorbis wifi wxwindows xface xine xml2 xmlrpc xmms
xpm xsl xv xvid yahoo zlib linguas_fr_FR linguas_fr linguas_en linguas_en_US
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET
Comment 1 Patrizio Bassi 2005-10-19 07:36:53 UTC
i have a different error, on configure: 
 
checking for default xvid... xvid4 
checking whether pvm3 support is requested... no 
checking whether libdv support is requested... no 
checking whether libquicktime support is requested... yes 
checking for pkgconfig support for libquicktime... yes 
checking for lqt-config... /usr/bin/lqt-config 
checking how to determine LIBQUICKTIME_CFLAGS... pkg-config 
checking quicktime/lqt.h usability... no 
checking quicktime/lqt.h presence... no 
checking for quicktime/lqt.h... no 
configure: error: libquicktime requested, but cannot compile quicktime/lqt.h 
 
!!! Please attach the config.log to your bug report: 
!!! /var/tmp/portage/transcode-0.6.14-r3/work/transcode-0.6.14/config.log 
 
!!! ERROR: media-video/transcode-0.6.14-r3 failed. 
!!! Function econf, Line 495, Exitcode 0 
!!! econf failed 
!!! If you need support, post the topmost build error, NOT this status message. 
 
Comment 2 Andrew D. Keyser (aka Legoguy) 2005-10-19 11:04:21 UTC
Ok, the first report here is due to gcc 4. Works with gcc 3.4.4.

The second one... I don't know about that one :/
Comment 3 Patrizio Bassi 2005-10-19 11:23:40 UTC
i had no /usr/include/quicktime directory, but /usr/include/lqt 
 
symlinked and now works. dunno if i had some problems or libquicktime ebuild was 
wrong 
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-30 15:39:33 UTC
transcode-0.6 will not work with GCC4.