Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108884 (vlc-stable-ffmpeg) - vlc-0.8.1-r1 fails to build
Summary: vlc-0.8.1-r1 fails to build
Status: RESOLVED DUPLICATE of bug 116181
Alias: vlc-stable-ffmpeg
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 112086 113231 113281 114204 117399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-11 09:20 UTC by Attila Stehr
Modified: 2006-01-01 15:47 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Attila Stehr 2005-10-11 09:20:03 UTC
video.c: In function `ffmpeg_NewPictBuf':
video.c:183: Fehler: structure hat kein Element namens 
Comment 1 Attila Stehr 2005-10-11 09:20:03 UTC
video.c: In function `ffmpeg_NewPictBuf':
video.c:183: Fehler: structure hat kein Element namens »frame_rate«
video.c:183: Fehler: structure hat kein Element namens »frame_rate_base«
video.c:185: Fehler: structure hat kein Element namens »frame_rate«
video.c:186: Fehler: structure hat kein Element namens »frame_rate_base«
video.c: In function `DecodeVideo__ffmpeg':
video.c:634: Fehler: structure hat kein Element namens »frame_rate«
video.c:638: Fehler: structure hat kein Element namens »frame_rate_base«
video.c:639: Fehler: structure hat kein Element namens »frame_rate«

translation:
video.c:639: error: structure has no element »frame_rate«


Reproducible: Always
Steps to Reproduce:

1. emerge -vD vlc
Actual Results:  
if x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../..   -DSYS_LINUX
-I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin
ffmpeg` -Wsign-compare -Wall -march=athlon64 -O3 -pipe -fomit-frame-pointer
-pipe -MT libffmpeg_a-video.o -MD -MP -MF ".deps/libffmpeg_a-video.Tpo" \
  -c -o libffmpeg_a-video.o `test -f 'video.c' || echo './'`video.c; \
then mv -f ".deps/libffmpeg_a-video.Tpo" ".deps/libffmpeg_a-video.Po"; \
else rm -f ".deps/libffmpeg_a-video.Tpo"; exit 1; \
fi
video.c: In function `ffmpeg_NewPictBuf':
video.c:183: Fehler: structure hat kein Element namens »frame_rate«
video.c:183: Fehler: structure hat kein Element namens »frame_rate_base«
video.c:185: Fehler: structure hat kein Element namens »frame_rate«
video.c:186: Fehler: structure hat kein Element namens »frame_rate_base«
video.c: In function `DecodeVideo__ffmpeg':
video.c:634: Fehler: structure hat kein Element namens »frame_rate«
video.c:638: Fehler: structure hat kein Element namens »frame_rate_base«
video.c:639: Fehler: structure hat kein Element namens »frame_rate«
make[6]: *** [libffmpeg_a-video.o] Fehler 1
make[6]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[5]: *** [all-modules] Fehler 1
make[5]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec/ffmpeg'
make[4]: *** [all-recursive] Fehler 1
make[4]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec'
make[3]: *** [all] Fehler 2
make[3]: Leaving directory
`/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules/codec'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1/modules'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/vlc-0.8.1-r1/work/vlc-0.8.1'
make: *** [all] Fehler 2

!!! ERROR: media-video/vlc-0.8.1-r1 failed.
!!! Function src_compile, Line 197, Exitcode 2
!!! make of VLC failed


Expected Results:  
clean build

Portage 2.0.51.22-r3 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /usr/X11R6/bin/startx /etc/env.d"
CXXFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy distlocks sandbox severe sfperms strict test"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
ftp://ftp.gentoo.mesh-solutions.com/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 audiofile avi berkdb bitmap-fonts bzlib cdda cdio
cdr crypt cups curl dbus dga directfb dlloader dmalloc dpms dts dvd dvdr dvdread
eds emacs emboss encode esd exif fam fame fat fbcon ffmpeg firefox flac
foomaticdb fortran freetype gdbm ggi gif gimpprint gnome gpm gstreamer gtk gtk2
hal hardened howl imagemagick imlib ipv6 ithreads javascript jpeg jpeg2k kde
lcms libsamplerate libwww lzo lzw lzw-tiff mad matroska memlimit mikmod mjpeg
mmap mng mozcalendar mozdevelop mozsvg mp3 mpeg mpi ncurses nls nptl nptlonly
ntfs nvidia ogg oggvorbis on-the-fly-crypt openal openexr opengl pam pda pdflib
perl png ppds python qt quicktime readline real reiserfs sdl slang sndfile spell
ssl stream svg symlink tcltk tcpd test tetex tga theora threads tidy tiff
toolbar truetype truetype-fonts type1-fonts unicode usb userlocales vcd videos
vorbis wmf xine xml xml2 xmms xosd xpm xprint xtermtoolbar xv xvid xvmc yv12
zlib linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, PORTDIR_OVERLAY
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-11 09:24:31 UTC
Which version of ffmpeg are you using? 
Comment 3 Attila Stehr 2005-10-11 16:21:42 UTC
Well, I used the ~amd64 version since I hoped that will solve a problem with
WMV9 files (see below). Now I emerged the stable version of ffmpeg and the build
of vlc is successful.

Am I supposed to set the 'bug' status to RESOLVED, UPSTREAM?

----- compile error with version 0.4.9_p20050906 ------------------->

magic atti # emerge -pvD ffmpeg

These are the packages that I would merge, in order:

Calculating dependencies  ...done!
[ebuild     UD] media-video/ffmpeg-0.4.9_p20050226-r5 [0.4.9_p20050906] +a52
+aac (-altivec) -debug -doc +dts +encode -ieee1394 +imlib (-mmx) -network +ogg
-oss +sdl +threads +truetype -v4l +vorbis +xvid +zlib 0 kB

Total size of downloads: 0 kB
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-11 16:29:40 UTC
If you want ~amd64 ffmpeg, you should also use ~amd64 vlc, the ~amd64 vs amd64  
can be a problem. In this case, newer ffmpeg are not supported by 0.8.1 
series, I'm sorry. 
Comment 5 Attila Stehr 2005-10-12 07:46:04 UTC
Okay. Thank you for clarification! :)
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:52:50 UTC
Adding an alias... 
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:54:29 UTC
*** Bug 112086 has been marked as a duplicate of this bug. ***
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:54:35 UTC
*** Bug 113231 has been marked as a duplicate of this bug. ***
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:54:43 UTC
*** Bug 113281 has been marked as a duplicate of this bug. ***
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-01 15:55:46 UTC
*** Bug 114204 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-01-01 15:29:35 UTC
*** Bug 117399 has been marked as a duplicate of this bug. ***
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-01 15:47:27 UTC
reopening...
Comment 13 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-01 15:47:48 UTC
Needs a newer vlc stable...

*** This bug has been marked as a duplicate of 116181 ***