A vulnerability has been found in all previously released versions of
OpenSSL (all versions up to 0.9.7h and 0.9.8a). Versions 0.9.7h and
0.9.8a have been released to address the issue. The vulnerability
potentially affects applications that use the SSL/TLS server
implementation provided by OpenSSL.
Such applications are affected if they use the option
SSL_OP_MSIE_SSLV2_RSA_PADDING. This option is implied by use of
SSL_OP_ALL, which is intended to work around various bugs in
third-party software that might prevent interoperability. The
SSL_OP_MSIE_SSLV2_RSA_PADDING option disables a verification step in
the SSL 2.0 server supposed to prevent active protocol-version
rollback attacks. With this verification step disabled, an attacker
acting as a "man in the middle" can force a client and a server to
negotiate the SSL 2.0 protocol even if these parties both support SSL
3.0 or TLS 1.0. The SSL 2.0 protocol is known to have severe
cryptographic weaknesses and is supported as a fallback only.
Applications using neither SSL_OP_MSIE_SSLV2_RSA_PADDING nor
SSL_OP_ALL are not affected. Also, applications that disable
use of SSL 2.0 are not affected.
*** Bug 108046 has been marked as a duplicate of this bug. ***
Mike, please commit the ebuilds with the stable keywords from bug 108046
ready for GLSA i guess
*** Bug 117214 has been marked as a duplicate of this bug. ***