Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108709 - sci-geosciences/grass - add opendwg support
Summary: sci-geosciences/grass - add opendwg support
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Deadline: 2020-09-21
Assignee: Sci-geo Project
URL: http://opendesign.com
Whiteboard: sunrise suggested
Keywords: EBUILD, PMASKED
Depends on:
Blocks:
 
Reported: 2005-10-10 04:12 UTC by karpi
Modified: 2020-09-21 06:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for grass with opendwg (grass-6.0.1.ebuild,3.31 KB, text/plain)
2005-10-10 04:14 UTC, karpi
Details
ebuild for opendwg (opendwg-2.012.ebuild,814 bytes, text/plain)
2005-10-10 04:23 UTC, karpi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karpi 2005-10-10 04:12:51 UTC
add v.in.dwg v.in/dxf module into grass. Uses opendwg toolkit from
http://opendesign.com

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 karpi 2005-10-10 04:14:12 UTC
Created attachment 70277 [details]
ebuild for grass with opendwg

it works for me
Comment 2 karpi 2005-10-10 04:23:04 UTC
Created attachment 70278 [details]
ebuild for opendwg

this ebuild emerges needed opendwg libs.

For getting that libs (all from that steps are pay free), you need:
1) register account on opendesign.com
2) print their license agreement, fill it, signe every one page of it
3) fax that sheets back (or send by paper mail)
3) when you obtain access into members ares, download "OpenDWG Toolkit/Viewkit
libraries" file:
AD27LINX.TAR.GZ
 Do n_o_t download "DWGdirect" DD_lnxX86.tar.gz, DD_lnxX86_3.4.3.tar.gz, they
do not work in grass !
-------------------
4) emerge opendwg
5) USE="opendwg" emerge grass
Comment 3 karpi 2005-10-10 04:29:36 UTC
opendwg ebuild suppose to be in:
media-libs
Comment 4 Emiliano Vavassori 2006-07-04 16:36:25 UTC
I'm writing a GRASS-CVS ebuild from official CVS snapshot for my personal use; ./configure needs --with-opendwg-libs= and --with-opendwg-includes=, may I indicate here the same directory (/usr/lib/opendwg)?

Thanks.
Comment 5 Emiliano Vavassori 2006-07-06 06:42:06 UTC
Ok, sorry for the previous stupid question. I think opendwg are to be placed in /opt/opendwg instead of /usr/lib/opendwg, because they are precompiled and shared as binary package.

In that case, ebuild needs to install also a /etc/env.d file to configure LDPATH to include the path to libs dir in /opt/opendwg.

I don't have a copy of that libs and probably I don't want one, but I can help you if you want.

Bye.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-28 04:08:08 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-09-21 06:01:47 UTC
package removed.