Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108479 - [Tracker] Split gnome-python bindings
Summary: [Tracker] Split gnome-python bindings
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Lowest normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard: Pending Removal: 2011-12-21
Keywords: PMASKED, Tracker
: 128911 140312 141732 150780 160991 192351 242640 249206 (view as bug list)
Depends on: 268485 270944 352910 352911 352912 352914 352916 352917 352920 352922 352924 352926 352927 352928 352929 352932 352934 352935 352937 352938 352939 370961 372161 372165 372167 372169 372171 372173 372175
Blocks:
  Show dependency tree
 
Reported: 2005-10-08 05:45 UTC by WerK
Modified: 2012-01-22 13:00 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
use flags for gda and spell (patch.txt,687 bytes, patch)
2006-03-19 12:45 UTC, Duarte Henriques
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WerK 2005-10-08 05:45:36 UTC
When I install gnome-python-extras, because one package needs its gnomeprint and
gnomeprint.ui python module, it tries to pull lots of dependencies(totem,
nautilus-cd-burner etc.), which are'nt really needed. The partial sollution to
this is use emerge --oneshot --nodeps dev-python/gnome-python-extras because the
package looks for installed stuff and compiles only the modules which are found
in the system. I think it should utilize USEflags : totem gtkhtml gnomeprint
spell gtop nautilus-cd-burner and so on.

Reproducible: Always
Steps to Reproduce:
1. emerge dev-python/gnome-python-extras

Actual Results:  
Tries to pull lots of dependencies, which are'nt really needed if you are not
using gnome.

Expected Results:  
Install only those dependencies which are defined with USE flags.

It should be pretty easy to do, only modification required is the RDEPEND part
of the ebuild.
Comment 1 John N. Laliberte (RETIRED) gentoo-dev 2005-10-08 06:05:34 UTC
Its not just easy enough to modify and put in the xxx?().

The configure.in does not have real switches, thats why all those things are not
useflagged.

I have a patch locally that enables the switches that I will submit upstream
shortly.
Comment 2 Duarte Henriques 2006-03-19 12:45:34 UTC
Created attachment 82598 [details, diff]
use flags for gda and spell

It really is that simple as adding the use flags and optional deps. The configure script is written in such a way that it just doesn't install these components if they are not found. I don't need a spell checker nor gda, so I used this and it worked fine.
Comment 3 Jorge Vargas 2006-05-01 10:44:19 UTC
(In reply to comment #2)
> Created an attachment (id=82598) [edit]
> use flags for gda and spell
> 
Does this really works?
> It really is that simple as adding the use flags and optional deps. The
> configure script is written in such a way that it just doesn't install these
> components if they are not found. I don't need a spell checker nor gda, so I
> used this and it worked fine.
> 

I'm having exactly the same issue with mozembeded, it's trying to pull all kinds of stuff.

any thoughs on this being implemented?
Comment 4 John N. Laliberte (RETIRED) gentoo-dev 2006-07-03 11:21:41 UTC
*** Bug 128911 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-07-14 02:49:14 UTC
*** Bug 140312 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-07-25 13:24:30 UTC
*** Bug 141732 has been marked as a duplicate of this bug. ***
Comment 7 yoyo 2006-09-19 08:26:37 UTC
Well I think it's the better place for my problem. It is :

When firefox USEflag is enabled, gnome-python-extras require mozilla-firefox while mozilla-firefox-bin is installed.
Is this a correct behaviour ??

In any case, I thought it just needs to replace 
firefox? ( >=www-client/mozilla-firefox-1.0 ) by 
firefox? ( >=www-client/mozilla-firefox-1.0 || >=www-client/mozilla-firefox-bin-1.0 ) or equivalent in the ebuild file but it didn't work.

Could you help ?
Comment 8 Rémi Cardona gentoo-dev 2006-09-19 08:41:06 UTC
It is a correct behavior since firefox-bin doesn't provide Gecko libs for other applications to use. It's basically stand-alone. You need either firefox or some other package that provides a gtkmozembed library.

Mozilla (and then Seamonkey) used to provide it, Firefox does, XulRunner will in the future, but right now Gnome (and the Gnome herd) only supports Firefox and XulRunner. Since XulRunner is not an official part of Gentoo yet, you'll need to build mozilla-firefox.

This is a completely different bug altogether.
Comment 9 yoyo 2006-09-20 07:24:29 UTC
(In reply to comment #8)

Ok, thanks a lot for all these precisions R
Comment 10 yoyo 2006-09-20 07:24:29 UTC
(In reply to comment #8)

Ok, thanks a lot for all these precisions Rémy. I'll wait for the XulRunner to be included in the tree.
But for now, I emerge mozilla-firefox to satisfy this regular depence.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-10-10 13:32:32 UTC
*** Bug 150780 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-12-21 23:57:05 UTC
*** Bug 158795 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-01-19 03:36:13 UTC
I'm against adding USE flags for components until we have use-based deps.  The current built_with_use system is horrible, and results in tons of failures to emerge.  Once we have use-based deps, I'm willing to revisit this.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2008-02-05 09:52:08 UTC
Marking LATER wrt Comment #13 
Comment 15 Mart Raudsepp gentoo-dev 2008-02-07 23:48:24 UTC
Jakub, please don't touch like that bugs that are not assigned to bugwranglers, thank you.
Retitling for the real solution (which we have an example of how to do now for gnome-python-desktop) and reopening...

The real workable solution involves splitting the actual bindings into multiple packages and making gnome-python-desktop a meta package that pulls them all in (and results in all the same things getting installed as far as files go). Major build system massaging and a "would be nice but very low priority" kind of thing, and I don't believe any of the gnome team searches for RESOLVED LATER to ever find these bugs again, so keeping it open...
Comment 16 Gilles Dartiguelongue gentoo-dev 2008-04-21 22:14:58 UTC
waiting on updates of Ford_Prefect which should happen really soon (tm).
I'll be duping bugs concerning this topic to clean up bugzilla.
Comment 17 Gilles Dartiguelongue gentoo-dev 2008-04-21 22:19:48 UTC
*** Bug 160991 has been marked as a duplicate of this bug. ***
Comment 18 Gilles Dartiguelongue gentoo-dev 2008-04-21 22:25:04 UTC
*** Bug 192351 has been marked as a duplicate of this bug. ***
Comment 19 Arun Raghavan (RETIRED) gentoo-dev 2008-04-22 17:53:02 UTC
(In reply to comment #16)
> waiting on updates of Ford_Prefect which should happen really soon (tm).
> I'll be duping bugs concerning this topic to clean up bugzilla.

Time-frame for update is about one week. Sorry for the delay. Real-life stuff. :|
Comment 20 Arun Raghavan (RETIRED) gentoo-dev 2008-05-05 17:43:30 UTC
(In reply to comment #19)
> (In reply to comment #16)
> > waiting on updates of Ford_Prefect which should happen really soon (tm).
> > I'll be duping bugs concerning this topic to clean up bugzilla.
> 
> Time-frame for update is about one week. Sorry for the delay. Real-life stuff.
> :|

Latest tree can be got from http://gitorious.org/projects/g-py-split/repos/mainline (it's a page with links to the git:// and http:// repository). Branch is still g-py-split. Major changes since the last time -- feedback and (dare I ask?) testing welcome. :)
Comment 21 R Bar-On 2008-05-21 17:06:16 UTC
I'm not quite sure how this is supposed to work.  I cloned the git overlay, unmasked everything necessary and emerged gnome-python-desktop.  It just wants to install everything that the old version wanted (incl totem, etc).  There don't seem to be use flags to set options.  I'd love to test this, but can't for the life of me figure out what I'm supposed to do....
Comment 22 Arun Raghavan (RETIRED) gentoo-dev 2008-05-21 17:12:30 UTC
(In reply to comment #21)
[...]
> I'm not quite sure how this is supposed to work.  I cloned the git overlay,
> unmasked everything necessary and emerged gnome-python-desktop.  It just wants

Well, it's still work in progress. Currently, gnome-python-desktop is just a meta-ebuild which is supposed to be functionally equivalent to the old gnome-python-desktop ebuild.

The idea is that once this is in-tree, packages can start depending on only those modules (e.g. dev-python/gtkmozembed-python which they require. Only people who explicitly want all packages need to install gnome-python-desktop itself.

In the mean time, it'd be great if as a first step you could use the meta ebuilds as replacements for the monolithic ebuilds and verify that nothing breaks.

Thanks!
Comment 23 Gilles Dartiguelongue gentoo-dev 2008-05-22 21:28:32 UTC
sorry there is no relation whatsoever between these bugs.
Comment 24 horea_christian 2008-05-25 15:25:52 UTC
yes, I'm having the same issue. I emerged screenlets from the desktop-effects overlay and now my beautifully lightweight gnome-light installation is crammed with totem and nautilus cd burner and the likes :( 

it would be really helpful to have some use flags for all the additional stuff gnome-python-desktop pulls in. I really see no need for it to come with totem or volume control or what not...
Comment 25 Arun Raghavan (RETIRED) gentoo-dev 2008-05-25 15:39:58 UTC
(In reply to comment #24)
[...]
> it would be really helpful to have some use flags for all the additional stuff
> gnome-python-desktop pulls in. I really see no need for it to come with totem
> or volume control or what not...

As mentioned in comment 20 and 22, this is being worked on. We hope to have this in-tree soon, after which individual packages will be able to depend o the modules they need.
Comment 26 horea_christian 2008-05-25 17:44:38 UTC
sry, I missed that... so how much till it gets into portage? how can I help test it?
Comment 27 Arun Raghavan (RETIRED) gentoo-dev 2008-05-25 20:28:05 UTC
(In reply to comment #26)
> sry, I missed that... so how much till it gets into portage? how can I help
> test it?

This still has to be tested and then committed, after which each package that uses any of these packages needs to have its deps updated. So the only real answer is "when it's ready".

In the mean time, it'd be great if you could get try the ebuilds in the overlay mentioned above and report any issues here. Thanks!
Comment 28 Arun Raghavan (RETIRED) gentoo-dev 2008-09-03 02:39:18 UTC
FYI, split gnome-python is now in tree. Will update when gnome-python-desktop and gnome-python-extras are done.
Comment 29 trefoil 2008-09-03 05:21:52 UTC
I know bugzie isn't the place for it, but I applaud your work on this.
Comment 30 Arun Raghavan (RETIRED) gentoo-dev 2008-09-14 19:26:46 UTC
(In reply to comment #29)
> I know bugzie isn't the place for it, but I applaud your work on this.

Thank you!

gnome-python-desktop bindings are in. gnome-python-extras, and dependencies of all three are pending.
Comment 31 Gilles Dartiguelongue gentoo-dev 2008-10-18 19:08:17 UTC
*** Bug 242640 has been marked as a duplicate of this bug. ***
Comment 32 Gilles Dartiguelongue gentoo-dev 2008-10-19 10:48:16 UTC
FYI, gnome-python-extras is now in, I'll keep working on fixing deps around the tree as Arun will be mostly away until december.
Comment 33 Gilles Dartiguelongue gentoo-dev 2008-11-29 11:31:14 UTC
*** Bug 249206 has been marked as a duplicate of this bug. ***
Comment 34 Gilles Dartiguelongue gentoo-dev 2009-05-23 14:28:53 UTC
converting to a tracker bug so we can open bugs and get rid of monolithic deps.

See:
http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python
http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python-desktop
http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python-extras

Currently, excluding blockers dep:
 * gnome-python: 61 revisions using it
 * gnome-python-desktop: 30 revisions using it
 * gnome-python-extras: 34 revisions using it
Comment 35 Matt Enright 2010-03-11 13:56:58 UTC
(In reply to comment #34)
> converting to a tracker bug so we can open bugs and get rid of monolithic deps.
> 
> See:
> http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python
> http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python-desktop
> http://tinderbox.dev.gentoo.org/misc/rindex/dev-python/gnome-python-extras
> 
> Currently, excluding blockers dep:
>  * gnome-python: 61 revisions using it
>  * gnome-python-desktop: 30 revisions using it
>  * gnome-python-extras: 34 revisions using it
> 

Is this still in-progress, or even desirable given the proper USE dependencies now in EAPI-2?
Comment 36 Gilles Dartiguelongue gentoo-dev 2010-03-11 14:32:10 UTC
how does this related to default IUSE at all ???
Comment 37 Matt Enright 2010-03-11 14:35:20 UTC
(In reply to comment #36)
> how does this related to default IUSE at all ???
> 

It doesn't, but it relates to the split packages...I was under the impression that there was a move away from splitting upstream sources in Gentoo now that the USE dependencies are sanely handled.
Comment 38 Peter Volkov (RETIRED) gentoo-dev 2011-04-19 05:54:01 UTC
Hm. But what provides gnome-python-2.0.pc now?
Comment 39 Gilles Dartiguelongue gentoo-dev 2011-04-19 08:27:58 UTC
(In reply to comment #38)
> Hm. But what provides gnome-python-2.0.pc now?

# qlist  dev-python/gnome-python-desktop-base
/usr/lib/pkgconfig/gnome-python-desktop-2.0.pc

This is depended on by all split python bindings ebuilds so you don't have to worry about that.
Comment 40 Peter Volkov (RETIRED) gentoo-dev 2011-04-19 10:57:48 UTC
(In reply to comment #39)
> (In reply to comment #38)
> > Hm. But what provides gnome-python-2.0.pc now?
> 
> # qlist  dev-python/gnome-python-desktop-base
> /usr/lib/pkgconfig/gnome-python-desktop-2.0.pc

This has a different name and pkgconfig search for gnome-python-2.0 fails... Actually absence of gnome-python-2.0.pc file kept dev-python/nautilus-python from being ported to split gnome-python bindings and although now I've modified configure script to avoid this check I'm still interested in more clean fix to submit upstream.
Comment 41 Gilles Dartiguelongue gentoo-dev 2011-04-19 19:13:45 UTC
Sorry I meant:

$ qlist dev-python/gnome-python-base
/usr/lib64/pkgconfig/gnome-python-2.0.pc

It's the same logic for all three original bindings providers.
Comment 42 Pacho Ramos gentoo-dev 2011-06-13 15:05:24 UTC
All deps should be fixed, should I hardmask metas for removal or we want to keep them for any other usage?
Comment 43 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-06-15 07:44:59 UTC
(In reply to comment #42)
> All deps should be fixed, should I hardmask metas for removal or we want to
> keep them for any other usage?

Let's get rid of them. None of these packages will ever get updates again anyway.
Comment 44 Pacho Ramos gentoo-dev 2012-01-22 13:00:11 UTC
Done