Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 10773 - qt-3.1.0 cannot be emerged.
Summary: qt-3.1.0 cannot be emerged.
Status: RESOLVED DUPLICATE of bug 10834
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2002-11-15 08:41 UTC by Dave Berenson
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Dave Berenson 2002-11-15 08:41:10 UTC
I was able to emerge the older qt-snapshots, but this one is just not working
for me.

g++ -fno-exceptions -o ../../../bin/uic .obj/release-shared-mt/main.o
.obj/release-shared-mt/uic.o .obj/release-shared-mt/form.o
.obj/release-shared-mt/object.o .obj/release-shared-mt/subclassing.o
.obj/release-shared-mt/embed.o .obj/release-shared-mt/widgetdatabase.o
.obj/release-shared-mt/domtool.o .obj/release-shared-mt/parser.o   
-L/var/tmp/portage/qt-3.1.0/work/qt-x11-free-3.1.0/lib -L/usr/X11R6/lib
-L/usr/X11R6/lib -ldl -lpthread -lqt-mt -lmng -ljpeg -lpng -lz -lpthread -lGLU
-lGL -lXmu -lSM -lICE -ldl -lXext -lX11 -lm -lXinerama -lXrender -lXft
-lfreetype -lXi
/var/tmp/portage/qt-3.1.0/work/qt-x11-free-3.1.0/lib/ undefined
reference to `XftDrawCreateAlpha'
/var/tmp/portage/qt-3.1.0/work/qt-x11-free-3.1.0/lib/ undefined
reference to `XftCharExists'
/var/tmp/portage/qt-3.1.0/work/qt-x11-free-3.1.0/lib/ undefined
reference to `XftDrawPicture'
collect2: ld returned 1 exit status
make[3]: *** [../../../bin/uic] Error 1
make[3]: Leaving directory
make[2]: *** [sub-uic] Error 2
make[2]: Leaving directory
make[1]: *** [sub-designer] Error 2
make[1]: Leaving directory `/var/tmp/portage/qt-3.1.0/work/qt-x11-free-3.1.0/tools'
make: *** [sub-tools] Error 2

!!! ERROR: x11-libs/qt-3.1.0 failed.
!!! Function src_compile, Line 72, Exitcode 2
!!! (no error message)

I'm running xfree-4.2.1 [not r1] with xft2/fontconfig. I re-emerged xft2 just to
be safe, as that fixed it most of the time.  I'm still having a problem.
Comment 1 Hannes Mehnert (RETIRED) gentoo-dev 2002-11-15 12:28:20 UTC
the problem is xft2, if you unmerge it, qt will compile. 
Comment 2 Bart Verwilst 2002-11-15 12:44:05 UTC
isn't qt 3.1 supposed to be compatible with xft2?
Comment 3 Dave Berenson 2002-11-15 12:46:14 UTC
Yes, it is... 
And for the heck of it I tried what you said, and I got this: 
root@gentoo grandpajive # emerge qt 
Calculating dependencies ...done! 
>>> emerge (1 of 1) x11-libs/qt-3.1.0 to / 
>>> md5 ;-) qt-x11-free-3.1.0.tar.gz 
>>> Unpacking source... 
>>> Unpacking qt-x11-free-3.1.0.tar.gz 
>>> Source unpacked. 
Xft support cannot be enabled due to functionality tests! 
 Turn on verbose messaging (-v) to ./configure to see the final report. 
 If you believe this message is in error you may use the continue 
 switch (-continue) to ./configure to continue. 
!!! ERROR: x11-libs/qt-3.1.0 failed. 
!!! Function src_compile, Line 68, Exitcode 101 
!!! (no error message) 
Comment 4 Hannes Mehnert (RETIRED) gentoo-dev 2002-11-15 14:16:24 UTC
sorry if i'm wrong, but i get the following: 
-when i emerge xft-2.0, i get exactly your error, without xft-2.0, qt-3.1.0 compiles 
fine (with xfree-4.2.1) 
-look at it is a similar issue 
Comment 5 Dave Berenson 2002-11-15 14:38:09 UTC
agreed, it is similar.. but I noticed that with 3.1.0_pre20021104 some extra
things happen:

cd include && headers=`ls q*.h 2>/dev/null` &&\
        [ "x$headers" != "x" ] && rm -f $headers;
cd include && ln -f -s ../src/*/q*.h . && ln -f -s ../extensions/*/src/q*.h . && \
ln -f -s ../tools/designer/uilib/q*.h . &&\
        ln -f -s ../tools/assistant/lib/q*.h . && rm -f q*_p.h && \
cd private && rm -f q*.h && ln -f -s ../../src/*/q*_p.h .;

and with 3.0.5-rc2 some patches are applied, and with this version no patches or
anything happen.

I tried again after an rsync from 2 minutes ago, and I still get that problem
when I remove xft.  I'd really hate to lose xft, but I could try compiling
without xft. [ie, remove it from the configure line in the ebuild].

Comment 6 Hannes Mehnert (RETIRED) gentoo-dev 2002-11-15 15:39:50 UTC
well, qt-3.1.0 works with xft-1 (which is from xfree), you don't have to change the 
a problem is, that xft-2 overwrites files in /usr/include/X11/Xft/, so you have to 
emerge xfree first (which will put his xft files there) and then emerge qt. 
Comment 7 Dave Berenson 2002-11-15 15:58:29 UTC
Oddly enough, I could build qt-3.1.0 from source when I removed xft2.. the
ebuild when checking/testing for xft would fail.  

I used this for the configure line:

./configure -system-zlib -qt-gif -system-libpng \
-system-libjpeg -plugin-imgfmt-mng -thread -no-stl \
-no-xinerama -no-g++-exceptions

When configuring it said it didn't find XFT so... its not there.  Hmm. Guess
thats why xft2 is masked after all ;)

Nonetheless its a sticky situation... I hope I'm the only one stuck with this.  
Comment 8 Hannes Mehnert (RETIRED) gentoo-dev 2002-11-16 11:27:16 UTC
ok, if you want to use xft-2 and qt-3.1, i have the following solution for you: 
emerge xft-2 
rm /usr/X11R6/lib/libXft* 
then emerge qt-3.1 should work with xft-2 
Comment 9 Hannes Mehnert (RETIRED) gentoo-dev 2002-11-16 20:00:46 UTC
well, i opened a bug about xft-2 and gentoo in general, i mark this as duplicate of it. 
thank you for submission. 

*** This bug has been marked as a duplicate of 10834 ***