Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 107350 - Can not burn DVD(weird dmesg)
Summary: Can not burn DVD(weird dmesg)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-26 19:13 UTC by Lee Trager
Modified: 2005-10-03 11:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Trager 2005-09-26 19:13:41 UTC
Im trying to burn a DVD with my Pioneer DVR-108 FW-1.20 and every time I try to
k3b gives me the following error

System
-----------------------
K3b Version: 0.12

KDE Version: 3.4.2
QT Version:  3.3.4
Kernel:      2.6.13-gentoo-r2
Devices
-----------------------
PIONEER DVD-RW  DVR-108 1.20 (/dev/hda, ) at /mnt/cdrom [CD-R; CD-RW; CD-ROM;
DVD-ROM; DVD-R; DVD-RW; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential;
DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double
Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16;
RAW/R96P; RAW/R96R; Restricted Overwrite]

Used versions
-----------------------
growisofs: 5.21

growisofs
-----------------------
WARNING: /dev/hda already carries isofs!
About to execute 'builtin_dd
if=/home/nuke/KNOPPIX_V4.0.2DVD-2005-09-23-EN/KNOPPIX_V4.0.2DVD-2005-09-23-EN.iso
of=/dev/hda obs=32k seek=0'
/dev/hda: restarting DVD+RW format...
/dev/hda: "Current Write Speed" is 4.1x1385KBps.
:-( unable to WRITE@LBA=740h: Input/output error
:-( write failed: Input/output error
/dev/hda: flushing cache
:-( unable to FLUSH CACHE: Input/output error
/dev/hda: writing lead-out

growisofs command:
-----------------------
/usr/bin/growisofs -Z
/dev/hda=/home/nuke/KNOPPIX_V4.0.2DVD-2005-09-23-EN/KNOPPIX_V4.0.2DVD-2005-09-23-EN.iso
-use-the-force-luke=notray -use-the-force-luke=tty -dvd-compat -speed=4 

My dmesg gives me this
hda: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hda: CHECK for good STATUS
hda: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
hda: cdrom_decode_status: error=0x40 { LastFailedSense=0x04 }
ide: failed opcode was: unknown
hda: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
hda: cdrom_decode_status: error=0x40 { LastFailedSense=0x04 }
ide: failed opcode was: unknown
hda: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
hda: cdrom_decode_status: error=0x40 { LastFailedSense=0x04 }
ide: failed opcode was: unknown
hda: cdrom_decode_status: status=0x51 { DriveReady SeekComplete Error }
hda: cdrom_decode_status: error=0x40 { LastFailedSense=0x04 }
ide: failed opcode was: unknown
hda: DMA disabled
hda: ide_intr: huh? expected NULL handler on exit
hda: ATAPI reset complete
hda: write_intr: bad interrupt reason 1
hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
ide: failed opcode was: unknown
hda: drive not ready for command
hda: status timeout: status=0xd8 { Busy }
ide: failed opcode was: unknown
hda: drive not ready for command
hda: ATAPI reset complete

Reproducible: Always
Steps to Reproduce:
1. Start k3b
2. Select Knoppix 4.0.2 DVD ISO
3. Burn ISO

Actual Results:  
k3b and dmesg gives me error.

Expected Results:  
Burned the DVD ISO

Portage 2.0.52-r1 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1, 2.6.13
-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.13-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe -ffast-math -msse3 -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share
/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kd
e/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defau
lts/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O3 -pipe -ffast-math -msse3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/
distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib aim alsa amd64 arts avi bash-completion berkdb bitmap-fonts
 bzlib cdb cdr crypt cups curl dedicated dvb dvd dvdr dvdread eds emboss emul-li
nux-x86 encode esd ethereal examples fam ffmpeg flac font-server foomaticdb fort
ran ftp gcj gdbm gif gimpprint glut gnome gpm gstreamer gtk gtk2 gtkhtml imagema
gick imlib ipv6 java javascript jpeg junit kde ldap lm_sensors lzw lzw-tiff mad 
mikmod mmap mng motif mozilla mp3 mpeg ncurses nls nocd nptl nvidia offensive og
g oggvorbis openal opengl oscar oss pam pda pdflib perl png python qt quicktime 
readline sdl slang spell ssl svg tcpd theora tiff truetype-fonts type1-fonts usb
 userlocales videos vorbis xine xml xml2 xmms xpm xprint xv xvid zlib userland_G
NU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-09-27 00:03:40 UTC
We really cannot fix a broken DVD writer...
Comment 2 Lee Trager 2005-09-27 04:46:26 UTC
I didnt think the drive itself was broken because just the otherday I was
burning DVDs/CDs fine. Infact I burned a CD right before this. Well I guess ill
RMA it.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-09-27 04:51:13 UTC
According to the dmesg output, there's definitely something really wrong w/ the
drive. You can try in another computer or using some livecd linux distro, but it
does not look sane. Might also be just a bad cable.
Comment 4 Lee Trager 2005-10-02 19:48:52 UTC
I didnt get a chance to really play around with my DVD burner till today but I
downloaded Nero for Linux and everything is fine, there is no dmesg at all. The
only time I get this error is with some DVD ISOs(knoppix for example) and
possibly some media types(maxell DVD+RW). Could this be a problem with
DVD+RW/+R/-R[W] tools?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-10-02 23:22:08 UTC
(In reply to comment #4)

I don't really understand, please describe when exactly you get this error. 
Comment 6 Lee Trager 2005-10-03 04:50:28 UTC
Whenever I burn a DVD with k3b using growisofs I get that dmesg. Sometimes it
will burn the DVD fine other times it will error out. If I use Nero For Linux it
burns just fine, there is no dmesg.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-10-03 04:56:33 UTC
(In reply to comment #6)
> Whenever I burn a DVD with k3b using growisofs I get that dmesg. Sometimes it
> will burn the DVD fine other times it will error out. 

I'm sorry but something that is sometimes reproducible, sometimes not and
sometimes happens with some media and not with others and with some ISOs and not
with others really suggests that your hardware is not in a sane shape and
randomly fails. I'd also suggest that you check the media burnt w/ Nero if they
are actually readable and not faulty. 
Comment 8 Luis Medinas (RETIRED) gentoo-dev 2005-10-03 11:12:17 UTC
it seems to me that is a DMA problem. Try another kernel version and take a look
at your BIOS.
You can try to modify a few things with hdparm.