Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 107274 - media-gfx/gwenview > 1.2.0 build error
Summary: media-gfx/gwenview > 1.2.0 build error
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Heinrich Wendel (RETIRED)
Depends on:
Reported: 2005-09-26 05:08 UTC by Marcin Gryszkalis
Modified: 2005-09-29 04:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Build log (4410-gwenview-1.3.0.log,65.21 KB, text/plain)
2005-09-26 05:10 UTC, Marcin Gryszkalis

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Gryszkalis 2005-09-26 05:08:05 UTC
Build of gwenview fails on kde 3.4.1 because of some hardcoded (?) kde3.3 strings.
Below few lines from build log, complete log attached

Reproducible: Always
Steps to Reproduce:
emerge --update gwenview

Actual Results:  
>>> Unpacking source...
>>> Unpacking gwenview-1.3.0.tar.bz2 to /var/tmp/portage/gwenview-1.3.0/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... i686-pc-linux-gnu-strip
checking for kde-config... /usr/kde/3.4/bin/kde-config
checking where to install... /usr (as requested)
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
not using lib directory suffix
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for objdir... .libs
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for Qt... libraries /usr/qt/3/lib, headers /usr/qt/3/include using -mt
checking for moc... /usr/qt/3/bin/moc
checking for uic... /usr/qt/3/bin/uic
checking whether uic supports -L ... yes
checking whether uic supports -nounload ... yes
checking if Qt needs -ljpeg... no
checking for rpath... yes
checking for KDE... libraries /usr/kde/3.4/lib, headers /usr/kde/3.4/include
checking if UIC has KDE plugins available... yes
checking for KDE paths... defaults
checking for dcopidl... /usr/kde/3.4/bin/dcopidl
checking for dcopidl2cpp... /usr/kde/3.4/bin/dcopidl2cpp
checking for mcopidl... /usr/kde/3.4/bin/mcopidl
checking for artsc-config... /usr/kde/3.4/bin/artsc-config
checking for meinproc... /usr/kde/3.4/bin/meinproc
checking for kconfig_compiler... /usr/kde/3.4/bin/kconfig_compiler
checking for dcopidlng... /usr/kde/3.4/bin/dcopidlng
checking for xmllint... /usr/bin/xmllint
checking for Qt docs... /usr/qt/3/doc/html
checking for dot... /usr/bin/dot
checking for doxygen... /usr/bin/doxygen

configure: creating ./config.status
fast creating Makefile fast created 119 file(s).
config.status: creating config.h
config.status: executing depfiles commands

Good - your configure finished. Start make now

make  all-recursive
make[1]: Entering directory `/var/tmp/portage/gwenview-1.3.0/work/gwenview-1.3.0'
Making all in doc
make[2]: Entering directory
/usr/kde/3.4/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
make[2]: Leaving directory `/var/tmp/portage/gwenview-1.3.0/work/gwenview-1.3.0/doc'
Making all in src
make[2]: Entering directory
Making all in tsthread
make[3]: Entering directory
/usr/qt/3/bin/moc ./tsthread.h -o tsthread.moc
/bin/sh ../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++
-DHAVE_CONFIG_H -I. -I. -I../.. -I. -I./.. -I/usr/kde/3.4/include
-I/usr/qt/3/include -I.   -DQT_THRE
AD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts
-Wall -W -Wpointer-arith -W
no-non-virtual-dtor -DNDEBUG -DNO_DEBUG -O2 -mcpu=athlon -O2 -pipe
-fomit-frame-pointer -g -Wformat-security -Wmissing-format-attribute
-fno-exceptions -fno-check-new -fno-common
-DQT_NO_TRANSLATION  -c -o tsthread.lo `test -f 'tsthread.cpp' || echo
/bin/sh ../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++
-DHAVE_CONFIG_H -I. -I. -I../.. -I. -I./.. -I/usr/kde/3.4/include
-I/usr/qt/3/include -I.   -DQT_THRE
AD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts
-Wall -W -Wpointer-arith -W
no-non-virtual-dtor -DNDEBUG -DNO_DEBUG -O2 -mcpu=athlon -O2 -pipe
-fomit-frame-pointer -g -Wformat-security -Wmissing-format-attribute
-fno-exceptions -fno-check-new -fno-common
-DQT_NO_TRANSLATION  -c -o tswaitcondition.lo `test -f 'tswaitcondition.cpp' ||
echo './'`tswaitcondition.cpp
/bin/sh ../../libtool --silent --mode=link --tag=CXX i686-pc-linux-gnu-g++ 
-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W
-Wpointer-arith -Wno-non-virtual-dtor -DNDEBUG -DNO_DEBUG -O2 -mcpu=athlon -O2
-pipe -fomit-frame-pointer -g -Wformat-security -Wmissing-format-attribute
-fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o   tsthread.lo tswaitcondition.lo

/bin/sh ../../libtool --silent --mode=link --tag=CXX i686-pc-linux-gnu-g++ 
-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -Wcast-align -Wconver
sion -Wchar-subscripts -Wall -W -Wpointer-arith -Wno-non-virtual-dtor -DNDEBUG
-DNO_DEBUG -O2 -mcpu=athlon -O2 -pipe -fomit-frame-pointer -g -Wformat-security
ribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE
L/usr/kde/3.4/lib -L/usr/qt/3/lib -L/usr/lib    -version-info 1:0:0
-no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined printdialog.lo
thumbnailloadjob.lo imageview.lo ba
tchmanipulator.lo document.lo externaltoolmanager.lo externaltoolcontext.lo
externaltoolaction.lo externaltooldialog.lo fileviewstack.lo
filethumbnailview.lo fileoperation.lo file
opobject.lo filethumbnailviewitem.lo qxcfi.lo archive.lo slideshow.lo
filedetailview.lo filedetailviewitem.lo imagesavedialog.lo slideshowdialog.lo
jpegformattype.lo pngformattype
.lo mngformattype.lo xpm.lo documentimpl.lo documentloadingimpl.lo
documentloadedimpl.lo documentjpegloadedimpl.lo documentanimatedloadedimpl.lo
kipiinterface.lo busylevelmanager.
lo cache.lo threadgate.lo imageviewtools.lo fullscreenbar.lo imageloader.lo
cursortracker.lo captionformatter.lo thumbnaildetailsdialog.lo
printdialogpagebase.lo externaltooldialo
gbase.lo slideshowdialogbase.lo thumbnaildetailsdialogbase.lo gvconfig.lo -lkio
-lkdeui -lkdecore -lkdeprint -lqt-mt  -lz -lpng -lz -lm -lXext -lX11  -lSM -lICE
-lpthread -ljpeg -
lpng -lz -lm -lmng -lz -lm -lkipi -lexif -lm   ../imageutils/
grep: /usr/kde/3.3/lib/ No such file or directory
/bin/sed: can't read /usr/kde/3.3/lib/ No such file or directory
libtool: link: `/usr/kde/3.3/lib/' is not a valid libtool archive
make[3]: *** [] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gwenview-1.3.0/work/gwenview-1.3.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gwenview-1.3.0/work/gwenview-1.3.0'
make: *** [all] Error 2

Portage (default-linux/x86/2005.0, gcc-3.3.6, glibc-2.3.5-r1,
2.6.12-gentoo-r10-hq i686)
System uname: 2.6.12-gentoo-r10-hq i686 AMD Duron(tm) processor
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2
sys-apps/sandbox:    1.2.10
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-mcpu=athlon -O2 -pipe -fomit-frame-pointer -g"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon -O2 -pipe -fomit-frame-pointer -g"
FEATURES="autoconfig ccache distlocks noauto nostrip notitles sandbox sfperms
strict userpriv usersandbox"
USE="x86 3dnow 3dnowex X acpi adns alsa apache2 apm arts avi bash-completion
berkdb bitmap-fonts bonobo bzip2 cdr crypt cscope cups curl divx4linux doc eds
emboss encode esd fam flac foomaticdb fortran gd gdbm gif gnome gphoto2 gpm
gstreamer gtk gtk2 guile imagemagick imlib innodb ipv6 irda jabber jack java
javascript jpeg junit kde kipi libg++ libwww lm_sensors mad maildir mbox mikmod
mmx motif mozdevelop mozilla mp3 mpeg mysql mysqli ncurses nls ogg oggvorbis
opengl oss pam pcre pdflib perl php png python qt quicktime readline real samba
sdl skey slang spell ssl svga symlink tcltk tcpd tetex tiff truetype
truetype-fonts type1-fonts unicode usb v4l v4l2 vhosts visualization vorbis
win32codecs xine xml xml2 xmms xv xvid zlib video_cards_radeon linguas_en
userland_GNU kernel_linux elibc_glibc"
Comment 1 Marcin Gryszkalis 2005-09-26 05:10:15 UTC
Created attachment 69260 [details]
Build log
Comment 2 Heinrich Wendel (RETIRED) gentoo-dev 2005-09-26 07:01:08 UTC
i don't think it's a gwenview problem, but something screwed up with your 
system, not sure what though
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2005-09-26 09:21:50 UTC
Heinrich >> Bug 98425, applied the workaround to gwenview

Marcin: Please sync in a couple of hours, the modified ebuild tells you how to
upgrade properly, then.
Comment 4 Marcin Gryszkalis 2005-09-27 02:15:00 UTC
I did sync, it seems that ebuild is changed because after
# emerge --update gwenview 
it said:
 * Scan for possible needed slot related rebuilds.
 * Please run "emerge --oneshot  =media-plugins/kipi-plugins-0.1.0_beta2" before

Then I did
# emerge --oneshot  =media-plugins/kipi-plugins-0.1.0_beta2
(not sure if it's important but I have kipi-plugins-0.1.0_beta2 already installed)

Unfortunately it didn't work:

/bin/sh ../../libtool --silent --mode=link --tag=CXX i686-pc-linux-gnu-g++ 
-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500
-D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W
-Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -mcpu=athlon -O2 -pipe
-fomit-frame-pointer -g -Wformat-security -Wmissing-format-attribute
-fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o -rpath /usr/lib/kde3 -module -avoid-version -module
-no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /usr/lib -R
/usr/kde/3.4/lib -R /usr/qt/3/lib -R /usr/lib  -L/usr/kde/3.4/lib
-L/usr/qt/3/lib -L/usr/lib    plugin_printwizard.lo frmprintwizard.lo
cropframe.lo tphoto.lo utils.lo frmprintwizardbase.lo -lkparts -lkdeprint
-lkdeui -lkdecore -lkipi
grep: /usr/kde/3.3/lib/ No such file or directory
/bin/sed: can't read /usr/kde/3.3/lib/ No such file or directory
libtool: link: `/usr/kde/3.3/lib/' is not a valid libtool archive
make[3]: *** [] Error 1

Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2005-09-27 15:34:44 UTC
I missed to add the same check to the older kipi-plugins ebuilds. Should work now.
Comment 6 Marcin Gryszkalis 2005-09-29 04:38:30 UTC
I can confirm that it works now (gwenview told me to rebuild kipi-plugins and
kipi-plugins asked me to rebuild kipi and exifier - I did and everything worked).
Comment 7 Marcin Gryszkalis 2005-09-29 04:38:56 UTC
so it's verified
Comment 8 Marcin Gryszkalis 2005-09-29 04:49:26 UTC
Oh, I forgot to say "thank you!" ;) That was quick.