Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 107193 - ksvg-3.5_beta1 fails to build with link failure
Summary: ksvg-3.5_beta1 fails to build with link failure
Status: RESOLVED DUPLICATE of bug 78720
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High blocker (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-25 09:35 UTC by Jose daLuz
Modified: 2005-09-25 10:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jose daLuz 2005-09-25 09:35:41 UTC
I am installing kde-meta 3.5beta1.  When the process reaches ksvg, I get the
following error:

/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
.libs/Converter.o: relocation R_X86_64_PC32 against
`std::basic_ostringstream<char, std::char_traits<char>, std::allocator<char>
>::basic_ostringstream(std::_Ios_Openmode)@@GLIBCXX_3.4' can not be used when
making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
final link failed: Bad value
collect2: ld returned 1 exit status
make[6]: *** [libtext2path.la] Error 1
make[6]: Leaving directory
`/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1/ksvg/impl/libs/libtext2path/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory
`/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1/ksvg/impl/libs/libtext2path'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
`/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1/ksvg/impl/libs'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1/ksvg/impl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1/ksvg'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/ksvg-3.5_beta1/work/ksvg-3.5_beta1'
make: *** [all] Error 2

!!! ERROR: kde-base/ksvg-3.5_beta1 failed.

As can be seen from emerge --info below, I have the pic useflag set (it's been
set almost since I started using Gentoo this March) and world has been build
with that useflag multiple times.


Reproducible: Always
Steps to Reproduce:
1. emerge -av kde-meta
2.
3.

Actual Results:  
Build ends with above error.

Expected Results:  
Build should complete without errors.

 emerge --info
Portage 2.0.52-r1 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-ck5 x86_64)
=================================================================
System uname: 2.6.13-ck5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0_pre8
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env
/usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/bmg-main /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X aac aalib alsa avi bash-completion berkdb bitmap-fonts cdr crypt
cups curl dbus eds emboss encode esd flac foomaticdb fortran gdbm gif gnome gpm
gstreamer gtk gtk2 hal howl imagemagick imlib ipv6 java jpeg kde ldap libwww lzw
lzw-tiff mad maildir mikmod mono motif mozilla mp3 mpeg ncurses nls nptl ogg
oggvorbis opengl pam pdflib perl pic png python qt quicktime readline ruby samba
sdl speex spell sqlite ssl tcltk tcpd tetex theora tiff truetype-fonts
type1-fonts usb userlocales vorbis xine xml xml2 xmms xpm xv zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Comment 1 Jose daLuz 2005-09-25 10:02:49 UTC
I followed this with "emerge --resume --skipfirst".  The build stops at kgamma,
with a similar error:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
.libs/xvidextwrap.o: relocation R_X86_64_PC32 against
`std::basic_istringstream<char, std::char_traits<char>, std::allocator<char>
>::basic_istringstream(std::basic_string<char, std::char_traits<char>,
std::allocator<char> > const&, std::_Ios_Openmode)@@GLIBCXX_3.4' can not be used
when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
final link failed: Bad value
collect2: ld returned 1 exit status
make[4]: *** [kcm_kgamma.la] Error 1
make[4]: Leaving directory
`/var/tmp/portage/kgamma-3.5_beta1/work/kgamma-3.5_beta1/kgamma/kcmkgamma'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/var/tmp/portage/kgamma-3.5_beta1/work/kgamma-3.5_beta1/kgamma/kcmkgamma'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/var/tmp/portage/kgamma-3.5_beta1/work/kgamma-3.5_beta1/kgamma'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kgamma-3.5_beta1/work/kgamma-3.5_beta1'
make: *** [all] Error 2

!!! ERROR: kde-base/kgamma-3.5_beta1 failed.
Comment 2 Gregorio Guidi (RETIRED) gentoo-dev 2005-09-25 10:14:06 UTC
It's caused by -fvisibility-inlines-hidden in CXXFLAGS. 

*** This bug has been marked as a duplicate of 78720 ***