Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106713 - mozilla & firefox and all products using "mozsvg" need to drop cairo support
Summary: mozilla & firefox and all products using "mozsvg" need to drop cairo support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 104526 (view as bug list)
Depends on: 105396
Blocks: 98828 2.12 104060 106297
  Show dependency tree
 
Reported: 2005-09-20 12:31 UTC by Doug Goldstein
Modified: 2005-09-29 23:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Goldstein gentoo-dev 2005-09-20 12:31:58 UTC
Mozilla and all Mozilla based products using mozsvg need to switch from
"--enable-svg" to "--enable-svg=libart" so they don't use Cairo.

The Cairo API has changed and Mozilla's codebase has not updated accordingly and
as a result we can't release Cairo because of Mozilla's dependancy on the old API.

We need a new Cairo out so we need Mozilla to stop using it until Mozilla is
updated to the stable API
Comment 1 Hanno Zysik (geki) 2005-09-20 15:42:12 UTC
Small patch for Mozilla to use Cairos stable API is at bug 98828.
Likewise upstream did for cvs head (deer park).
No backport. Just API change.

Well, there is one tricky part where one function call got separated to two. One
wrapper function or however you may call it. I am no real programmer but I see
that there is no change from code being used. In the end it does the same.

I don't remember well about that part. One month ago I posted it. All the ones
that tested the patch did not report issues. I got no issues, too.

I, aswell, do not know why it is not included into portage. Noone was in need to
comment on that yet.

This patch is for Mozilla and Firefox. No idea if this patch is useful for
Thunderbird and/or Sunwhatever and other products.

It was easy to patch that. Sure other Mozilla products are as easy as
Mozilla/Firefox to patch. A good start is to have a look at cvs head. :)

May be we can get a list of broken Mozilla products to work on patches?
Comment 2 Doug Goldstein gentoo-dev 2005-09-23 16:40:53 UTC
mozilla
mozilla-firefox
gecko-sdk
Comment 3 Hanno Zysik (geki) 2005-09-24 09:45:39 UTC
Patch at bug 98828
Other products failing?
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2005-09-25 16:35:54 UTC
Those options are for the newer 1.4 brances.  Anyhow, using libart in 1.7.12 and
1.0.7.  Will go stable depending on bug #105396.
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2005-09-26 11:50:40 UTC
*** Bug 104526 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-09-29 23:58:13 UTC
*** Bug 107666 has been marked as a duplicate of this bug. ***