Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106692 - compile wxGTK with debug and release (for developing with wxWidgets)
Summary: compile wxGTK with debug and release (for developing with wxWidgets)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
: 117866 (view as bug list)
Depends on: 178824
Blocks:
  Show dependency tree
 
Reported: 2005-09-20 09:10 UTC by Dennis Muhlestein
Modified: 2007-09-01 09:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild with builddebug use flag (wxGTK-2.6.1.ebuild,2.04 KB, text/plain)
2005-09-20 09:12 UTC, Dennis Muhlestein
Details
wxGTK-2.6.2-r1.ebuild with builddebug (wxGTK-2.6.2-r1.ebuild,1.87 KB, text/plain)
2006-01-14 07:02 UTC, kaouete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Muhlestein 2005-09-20 09:10:18 UTC
While developing with wxGTK, I like to use the debug build of wxGTK.  I didn't
want to have to re-emerge without the "debug" use flag in order to get a release
build for building my releases though.

I created a "builddebug" use flag in the wxGTK-2.6.1 ebuild that can be
specified to install both the debug and release builds at the same time.

Reproducible: Always
Steps to Reproduce:
1. Copy new ebuild to /usr/local/portage/x11-libs/wxGTK
2. echo "x11-libs/wxGTK builddebug" >> /etc/portage/package.use
3. emerge -av wxGTK

Actual Results:  
#> wx-config --list

 Default config is gtk2-unicode-debug-2.6

  Default config will be used for output

  Alternate matches:
    gtk2-ansi-debug-2.6
    gtk2-ansi-release-2.6
    gtk2-unicode-release-2.6
Comment 1 Dennis Muhlestein 2005-09-20 09:12:09 UTC
Created attachment 68867 [details]
Ebuild with builddebug use flag

I'm not an ebuild expert.  This works for me though.  Probably needs some
review before (or if) can be added to portage.
Comment 2 kaouete 2006-01-14 07:01:29 UTC
i was looking for something like that.

I made a version for wxGTK-2.6.2-r1 ebuild.

i just added a --enable-debug_gdb in the configure for the debug build.
and i put the install of the debug in first to have /usr/bin/wx-config links to the gtk2-unicode-release.
Comment 3 kaouete 2006-01-14 07:02:45 UTC
Created attachment 77074 [details]
wxGTK-2.6.2-r1.ebuild with builddebug
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-01-15 03:33:09 UTC
*** Bug 117866 has been marked as a duplicate of this bug. ***
Comment 5 Mart Raudsepp gentoo-dev 2006-04-10 22:51:54 UTC
Would SLOT'ing on debug perhaps work out?
E.g, 2.6 SLOT for when no debug USE flag, 2.6-debug SLOT when debug USE flag, with all problems sorted out that may arise on the co-existance (wx-config, et cetera)
Comment 6 Dennis Muhlestein 2006-04-11 07:54:59 UTC
Sounds like it would work just fine to me. Would the slot fill a virtual/wx-2.6 space?  You could have either one or both installed, is that correct?
Comment 7 Mart Raudsepp gentoo-dev 2006-04-11 09:40:30 UTC
It is just an initial idea noted from my part, that perhaps some more knowledgable person regarding ebuild handling might shoot down before I shoot myself in the foot.
My ideas go in the lines of striving towards having all wxGTK dependent apps work against unicode, and demand for that then. The SLOT would be utilized as a different way to have co-existing different settings builds. Before gtk1/2 co-existance was handled by USE flag hell which is gone now in latest stable ebuild. I think SLOTs might work out better for allowing all of the following builds co-exist all in different slots:
2.6-release-unicode
2.6-release-ansi
2.6-debug-unicode
2.6-debug-ansi

I have no interest for gtk1 versions of all those.

Packages could use the wxwidgets eclass to select a suitable build, and instruct the user to install a wxGTK that meets demands, if a suitable one isn't installed yet. The dependency on wxGTK would pull in a wxGTK that might not be suitable, and the user will have to pull in another and the former was unnecessary.
Ugly like that until portage supports USE depends.

If someone would be able to comment on the feasibility of this idea, I'd be glad.
Not much ugliness with debug and release SLOTs, as it will suit either way to the app, but is more problematic for the unicode vs ansi ordeal.
Comment 8 Mark Loeser (RETIRED) gentoo-dev 2006-04-11 10:38:26 UTC
Slots can't be dynamic like that.  They need to be entirely deterministic and not depend on USE flags.
Comment 9 Mart Raudsepp gentoo-dev 2006-04-11 10:41:37 UTC
Alright.
I recalled a USE flag in the toolchain that made micro versions go to different SLOTs, instead of merely minor versions, hence the idea from there.
Comment 10 Mark Loeser (RETIRED) gentoo-dev 2006-04-11 10:44:42 UTC
Yea, we do have that, and it is wrong there as well :)