Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 106188 - dev-tex/letterspacing-20051018.ebuild (New Package)
Summary: dev-tex/letterspacing-20051018.ebuild (New Package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD, REVIEWED
Depends on:
Blocks:
 
Reported: 2005-09-16 06:55 UTC by Ulrich Müller
Modified: 2008-10-14 21:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
letterspacing-1.0.0.ebuild (letterspacing-1.0.0.ebuild,614 bytes, text/plain)
2005-09-16 06:56 UTC, Ulrich Müller
Details
letterspacing-1.0.0.ebuild (letterspacing-1.0.0.ebuild,621 bytes, text/plain)
2005-10-17 23:53 UTC, Ulrich Müller
Details
New licence for the package (letterspacing-licence,798 bytes, text/plain)
2005-10-18 14:18 UTC, Ulrich Müller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2005-09-16 06:55:15 UTC
Hello,

Please find attached letterspacing-1.0.0.ebuild, providing letterspacing.tex
and letterspace.sty.

letterspacing.tex used to be included in teTeX up to version 2.
It was removed from the teTeX-3 distribution; as far as I understand,
due to license issues with the TeXLive CD. This ebuild adds the old
functionality back.

As category I suggest dev-tex.

Uli
Comment 1 Ulrich Müller gentoo-dev 2005-09-16 06:56:39 UTC
Created attachment 68579 [details]
letterspacing-1.0.0.ebuild
Comment 2 Ulrich Müller gentoo-dev 2005-10-17 23:42:54 UTC
I have asked the author, Phil Taylor, about the licence issue. He says that
the information on CTAN about the package (i.e. LPPL) is wrong. However, he is
willing to re-think the licence. Stay tuned...
Comment 3 Ulrich Müller gentoo-dev 2005-10-17 23:53:49 UTC
Created attachment 70911 [details]
letterspacing-1.0.0.ebuild

HOMEPAGE and SRC_URI have changed on CTAN.
Comment 4 Ulrich Müller gentoo-dev 2005-10-18 14:18:32 UTC
Created attachment 70973 [details]
New licence for the package

Phil has submitted a new version of letterspacing to CTAN today,
containing attached licence.
Comment 5 Ulrich Müller gentoo-dev 2005-10-19 01:11:51 UTC
With the new licence, letterspacing.tex can be re-included in the main
teTeX distribution; Thomas Esser has confirmed this. So there is no need
for a separate letterspacing package.

Resolving as Upstream.
Comment 6 Ulrich Müller gentoo-dev 2006-07-14 16:41:27 UTC
Reopening... it is not in tetex-3.0_p1 which was now announced to be the last tetex version.
Comment 7 Ulrich Müller gentoo-dev 2006-07-24 06:42:05 UTC
This is now in the Sunrise overlay. You can find it at:
http://gentoo-sunrise.org/svn/reviewed/dev-tex/letterspacing/
Comment 8 Ulrich Müller gentoo-dev 2008-09-12 05:56:21 UTC
letterspacing.tex is included in dev-texlive/texlive-genericrecommended. Therefore, I think that it makes sense to resolve this as WONTFIX, and also remove dev-tex/letterspacing from Sunrise.

Alexis, any opinion?
Comment 9 Alexis Ballier gentoo-dev 2008-10-03 15:03:48 UTC
(In reply to comment #8)
> letterspacing.tex is included in dev-texlive/texlive-genericrecommended.
> Therefore, I think that it makes sense to resolve this as WONTFIX, and also
> remove dev-tex/letterspacing from Sunrise.
> 
> Alexis, any opinion?

It seems I hadn't seen this :)

And totally agreed; unless we suddenly have half a dozen of new fresh blood willing to maintain single tex packages instead of reusing texlive's ones.

As a side note, I try not to touch texlive*recommended packages because, well, they are recommended :) while i'm fine with removing stuff from texlive*extra and revive old ebuilds. (but this is just a matter of how much time I have and there is no technical problem with using single packages instead of texlive's collections)
Comment 10 Ulrich Müller gentoo-dev 2008-10-14 21:26:55 UTC
Removed from Sunrise.