Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106094 - Add a use-flag to ethereal ebuild to disable saving files
Summary: Add a use-flag to ethereal ebuild to disable saving files
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks:
 
Reported: 2005-09-15 12:40 UTC by Rouslan Solomakhin
Modified: 2005-09-19 21:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ethereal-0.10.12-nosave.patch (ethereal-0.10.12-nosave.patch,835 bytes, patch)
2005-09-15 12:42 UTC, Rouslan Solomakhin
Details | Diff
ethereal-0.10.12-to-0.10.12-r1.ebuild.patch (ethereal-0.10.12-to-0.10.12-r1.ebuild.patch,723 bytes, patch)
2005-09-15 12:43 UTC, Rouslan Solomakhin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rouslan Solomakhin 2005-09-15 12:40:37 UTC
I would like to submit the attached patch to ethereal-0.10.12 complete with a
patch to ethereal-0.10.12.ebuild which will disable saving files in ethereal.

The reason I need this is to enable regular users in a classroom environment to
take traces of network traffic, without malicious users having a possibility to
overwrite vital files like /etc/fstab or /etc/rc.conf.

The way the patch to ethereal-0.10.12 works is it pops up a message saying
"Savind disabled" when a user saves a file. The patch to ethereal-0.10.12.ebuild
adds a use-flag "nosave", which (when enabled) applies the patch to source.

Reproducible: Always
Steps to Reproduce:
Comment 1 Rouslan Solomakhin 2005-09-15 12:42:09 UTC
Created attachment 68526 [details, diff]
ethereal-0.10.12-nosave.patch

Patch to ethereal-0.10.12 to disable saving files.
Comment 2 Rouslan Solomakhin 2005-09-15 12:43:53 UTC
Created attachment 68527 [details, diff]
ethereal-0.10.12-to-0.10.12-r1.ebuild.patch

A patch to ethereal-0.10.12.ebuild to have a use-flag "nosave", which applies
patch ethereal-0.10.12-nosave.patch.
Comment 3 Marco Morales 2005-09-19 21:15:03 UTC
Thanks for your contrib, but those kinda hacks are preferable submitted 
directly to ethereal development. Thanks again n e way :)