Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 106008 - cdrtools-2.01.01_alpha03: Operation not permitted. Cannot send SCSI cmd via ioctl
Summary: cdrtools-2.01.01_alpha03: Operation not permitted. Cannot send SCSI cmd via i...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-14 14:55 UTC by Thomas Maguin
Modified: 2005-09-15 04:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Maguin 2005-09-14 14:55:35 UTC
When I try to burn as user with cdrtools-2.01.01_alpha03 I get this error message:
Operation not permitted. Cannot send SCSI cmd via ioctl and the commando
terminates. 

Reproducible: Always
Steps to Reproduce:
1. emerge cdrtools-2.01.01_alpha03
2. make user burning possible (k3bsetup, make groups, set rights)
3. cdrecord dev=ATA:1,0,0 -dao -dummy driveropst=burnfree ...

Actual Results:  
error message appear and the program terminates.

Expected Results:  
burn my cd. This cdrtools-version is now four months old - i would really
expect, that I can use it now.
Comment 1 Thomas Maguin 2005-09-14 14:56:48 UTC
Portage 2.0.51.22-r2 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-love1 i686)
=================================================================
System uname: 2.6.12-love1 i686 AMD Athlon(tm)
Gentoo Base System version 1.6.13
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -mtune=athlon-xp -O3 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mtune=athlon-xp -O3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks fixpackages maketest nostrip
sandbox sfperms strict test"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/
rsync://ftp.belnet.be/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X a52 aac acpi acpi4linux alsa apic apm arts audiofile
avi berkdb bitmap-fonts browserplugin bzip2 cddb cdparanoia cdr cdrom codecs
crypt css cups curl dga dio disk-cache divx4linux djbfft doc dpms dts dvd dvdr
dvdread dxr3 eds encode exif fam fame fb ffmpeg foomaticdb fortran freetype gd
gdbm gif gimp glut gnuplot gpg gpm gstreamer gtk gtk2 gtkhtml icq imagemagick
imap imlib ipv6 irc irda jabber java javascript joystick jp2 jpeg jpeg2k kcal
kde koffice-plugin lcms libg++ libwww lirc live lm_sensors logitech-mouse
logrotate mad makecheck mbox md5sum mikmod mjpeg mmx mmx2 mmxext motif moznoirc
moznomail mozsvg mp3 mpeg mpeg4 mplayer ncurses net network nfsv4 nls
no-old-linux nocd nptl nptlonly nsplugin nvidia ogg oggvorbis openal openexr
opengl oss pam pdflib perl png posix ppds python qt quicktime readline real rtc
sblive sdl sndfile sox spamassassin speedo spell src sse ssl sysfs tcltk tcpd
tetex tiff transcode truetype truetype-fonts type1 type1-fonts unicode usb v4l
v4l2 vcd vcdimager vorbis xine xml2 xmms xosd xprint xv xvid zlib zvbi
linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL
Comment 2 Luis Medinas (RETIRED) gentoo-dev 2005-09-14 19:26:45 UTC
This version is hard masked. So it means that is an unstable version of
cdrtools. Its not ready to ~arch. This version closes a few bugs but it have a
few issues because it's an alpha release. Don't use it because it's broken.
Comment 3 Thomas Maguin 2005-09-15 00:11:29 UTC
Sorry, but burning as root is rossible and working flawlessly. So it is possibly
not a problem of cdrtools. It seems that is another chapter of the never ending
story "Linus has no cdrecorder".
Comment 4 Luis Medinas (RETIRED) gentoo-dev 2005-09-15 04:21:36 UTC
That version is unstable don't use it. Please use the stable version available
on x86 (2.01) or the testing version (2.01.01_alpha01).
I'm aware of this problems with this version and i'm trying to fix this problems
so don't USE this version atm.